Bug 485616 - apt-get fails
apt-get fails
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: apt (Show other bugs)
rawhide
i586 Linux
low Severity medium
: ---
: ---
Assigned To: Axel Thimm
Fedora Extras Quality Assurance
:
: 485614 487459 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-15 06:04 EST by Frank Murphy
Modified: 2009-07-31 13:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-26 04:09:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Frank Murphy 2009-02-15 06:04:57 EST
Description of problem: alt-get fails


Version-Release number of selected component (if applicable):
apt-debuginfo-0.5.15lorg3.95-0.git416.3.fc11.i386
apt-0.5.15lorg3.95-0.git416.3.fc11.i386
fedora-package-config-apt-10-3.noarch


How reproducible: always


Steps to Reproduce:
1. /usr/bin/apt-get update
2.
3.
  
Actual results:
sudo /usr/bin/apt-get update
Reading Package Lists... Done
apt-get: rpmds.c:518: rpmdsDupArgv: Assertion `argv[ac] != ((void *)0)' failed.
Aborted


Expected results: working apt-get (arg)


Additional info:
Comment 1 Panu Matilainen 2009-02-16 04:34:31 EST
*** Bug 485614 has been marked as a duplicate of this bug. ***
Comment 2 Panu Matilainen 2009-02-26 02:53:42 EST
*** Bug 487459 has been marked as a duplicate of this bug. ***
Comment 3 Panu Matilainen 2009-02-26 04:09:08 EST
The issue here is that apt uses rpmdsSingle() in a way that rpm itself (or nothing else that I'm aware of) does, second time getting caught by this :)
This should be resolved in rpm-4.6.0-10.fc11 in rawhide, please reopen if updating to that doesn't fix.
Comment 4 Eli Wapniarski 2009-02-26 06:44:59 EST
Did the trick in F-10. rpm built successfully in x86_64 and i386 and fixed the problem.

Note You need to log in before you can comment on or make changes to this bug.