This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 485751 - /etc/X11/prefdm should support falling back to SLiM
/etc/X11/prefdm should support falling back to SLiM
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 478821
  Show dependency treegraph
 
Reported: 2009-02-16 12:46 EST by Christoph Wickert
Modified: 2014-03-16 23:17 EDT (History)
5 users (show)

See Also:
Fixed In Version: 8.86.3-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-24 16:44:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Proposed Patch to configure slim via DISPLAYMANAGER on /etc/X11/prefdm (518 bytes, patch)
2009-03-05 11:37 EST, Jochen Schmitt
no flags Details | Diff

  None (edit)
Description Christoph Wickert 2009-02-16 12:46:13 EST
Description of problem:
I've had some users complaining that they don't get X after doing an install with base-x and lxde-desktop. This is because the lxde-desktop group only includes SLiM but but xdm, gdm or kdm.

Version-Release number of selected component (if applicable):
initscripts-8.86-1.i386

How reproducible:
always

Steps to Reproduce:
1. install Fedora 10 with base-x and lxde-desktop groups
2. reboot
  
Actual results:
No X, no firstboot

Expected results:
X should start up with firstboot

Additional info:

--- /etc/X11/prefdm.orig	2008-11-11 17:59:18.000000000 +0100
+++ /etc/X11/prefdm	2009-02-16 18:36:19.000000000 +0100
@@ -36,6 +36,7 @@
 # Fallbacks, in order
 exec gdm "$@" >/dev/null 2>&1 </dev/null
 exec kdm "$@" >/dev/null 2>&1 </dev/null
+exec slim-dynwm "$@" >/dev/null 2>&1 </dev/null
 exec wdm "$@" >/dev/null 2>&1 </dev/null
 exec xdm "$@" >/dev/null 2>&1 </dev/null
 # catch all exit error
Comment 1 Bill Nottingham 2009-02-16 14:13:06 EST
Meh. This cries out for something that can be modifed more sanely. Let me see if there's a better way out of this.
Comment 2 Christoph Wickert 2009-02-16 14:49:33 EST
(In reply to comment #1)
> Meh. This cries out for something that can be modifed more sanely.

Why that? If this is not sane, the others aren't sane ether. I guess the best would be the Xclients.d solution from bug #142260, but I have no idea how this is supposed to work.
Comment 3 Bill Nottingham 2009-02-16 15:00:59 EST
Well, the simple answer for LXDE is to write a /etc/sysconfig/desktop with DISPLAYMANAGER set somewhere. But I don't want to keep having to modify this file for every desktop that may possibly exist.
Comment 4 Christoph Wickert 2009-02-16 15:19:57 EST
I know about /etc/sysconfig/desktop, I'm happily using it in
http://cwickert.fedorapeople.org/lxde/fedora-livecd-lxde.ks

But how am I supposed to write/modify this file on a normal install (when not installing from the LXDE livecd)?
Comment 5 lexual 2009-03-03 19:51:53 EST
Doesn't gdm needed to be added to lxde-desktop group in comps.xml.
xfce-desktop & gnome-desktop both have it.
kde-desktop will install kdm.
Comment 6 Christoph Wickert 2009-03-04 03:40:38 EST
No, I'm not going add gdm to the lxde-group, because it will pull in gnome-session, gnome-control-center and many more. That's why I added slim and want prefdm to support it.
Comment 7 lexual 2009-03-04 06:25:18 EST
Why does gdm depend on gnome-session?
Comment 8 Christoph Wickert 2009-03-04 08:30:05 EST
Because the new GDM that was introduced in Fedora 8 runs in a Gnome session.
Comment 9 Jochen Schmitt 2009-03-05 11:37:34 EST
Created attachment 334152 [details]
Proposed Patch to configure slim via DISPLAYMANAGER on /etc/X11/prefdm

I wnat to propose, that it should be possible to use slim via setting DSPLAYMANAGER=SLIM in the /etc/X11/prefdm file.
Comment 10 Christoph Wickert 2009-03-05 12:34:40 EST
You can already make SLiM defdault in /etc/sysconfig/desktop, but does it really mela a difference if the file reads
DISPLAYMANAGER=SLIM or
DISPLAYMANAGER=/usr/bin/slim-dynwm

This still is no fallback and the file still needs to be configured manually. I'm looking for something that is working out of the box after a "yum groupinstall LXDE".
Comment 11 Bill Nottingham 2009-03-24 16:44:51 EDT
Well, that can't work now because you don't get SLIM with 'yum groupinstall lxde', at least not without extra flags or package selection.

Aside from that, fixed in http://git.fedorahosted.org/git/?p=initscripts.git;a=commitdiff;h=7fed044885fb2eeb92fe59cec649318caff7e382.
Comment 12 Fedora Update System 2009-04-02 14:04:20 EDT
initscripts-8.86.1-1 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/initscripts-8.86.1-1
Comment 13 Fedora Update System 2009-04-03 00:16:01 EDT
initscripts-8.86.2-1 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/initscripts-8.86.2-1
Comment 14 Fedora Update System 2009-04-22 16:22:31 EDT
initscripts-8.86.3-1 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.