Bug 478821 - Firstboot Problems rl5
Firstboot Problems rl5
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: lxde-common (Show other bugs)
10
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Christoph Wickert
Fedora Extras Quality Assurance
:
: 485738 (view as bug list)
Depends On: 142260 485751 485789
Blocks: LXDE
  Show dependency treegraph
 
Reported: 2009-01-05 06:57 EST by Frank Murphy
Modified: 2009-06-13 15:16 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-07 07:36:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
lxde tweaks (591 bytes, text/plain)
2009-01-05 06:57 EST, Frank Murphy
no flags Details

  None (edit)
Description Frank Murphy 2009-01-05 06:57:02 EST
Created attachment 328187 [details]
lxde tweaks

Description of problem: Will not go to firstboot(5) if only DE\WM installed.


Version-Release number of selected component (if applicable):


How reproducible: Fresh Install from F10-DVD (i386),
Check LXDE only in Desktop, Base, X etc.. to suit.


Steps to Reproduce:
1. Reboot when asked
2.
3.
  
Actual results: rl3 firstboot screen?


Expected results: rl5 firstboot screen


Additional info:
had to do the following tweaks: check attached test
(is there an easier way)
Comment 1 Christoph Wickert 2009-01-05 10:21:20 EST
Sorry Frank, I don't really understand what you are talking about. You are complaining that
1. the machine won't go into runlevel 5 after installation by default
2. firstboot is not run after installation
3. SLiM is not started automatically
4. LXDE does not start without configuring /etc/sysconfig/desktop previously.

Did I understand that correctly?

All these will be fixed in the LXDE-Spin I'm working on [1], but there is not much I can do in lxde-common because the package does not own the relevant files:
1. needs to be fixed in anaconda, because anaconda writes the inittab.
2. caused by 1.
3. needs to be fixed in initscripts, because they own etc/X11/prefdm.
4. LXDE should not be made default, but it should be detected and run automatically. Editing /etc/X11/xinit is strictly forbidden because everybody will get LXDE then. Your edit also prevents /etc/X11/xinit/Xclients from being executed.

The proper way is to add /etc/X11/xinit/Xclients.d/Xclients.lxde.sh as described in bug #142260. Also affects Xfce and _all_ other desktops/window-managers except of Gnome and KDE, because ATM none use /etc/X11/xinit/Xclients.d/.

[1] https://fedoraproject.org/wiki/Features/LXDESpin

P. S.: I know http://wiki.lxde.org/en/Fedora, because I wrote that page. ;)
Comment 2 Frank Murphy 2009-01-05 11:06:19 EST
You pretty much got it covered.
Look forward to the spin.

Frank
Comment 3 Christoph Wickert 2009-01-05 13:50:49 EST
Ok then. I will add /etc/X11/xinit/Xclients.d/Xclients.lxde.sh in the next release of lxde-common.

I will also ask for support of SLiM in the initscripts and eventually in anaconda. I'm going to cc you to the bugs I open. Thanks a lot for your comments so far.
Comment 4 Christoph Wickert 2009-02-16 11:51:37 EST
*** Bug 485738 has been marked as a duplicate of this bug. ***
Comment 5 Christoph Wickert 2009-04-07 07:36:01 EDT
Ok, all outstanding bugs are fixed and I've just made SLiM default in comps, so this should not happen any longer.

Note You need to log in before you can comment on or make changes to this bug.