Bug 485899 - Evolution crashes when hitting print button
Evolution crashes when hitting print button
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
: 487427 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-17 05:53 EST by Mike Chambers
Modified: 2009-02-25 18:03 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-17 18:18:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Chambers 2009-02-17 05:53:41 EST
Description of problem:Program crashes anytime print button is pushed


Version-Release number of selected component (if applicable):


How reproducible:Everytime


Steps to Reproduce:
1.Open evolution
2.highlight an email and preview or open it
3.click on print button
  
Actual results:program crashess




Expected results:program should remain open and print 


Additional info:This is bug buddy info from the crash...

Distribution: Fedora release 10.91 (Rawhide)
Gnome Release: 2.25.90 2009-02-03 (Red Hat, Inc)
BugBuddy Version: 2.25.2

System: Linux 2.6.29-0.119.rc5.fc11.i586 #1 SMP Sat Feb 14 18:38:24 EST 2009 i686
X Vendor: The X.Org Foundation
X Vendor Release: 10599902
Selinux: No
Accessibility: Disabled
GTK+ Theme: Nodoka
Icon Theme: Echo
GTK+ Modules: canberra-gtk-module, gnomebreakpad

Memory status: size: 0 vsize: 0 resident: 0 share: 0 rss: 0 rss_rlim: 0
CPU usage: start_time: 0 rtime: 0 utime: 0 stime: 0 cutime:0 cstime: 0 timeout: 0 it_real_value: 0 frequency: 0



----------- .xsession-errors (37 sec old) ---------------------
** (gnome-screensaver:2553): WARNING **: Unable to find watch for alarm
** (gnome-screensaver:2553): WARNING **: Unable to find watch for alarm
Xlib:  extension "XFree86-Misc" missing on display ":0.0".
** (evolution:4677): DEBUG: mailto URL command: evolution --component=mail %s
** (evolution:4677): DEBUG: mailto URL program: evolution
(evolution:4677): gtkhtml-WARNING **: oo
camel-Message: ++
camel-Message: --
** (evolution:5819): DEBUG: mailto URL command: evolution --component=mail %s
** (evolution:5819): DEBUG: mailto URL program: evolution
gnome-session[2394]: WARNING: Unable to find watch for alarm 12582923
gnome-session[2394]: WARNING: Unable to find watch for alarm 12582924
--------------------------------------------------
Comment 1 Milan Crha 2009-02-17 07:06:18 EST
Strange, it doesn't crash to me. Can you paste here a backtrace of the crash (with debug info packages for evolution, evolution-data-server, gtkhtml3 installed), please?

The only change I remember is from the upstream bug [1], but it crashed in a preview pane immediately, and it is included in a rawhide build too, thus it is probably something else.

[1] http://bugzilla.gnome.org/show_bug.cgi?id=561628
Comment 2 Mike Chambers 2009-02-17 18:18:18 EST
Ok that's strange.  After today's updates, it's not crashing now *shrug*.  I had just installed the debuginfo packages after the updates  and tried but no crash.  So will close for now and reopen if it turns up again.
Comment 3 Milan Crha 2009-02-24 14:34:08 EST
I just tried and it also doesn't want to crash to me with 2.24.4. Feel free to reopen with back trace, when/whether it comes back.
Comment 4 Matthew Barnes 2009-02-24 14:56:04 EST
Don't suppose you also upgraded gtk2 or cups in the interim.  That's the only thing I can think of to explain why you're not seeing it now.
Comment 5 Matthew Barnes 2009-02-25 18:03:17 EST
*** Bug 487427 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.