Bug 486024 - i8042 unbind required for keyboard/mouse to be useable following hibernate/resume cycle on Dell D630
i8042 unbind required for keyboard/mouse to be useable following hibernate/re...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: John Feeney
desktop-bugs@redhat.com
: Patch
Depends On: 450326
Blocks: 502912 533192 600363
  Show dependency treegraph
 
Reported: 2009-02-17 17:12 EST by ritz
Modified: 2013-01-10 02:58 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-25 09:17:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch based on upstream code (10.11 KB, patch)
2009-02-27 02:39 EST, ritz
no flags Details | Diff

  None (edit)
Description ritz 2009-02-17 17:12:15 EST
Description of problem:
hibernate key (Fn+F1) stops working following hibernate/resume cycle

Version-Release number of selected component (if applicable):
kernel-2.6.18-128.el5

How reproducible:
always

Steps to Reproduce:
1. Boot
2. Hibernate using Fn+F1
3. Resume
4. Try to hibernate using Fn+F1
  
Actual results:
Does not hibernate following hibernate/resume cycle

Expected results:
Should hibernate

Additional info:
Workaround
echo -n "i8042" > /sys/bus/platform/drivers/i8042/unbind
echo -n "i8042" > /sys/bus/platform/drivers/i8042/bind


Possibly -
http://git.kernel.org/gitweb.cgi?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=82dd9eff4bf3b17f5f511ae931a1f350c36ca9eb

http://git.kernel.org/gitweb.cgi?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=a1cec06177386ecc320af643de11cfa77e8945bd
Comment 1 Matthew Garrett 2009-02-21 07:58:50 EST
I'm pretty sure this is a kernel bug - why did it get reassigned?
Comment 3 ritz 2009-02-22 23:51:51 EST
seems to be

Input: atkbd - properly handle special keys on Dell Latitudes
Giel de Nijs [Fri, 2 Nov 2007 13:08:02 +0000 (09:08 -0400)]
Most of Fn+F? special keys on (at least) the Dell Latitude laptops don't
generate a hardware key release event so the driver has to generate one.

http://git.kernel.org/gitweb.cgi?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff;h=554101e3e5f396b987c846332863a3fcdc87b1d6#patch1



Input: atkbd - expand Latitude's force release quirk to other Dells
Dell laptops fail to send key up events for several of their special
keys. There's an existing quirk in the kernel to handle this, but it's
limited to the Latitude range. This patch extends it to cover all
portable Dells.

http://git.kernel.org/gitweb.cgi?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=61579ba83934d397a4fa2bb7372de9ae112587d5




Possibly


Input: atkbd - mark keyboard as disabled when suspending/unloading
This will shut off garbage that may come from KBD port during resume.

http://git.kernel.org/gitweb.cgi?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=57f5b1590f2d801a3a7f072e2c65f14d4545852c

-- ritz
Comment 4 ritz 2009-02-23 13:31:50 EST
oh ! added patch required for dmi 

The patch below adds DMI/SMBIOS based module autoloading to the Linux
kernel. The idea is to load laptop drivers automatically (and other
drivers which cannot be autoloaded otherwise), based on the DMI system
identification information of the BIOS.

(Update to dmi_scan.c, and dmi.h needed)
http://git.kernel.org/gitweb.cgi?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff;h=4f5c791a850e5305a5b1b48d0e4b4de248dc96f9


x86: left over fix for leak of early_ioremp in dmi_scan
http://git.kernel.org/gitweb.cgi?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff;h=3212bff370c2f22e4987c6679ba485654cefb178


-- ritz
Comment 5 Issue Tracker 2009-02-23 13:36:54 EST
_TEST_ kernel can be picked up from
http://people.redhat.com/rkhadgar/work/bz486024/

-- ritz


This event sent from IssueTracker by rkhadgar 
 issue 179416
Comment 6 ritz 2009-02-27 02:39:20 EST
Created attachment 333439 [details]
patch based on upstream code
Comment 9 John Feeney 2010-06-30 10:26:29 EDT
My apologies to all who have been waiting on this. I'll have a kernel to test shortly. Thanks go to ritz for providing the patch.
Comment 11 John Feeney 2010-08-05 14:14:41 EDT
Any chance anyone with appropriate hardware could test the rpms I made? See  http://people.redhat.com/jfeeney/.bz486024

Much appreciated.
  John
Comment 12 John Feeney 2010-08-09 18:32:15 EDT
I'm afraid that this patch can't be posted or won't be accepted in rhel5.6 if there is no testing done. Could someone please provide some testing feedback. 
 Thanks. 
   John

Note You need to log in before you can comment on or make changes to this bug.