This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 450326 - hal/ Fixing non-mapped vendor buttons
hal/ Fixing non-mapped vendor buttons
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: hal (Show other bugs)
5.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Richard Hughes
desktop-bugs@redhat.com
:
Depends On: 490507
Blocks: 445871 447321 486024
  Show dependency treegraph
 
Reported: 2008-06-06 13:34 EDT by ritz
Modified: 2010-03-30 04:32 EDT (History)
9 users (show)

See Also:
Fixed In Version: hal-0.5.8.1-36
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-30 04:32:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
update spec for BuildRequire (1.02 KB, patch)
2008-06-06 13:34 EDT, ritz
no flags Details | Diff
patch hal to support keymapping (11.57 KB, patch)
2008-06-06 13:39 EDT, ritz
no flags Details | Diff

  None (edit)
Description ritz 2008-06-06 13:34:09 EDT
Description of problem:
The Dell Latitude has a hotkey Fn+F1 to suspend. This doesn't work.

How reproducible:
always

Steps to Reproduce:
Press Fn+F1

Actual results:
nothing happens
On Text Console you see the following messages:
atkbd.c: Unknown key pressed (translated set 2, code 0x8d on isa0060/serio0).
atkbd.c: Use 'setkeycodes e00d <keycode>' to make it known.

Expected results:
Machine should go to suspend mode

Additional info:
I have backported keyboard quirk from upstream, patch attached. Additionally,
user would need to induce fdi for dell keyboard mapping[1].

[1]
http://gitweb.freedesktop.org/?p=hal-info.git;a=blob_plain;f=fdi/information/10freedesktop/30-keymap-dell.fdi
Comment 1 ritz 2008-06-06 13:34:09 EDT
Created attachment 308549 [details]
update spec for BuildRequire
Comment 2 ritz 2008-06-06 13:39:12 EDT
Created attachment 308550 [details]
patch hal to support keymapping 

this patch updates hal to support key mapping. 

add originating_device property to input device to enable matching keyboard
mapping rules against atkbd.

installs hal-setup-keymap which maps keymapping.

finally, install rules for handling keymapping.
Comment 3 Richard Hughes 2008-07-14 12:01:37 EDT
Nice one Ritesh, I was going to do this tomorrow! I'm going to pull all the
30-keymap-* files into hal also, as hopefully the thinkpad bits can be pulled in
also.

+1 from me.
Comment 4 John Feeney 2008-07-24 13:23:22 EDT
Ritesh,
I was wondering if you could provide x86_64 hal rpms similar to i386 ones you
provided on your people page. Thanks if you can. In case you were wondering,
I would like to test them on a laptop that only supports x86_64.
Comment 5 ritz 2008-07-25 13:13:35 EDT
_TEST_ packages uploaded to http://people.redhat.com/rkhadgar/work/bz45036/

-- ritz
Comment 7 Cameron Meadors 2009-03-18 12:41:44 EDT
This looks like it would affect *many* if not all laptops.  Is this a new feature (that laptop keyboards work)?  Is there a specific set of laptops that the keymapping was broken and is now fixed by this change?
Comment 25 errata-xmlrpc 2010-03-30 04:32:36 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2010-0256.html

Note You need to log in before you can comment on or make changes to this bug.