Bug 486143 - Kernel panic with on Medion Akyoa E1210 netbook
Kernel panic with on Medion Akyoa E1210 netbook
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i586 Linux
high Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-18 11:39 EST by Phil Knirsch
Modified: 2015-03-04 20:20 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-10 23:18:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sos report produced with latest running i686 rawhide kernel. (651.95 KB, application/x-tar)
2009-02-18 11:48 EST, Phil Knirsch
no flags Details
Screenshot kernel oops (1.11 MB, image/jpeg)
2009-03-02 06:18 EST, Phil Knirsch
no flags Details

  None (edit)
Description Phil Knirsch 2009-02-18 11:39:12 EST
Description of problem:

Since the switch to i586 kernels in Fedora rawhide i've been reproducibly getting kernel panics with them.

So far i've tried 2 different i586 kernels all of which panic during boot with similar results (didn't have serial console, so typed it from screen hopefully with no mistakes):

[<c0413337>] ? do_flush_tlb_all+0x0/0x37
[<c044c68e>] ? mark_held_locks+0x53/0x6a
[<c0413337>] ? do_flush_tlb_all+0x0/0x37
[<c04522a5>] ? smp_call_function+0x1a/0x1e
[<c0432423>] ? on_each_cpu+0xf/0x3a
[<c0413302>] ? flush_tlb_all+0x14/0x16
[<c041be7d>] ? __change_page_attr_set_clr+0x526/0x603
[<c049428a>] ? vm_unmap_aliases+0x155/0x15e
[<c053a3d0>] ? _raw_spin_unlock+0x74/0x78
[<c041c07e>] ? change_page_attr_set_clr+0x124/0x2cb
[<c041c274>] ? set_memory_ro+0x19/0x1b
[<c041c28c>] ? set_pages_ro+0x16/0x18
[<c041af61>] ? mark_rodata_ro+0x3f/0x8d
[<c040129a>] ? init_post+0x17/0xd5
[<c09593d9>] ? kernel_init+0x1ca/0x1d4
[<c095920f>] ? kernel_init+0x0/0x1d4
[<c0404577>] ? kernel_thread_helper+0x7/0x10
Code: 00 00 00 00 8d bc 27 00 00 00 00 6a 00 68 78 49 40 c0 e9 94 45 2d 00 8d 74 26 00 6a 00 68 65 4e 40 c0 e9 84 45 2d 00 8d 74 26 00 <6a> ff 68 fc 8c 6d c0 e9 74 45 2d 00 8d 74 26 00 cf eb 0d 90 90
EIP: [<c0404490>] device_not_available0x0/0x10 SS:ESP 0068:f6c41e74
---[ end trace e4c07c7b7e518a8a ]---
swapper used greatest stack depth: 1028 bytes left
Kernel panic - not syncing: Attempted to kill init!


Version-Release number of selected component (if applicable):

kernel-2.6.29-0.119.rc5.fc11.i586

(and kernel-2.6.29-0.99.rc4.fc11.i586 before)

How reproducible:

Always

Steps to Reproduce:
1. Install rawhide on a Medion Akoya E1210
2. Try to boot
3. Kernel panic
  
Actual results:

Kernel panic

Expected results:

No kernel panic. ;)

Additional info:

I'll attach a sosreport to this bz, should contain all hw and other info. The machine itself is an Atom 270 based netbook.

In case you want me to produce some kernel dump or similar just let me know.
Comment 1 Phil Knirsch 2009-02-18 11:48:36 EST
Created attachment 332414 [details]
sos report produced with latest running i686 rawhide kernel.
Comment 2 Phil Knirsch 2009-02-19 10:50:05 EST
Just tested it with todays kernel and it works now:

kernel-2.6.29-0.131.rc5.git2.fc11.i586

Closing it for now, will reopen in case it reappears.

Thanks & regards, Phil
Comment 3 Phil Knirsch 2009-02-27 12:12:29 EST
Ok, false alarm, bug still happens quite frequently, just had 1 lucky boot with the kernel mentioned above.

Happens with latest kernels as well. I'll try using the nosetmode kernel option during boot as it seems to happen right before that.

Will update the bz as soon as i've tested it.

Regards, Phil
Comment 4 Chuck Ebbert 2009-02-27 18:48:55 EST
Can you get it to boot with vga=791 so you can see the first part of the oops message?

Looks very similar to bug 485695...
Comment 5 Phil Knirsch 2009-03-02 06:17:58 EST
OK, finally got it again with vga=6 and got a full screenshot of it now with the latest kernel (2.6.29-0.176.rc6.git5.fc11.i586) and attached a photo of it. I hope you don't need a text version of it :/.

Hope this helps.

I've also tried the 2.6.29-PAE-0.176.rc6.git5.fc11.i686 and that one boots without any problems.

Thanks & regards, Phil
Comment 6 Phil Knirsch 2009-03-02 06:18:46 EST
Created attachment 333725 [details]
Screenshot kernel oops
Comment 7 Kyle McMartin 2009-03-11 16:46:01 EDT
This should be fixed by 2.6.29-0.235.rc7.git4.
Comment 8 Phil Knirsch 2009-03-12 12:05:19 EDT
I'll give it a shot tonight when i get home and post an update here.

Thanks & regards, Phil
Comment 9 Phil Knirsch 2009-03-13 07:08:02 EDT
Yay it works! Did 10 reboots yesterday with the 2.6.29-0.237 and it worked like a charm.

Thanks for the fix, this bug can be closed.

Regards, Phil

Note You need to log in before you can comment on or make changes to this bug.