Bug 486167 - button for mute sound doesn't work, lenovo t500
button for mute sound doesn't work, lenovo t500
Status: CLOSED DUPLICATE of bug 475247
Product: Fedora
Classification: Fedora
Component: acpid (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Zdenek Prikryl
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-18 13:04 EST by Petr Sklenar
Modified: 2009-04-07 03:28 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-07 03:28:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Sklenar 2009-02-18 13:04:31 EST
Description of problem:
on nb lenovo t500 button for mute sound doesn't work

Version-Release number of selected component (if applicable):
acpid-1.0.8-2.fc11.x86_64

How reproducible:
always

Steps to Reproduce:
1.click mute
2.
3.
  
Actual results:
nothing

Expected results:
mute

Additional info:
System > Keyboard shortcut:
XF86AudioMute is not mute button
Comment 1 Zdenek Prikryl 2009-03-18 04:26:24 EDT
If the sound control isn't implemented directly in HW, you have to set the functionality at SW level. It means that you set sound volume/mute either via keyboard shortcuts or via apcid script. If you want to use acpid, the button has to generate acpi events. You can get then if you start acpid in debug mode ($ acpid -d). After you get the acpi event code, you have to write your own script. "How to" is in the documentation or take a look at working scripts /etc/acpi/*.

Anyway, this isn't bug in acpid, so I'm closing it.
Comment 2 Petr Sklenar 2009-03-18 05:16:27 EDT
I would guess that lenovo t500 is widely spread laptop among people, so it is pity that mute button does NOT work right now after normal installation.

That's not solution to write my own scripts for biggest button on keyboard from end-user's point of view.

For what component is this bug?
please change component.

bye petr :)
Comment 3 Zdenek Prikryl 2009-03-18 06:40:49 EDT
acpid package cannot contain this specific scripts. Every vendor has own acpi codes, so there would be a lot of scripts and only a few would be relevant for your laptop. What desktop environment do you have? Are up/down sound buttons implemented in HW or there is some SW which takes case of handling sound volume?
Comment 4 Petr Sklenar 2009-03-23 05:13:00 EDT
> Every vendor has own acpi codes, so there would be a lot of scripts and only a > few would be relevant for your laptop. 
don't care me but planty users with that lenovo t500 , I have t61 and it works there :)

> What desktop environment do you have?
It was at gnome env. Installation  was default (next>next>next) from latest fedora built, date 2009-02-18


> Are up/down sound buttons implemented in HW or there is some SW which takes
> case of handling sound volume?  
up/down works well, I don't know if there is SW|HW switch, I only now that mute button on lenovo t500 doesn't work.

........

L t500 smolt profile:
http://www.smolts.org/client/show/pub_ea607391-3e59-49f6-8a33-a9581bc5743c
Comment 5 Zdenek Prikryl 2009-03-25 04:27:30 EDT
(In reply to comment #4)
> > Every vendor has own acpi codes, so there would be a lot of scripts and only > > a few would be relevant for your laptop. 
> don't care me but planty users with that lenovo t500 , I have t61 and it works
> there :)

Again, t61 has HW implementation of the sound control, so on t61 buttons work out of the box without and SW requirements. In the case of t500 the situation can be different.

> > What desktop environment do you have?
> It was at gnome env. Installation  was default (next>next>next) from latest
> fedora built, date 2009-02-18

Have this installation sets any key-bindings for up/down buttons? Can you see a gnome related window with progress bar if you push a up/down sound button?

> > Are up/down sound buttons implemented in HW or there is some SW which takes
> > case of handling sound volume?  
> up/down works well, I don't know if there is SW|HW switch, I only now that mute
> button on lenovo t500 doesn't work.

As I wrote in the comment #1. Run acpid in the debug mode ($ acpid -d) and push the mute/up/down button. In the output you can see what acpi codes are generated. Then the output from debug mode past here.
Comment 6 Petr Sklenar 2009-04-06 09:44:56 EDT
>Have this installation sets any key-bindings for up/down buttons? Can you see a
>gnome related window with progress bar if you push a up/down sound button?

Yes I saw progress bar for up/down, key-bindings was set for that.

> As I wrote in the comment #1. Run acpid in the debug mode ($ acpid -d) and push
> the mute/up/down button. In the output you can see what acpi codes are
> generated. Then the output from debug mode past here.  

I haven't that machine now, ask your area-helpdesk for t500.
Comment 7 Zdenek Prikryl 2009-04-07 03:28:47 EDT
Seems that this issue is already reported...

*** This bug has been marked as a duplicate of bug 475247 ***

Note You need to log in before you can comment on or make changes to this bug.