Bug 475247 - qt/kdelibs: some multimedia keys not supported
qt/kdelibs: some multimedia keys not supported
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
rawhide
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
: Reopened
: 486167 502702 509296 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-08 12:13 EST by Julian G
Modified: 2009-11-25 10:14 EST (History)
21 users (show)

See Also:
Fixed In Version: 4.3.3-7.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-20 17:00:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
lshal (134.00 KB, text/plain)
2008-12-08 13:32 EST, Julian G
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 182672 None None None Never

  None (edit)
Description Julian G 2008-12-08 12:13:48 EST
Description of problem:
I've got a Thinkpad T500 and installed Fedora 10 KDE Live i686 with all updates. The mute button seems to work (without grafical feedback) but volume and brightness control buttons do nothing. Not even the volume bar appears.

Before I've used Kubuntu 8.10 and both did fine.
Comment 1 Kevin Fenzi 2008-12-08 12:42:05 EST
Are you using tpb? If so, you should not be...its old and depreciated. 
KDE should handle things natively. 

Let me figure out which KDE component handles this and get your bug moved to get attention. 

Thanks.
Comment 2 Rex Dieter 2008-12-08 12:43:31 EST
Wait, brightness should be handled automagically at the hal level, no?

hal-info is probably the way to go here (which contains the keycode to event mappings).
Comment 3 Julian G 2008-12-08 13:32:15 EST
Created attachment 326159 [details]
lshal
Comment 4 Julian G 2008-12-08 13:33:16 EST
I've used tpb just for testing because KDE shows me anything at all. KDE 3.5 had an extra section for thinkpads within the system settings but there seems to be nothing left.

The guidance power manager sets brightness according to AC or battery correctly, so something must work.

Attached lshal output (as root).
Comment 5 Rex Dieter 2008-12-08 13:46:33 EST
afaik, these keymapping->events happens at a level lower than kde.

For example, I can switch to a vt, and brightness keys work there too.

Hopefully, the hal-info folks can chime in with some helpful advice.
Comment 6 Julian G 2008-12-29 13:38:04 EST
any news? this is really a show stopper. i've tested fedora 10 kde live i686 on my girlfriends thinkpad r60 and it isn't working either.
Comment 7 Julian G 2008-12-29 19:03:08 EST
now i've tried fedora 10 gnome live i686 on thinkpad t500 and everything is doing fine. it seems to me to be a problem on the kde4-hal-interface.
Comment 8 Rex Dieter 2008-12-29 19:11:08 EST
KDE4 has never had keybindings for volume control (we're working upstream to correct that asap).  

In the meantime, I still assert that brightness control is (should be!) DE-agnostic.
Comment 9 Julian G 2009-01-27 04:48:37 EST
Is there a workaround available? What can I do to get things working? Is anyone interested in getting paid for fixing that?
Comment 10 Richard Hughes 2009-01-29 03:18:51 EST
(In reply to comment #9)
> In the meantime, I still assert that brightness control is (should be!)
> DE-agnostic.

Well, we have to use X in the session, and the user has preferences (for inctance the auto-dim threshold) that need getting from the session.

THB, you just need to listen for the X keys now, everything is going through evdev these days.
Comment 11 Rex Dieter 2009-01-29 08:49:59 EST
Thanks Richard, I think now it is a qt issue (from speaking with an upstream qt/kde developer)... it seems qt doesn't currently grok brightness key events.
Comment 12 Caio 2009-01-30 19:40:20 EST
I have a Dell Vostro 1400 and I have the same problem with fedora 10.
Until fedora 9 everything was fine.
Now I can't bind fn+brightness keys
I get an error saying QT doesn't recognize the key. But other fn+key combinations work fine.
Comment 13 Julian G 2009-02-14 13:30:00 EST
since the update to kde 4.2 volume keys are fine, but kde doesn't show an OSD information if i press the mute button.

brightness keys still don't work.
Comment 14 brendan 2009-03-14 11:54:54 EDT
I also have a Dell Vostro 1400 and can report the exact same behaviour.  The multimedia keys are recognized just fine, but not the brightness keys.

In the KDE Global Keyboard Shortcuts config for guidance-power-manager (which controls brightness now it seems) if I try to set the right keys for Brightness Up and Down, I get the following error : "the key you just pressed isn't supported by qt"

The keycodes are:
Up : 233
Down : 232
Comment 15 Serguei Miridonov 2009-03-20 14:33:01 EDT
I can confirm this with HP Pavilion dv5t:

keycode 233 (keysym 0x1008ff02, XF86MonBrightnessUp)
keycode 232 (keysym 0x1008ff03, XF86MonBrightnessDown)

BTW, there are two power managers which may change brightness and notebook behavior: Guidance Power Manager and Power Management - KDE Control Module. Is that normal? 

Power Management - KDE Control Module is more flexible and it may be tuned to change brightness on its own, for example, when the battery is short of charge, or when the notebook is idle for some time. However, it does not have hot keys to change brightness on user request.

Guidance Power Manager has these hotkeys but it is much less flexible in regard of various power profiles.
Comment 16 Nicolas 2009-03-29 12:36:42 EDT
I can also report a similar behaviour on a Thinkpad x300...

Fedora 10 with KDE 4.2.1 will not recognize the Fn+Fxx buttons, thought they appear correctly mapped with the expected XF86 codes... and xev shows the inputs captured as well.
When trying to assign the key *manually* in KDE - System Settings -> Global Keyboard Shortcuts, I get the error:
"The key you just pressed isn't supported by Qt"
These keys are working as expected on the same hardware with GNOME (either with Fedora 10 or Ubuntu 8.10)
  
# lshal|grep system.kernel
  system.kernel.machine = 'x86_64'  (string)
  system.kernel.name = 'Linux'  (string)
  system.kernel.version = '2.6.27.19-170.2.35.fc10.x86_64'  (string)
# lshal|grep system.hardware
  system.hardware.product = '647815G'  (string)
  system.hardware.vendor = 'LENOVO'  (string)
  system.hardware.version = 'ThinkPad X300'  (string)
# xmodmap -pk|grep XF86MonBrightness
    232         0x1008ff03 (XF86MonBrightnessDown)   (...)
    233         0x1008ff02 (XF86MonBrightnessUp)     (...)
Comment 17 Zdenek Prikryl 2009-04-07 03:28:47 EDT
*** Bug 486167 has been marked as a duplicate of this bug. ***
Comment 18 Steven M. Parrish 2009-04-27 20:11:20 EDT
Upstream is aware of this issue, however we have no ETA on a fix.  Watch this space for updates.
Comment 19 Julian G 2009-04-27 20:27:05 EDT
Who is upstream? Qt?
Comment 20 Steven M. Parrish 2009-05-14 20:09:06 EDT
Yes its Qt/Trolltech
Comment 21 Steven M. Parrish 2009-05-26 09:05:30 EDT
Going to close this as UPSTREAM.  Since there is little the KDE-SIG can do about this and other multimedia/laptop button issues we have to wait for upstream to address this.
Comment 22 Serguei Miridonov 2009-05-26 10:21:11 EDT
Just to make things clear... I don't like when submitted and confirmed bugs end like this. It just means that this system designed to fix bugs does'n work.

This bug still exists and, though not critically, reduces some functionality of a laptop. It is important because it relates to power managament which is important on laptops.

Now, you are closing this bug but we would like to know exactly, what have you done? Have you submitted a patch for Qt? Have you received any answer from them? Qt is open source now, so you could fix it yourself instead of closing it.

What's going on here? Why keep bugzilla running if it does not work even with this, I think, trivial bug?
Comment 23 Julian G 2009-05-26 18:24:27 EDT
at least i'd like to know the url of this bug in the qt bugtracker.
Comment 24 Rex Dieter 2009-05-26 22:23:17 EDT
*** Bug 502702 has been marked as a duplicate of this bug. ***
Comment 25 humufr 2009-07-11 04:50:41 EDT
First this bug is still present on F11. The workaround with keyboard and guidance-power-manager doesn't work anymore because there are no guidance-power-manager option in the keyboard shortcut. 
Second this bug doesn't exist on kubuntu. There are others and multiple bug on this distribution so it's why I was trying to migrate to F11 but as usual KDE is a second zone citizen too bad.
Comment 26 Mark van Rossum 2009-07-27 13:06:58 EDT
Work around on t61p:

chmod a+rw /proc/acpi/ibm/cmos

~/.xbindkeysrc:
(xbindkey '(XF86MonBrightnessUp) "echo 4 > /proc/acpi/ibm/cmos") 
 m:0x0 + c:233
(xbindkey '(XF86MonBrightnessDown) "echo 5 > /proc/acpi/ibm/cmos") 
 m:0x0 + c:232

run xbindkeys to activate the settings.
Comment 27 Rex Dieter 2009-08-15 13:31:32 EDT
updating upstream bug #, as well as relevant trolltech report,
http://qt.nokia.com/developer/task-tracker/index_html?method=entry&id=230168
Comment 28 Rex Dieter 2009-08-15 13:35:17 EDT
As well as launchpad tracker,
https://bugs.launchpad.net/fedora/+bug/293213

Mandriva, has some patches as well,
http://svn.mandriva.com/cgi-bin/viewvc.cgi/packages/updates/2009.1/qt4/current/SOURCES/qt-4.5.2-xorg-special-keys.patch

Sheesh, what a mess. :(

OK, re-opening here, and I'll see if I can make some sense from all the separate attempts to tackle this for us.
Comment 29 Rex Dieter 2009-08-15 14:06:09 EDT
hooray for helio for getting things upstreamed,
http://qt.gitorious.org/+kde-developers/qt/kde-qt/commits/patches/0288-more-x-keycodes
Comment 30 Rex Dieter 2009-08-15 16:21:16 EDT
OK, seems to work like a charm.

%changelog
* Sat Aug 18 2009 Rex Dieter <rdieter@fedoraproject.org> 4.5.2-7
- kde-qt: 287-qmenu-respect-minwidth
- kde-qt: 0288-more-x-keycodes (#475247)

built for rawhide, will (likely) be included in next qt refresh for F-10/F-11 as well, provided there are no objections from our fellow qt maintainers.

Now, powerdevil (and friends) need some keyboard shortcuts, leaving that for upstream kde.
Comment 31 Kevin Kofler 2009-08-15 19:34:42 EDT
No objections here, bug fixing is a good thing!
Comment 32 Fedora Update System 2009-08-17 17:53:13 EDT
qt-4.5.2-1.fc10.2 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update qt'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-8398
Comment 33 Fedora Update System 2009-08-17 18:03:55 EDT
qt-4.5.2-1.fc11.2 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update qt'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-8406
Comment 34 Julian G 2009-08-18 07:04:14 EDT
Still the same behavior on Thinkpad T500 using Fedora 10 i686.
Comment 35 Fedora Update System 2009-08-18 09:47:28 EDT
qt-4.5.2-2.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/qt-4.5.2-2.fc11
Comment 36 Fedora Update System 2009-08-18 09:52:54 EDT
qt-4.5.2-2.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/qt-4.5.2-2.fc10
Comment 37 Rex Dieter 2009-08-18 12:38:12 EDT
Julian, the keybindings may well still be lacking, but you should be able to at least assign the keys now, ie, you shouldn't get the "Qt doesn't recognize the key" type errors.
Comment 38 brendan 2009-08-18 13:02:54 EDT
I can confirm the same old behavior on a dell vostro 1400 using fully updated F11 and KDE -- including the updates-testing packages.
Comment 39 Rex Dieter 2009-08-18 13:10:29 EDT
what exactly is "old behavior"?

media keys not working by default?
media keys not assignable?
working?

and, while we're at it, declare precisely what you're testing,
rpm -q qt kdelibs
please.

Now, for *me* using qt-4.5.2-1.2 and newer, I can now at least assign brightness keys, whereas I previously saw "Qt doesn't recognize the key".
Comment 40 brendan 2009-08-18 13:16:11 EDT
Old behavior as in I still get the "Qt does not recognize the key" error when attempting to set the brightness keys.

rpm -q qt kdelibs
qt-4.5.2-1.fc11.1.x86_64
qt-4.5.2-1.fc11.1.i586
kdelibs-4.2.4-6.fc11.x86_64
Comment 41 Rex Dieter 2009-08-18 13:22:06 EDT
The fix went in qt-4.5.2-1.2 and later (you're testing 4.5.2-1.1)
Comment 42 brendan 2009-08-18 13:41:38 EDT
My mistake, I thought I had updated properly yesterday from the updates-testing repo.  I can now assign the keys just fine in the KDE system settings.  However, the keys do not appear to have any effect after they are assigned.  And kde settings does remember the assignments. Possibly a bug for kde/guidance-power-manager?
Comment 43 Rex Dieter 2009-08-18 13:45:27 EDT
Possibly, but that's a separate issue.
Comment 44 Julian G 2009-08-18 18:53:09 EDT
I'm able to set the keys for guidance-power-manager (which is removed on my system in favor of powerdevil). Maybe I missed it but i can't find the place to set brightness keys for powerdevil.
Comment 45 Rex Dieter 2009-08-18 19:21:59 EDT
yeah, that's what I implied by comment #37 about keybindings missing.  Powerdevil in particular has none currently.
Comment 46 Kevin Kofler 2009-08-19 15:03:40 EDT
*** Bug 518288 has been marked as a duplicate of this bug. ***
Comment 47 Fedora Update System 2009-08-20 17:00:26 EDT
qt-4.5.2-2.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 48 Fedora Update System 2009-08-20 17:01:09 EDT
qt-4.5.2-2.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 49 Rex Dieter 2009-09-12 19:59:42 EDT
*** Bug 509295 has been marked as a duplicate of this bug. ***
Comment 50 Rex Dieter 2009-09-12 20:00:55 EDT
*** Bug 509296 has been marked as a duplicate of this bug. ***
Comment 51 M. Hagoort 2009-09-13 10:02:45 EDT
https://bugzilla.redhat.com/show_bug.cgi?id=518288
Still not working in qt-4.5.2-3
Comment 52 Rex Dieter 2009-09-13 10:13:36 EDT
that bug isn't about multimedia keys, prob shouldn't be dup'd to this.
Comment 53 Fedora Update System 2009-11-25 09:55:40 EST
kdebase-workspace-4.3.3-7.fc10, kdelibs-4.3.3-4.fc10, kdebase-runtime-4.3.3-5.fc10, kdeaccessibility-4.3.3-1.fc10, kdeadmin-4.3.3-1.fc10, kdeartwork-4.3.3-1.fc10, kdebase-4.3.3-3.fc10, kdeedu-4.3.3-1.fc10, kdegames-4.3.3-2.fc10, kdegraphics-4.3.3-1.fc10, kdelibs-experimental-4.3.3-1.fc10, kdemultimedia-4.3.3-1.fc10, kdenetwork-4.3.3-4.fc10, kdepim-4.3.3-1.fc10, kdepim-runtime-4.3.3-1.fc10, kdepimlibs-4.3.3-1.fc10, kdeplasma-addons-4.3.3-1.fc10, kdesdk-4.3.3-1.fc10, kdetoys-4.3.3-1.fc10, kdeutils-4.3.3-1.fc10, konq-plugins-4.3.3-2.fc10, oxygen-icon-theme-4.3.3-1.fc10, qscintilla-2.4-7.fc10, webkitkde-0.0.2-0.1.20091109svn.fc10, kde-l10n-4.3.3-1.fc10, sip-4.9.3-1.fc10, PyKDE-3.16.6-1.fc10, PyQt4-4.6.2-1.fc10, qzion-0.4.0-5.fc10, qedje-0.4.0-4.fc10, PyQwt-5.2.0-2.fc10, PyQt-3.18.1-5.fc10, kdebindings-4.3.3-4.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 54 Fedora Update System 2009-11-25 10:06:20 EST
kdebase-workspace-4.3.3-7.fc11, kdelibs-4.3.3-4.fc11, kdebase-runtime-4.3.3-5.fc11, kdeaccessibility-4.3.3-1.fc11, kdeadmin-4.3.3-1.fc11, kdeartwork-4.3.3-1.fc11, kdebase-4.3.3-3.fc11, kdeedu-4.3.3-1.fc11, kdegames-4.3.3-2.fc11, kdegraphics-4.3.3-1.fc11, kdelibs-experimental-4.3.3-1.fc11, kdemultimedia-4.3.3-1.fc11, kdenetwork-4.3.3-4.fc11, kdepim-4.3.3-1.fc11, kdepim-runtime-4.3.3-1.fc11, kdepimlibs-4.3.3-1.fc11, kdeplasma-addons-4.3.3-1.fc11, kdesdk-4.3.3-1.fc11, kdetoys-4.3.3-1.fc11, kdeutils-4.3.3-1.fc11, konq-plugins-4.3.3-2.fc11, oxygen-icon-theme-4.3.3-1.fc11, qscintilla-2.4-7.fc11, webkitkde-0.0.2-0.1.20091109svn.fc11, sip-4.9.3-1.fc11, kde-l10n-4.3.3-1.fc11, PyKDE-3.16.6-1.fc11, PyQt4-4.6.2-1.fc11, qzion-0.4.0-5.fc11, qedje-0.4.0-4.fc11, PyQwt-5.2.0-2.fc11, PyQt-3.18.1-5.fc11, kdebindings-4.3.3-4.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 55 Fedora Update System 2009-11-25 10:14:24 EST
kdebase-workspace-4.3.3-7.fc12, kdelibs-4.3.3-4.fc12, kdebase-runtime-4.3.3-5.fc12, kde-l10n-4.3.3-1.fc12, kdeaccessibility-4.3.3-2.fc12, kdeadmin-4.3.3-1.fc12, kdeartwork-4.3.3-1.fc12, kdebase-4.3.3-3.fc12, kdeedu-4.3.3-2.fc12, kdegames-4.3.3-2.fc12, kdegraphics-4.3.3-1.fc12, kdelibs-experimental-4.3.3-1.fc12, kdemultimedia-4.3.3-2.fc12, kdenetwork-4.3.3-5.fc12, kdepim-4.3.3-1.fc12, kdepim-runtime-4.3.3-1.fc12, kdepimlibs-4.3.3-1.fc12, kdeplasma-addons-4.3.3-1.fc12, kdesdk-4.3.3-1.fc12, kdetoys-4.3.3-1.fc12, kdeutils-4.3.3-1.fc12, konq-plugins-4.3.3-2.fc12, oxygen-icon-theme-4.3.3-1.fc12, qscintilla-2.4-7.fc12, webkitkde-0.0.2-0.1.20091109svn.fc12, sip-4.9.3-1.fc12, qzion-0.4.0-5.fc12, qedje-0.4.0-4.fc12, PyQwt-5.2.0-3.fc12, PyQt-3.18.1-5.fc12, kdebindings-4.3.3-4.fc12, PyKDE-3.16.6-1.fc12, PyQt4-4.6.2-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.