Bug 486499 - mtrr issues - Xorg: conflicting memory types ... uncached minus<->write-combining
mtrr issues - Xorg: conflicting memory types ... uncached minus<->write-combi...
Status: CLOSED DUPLICATE of bug 484682
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-19 19:48 EST by Bill Nottingham
Modified: 2014-03-16 23:17 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-21 01:39:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
X log (25.34 KB, application/octet-stream)
2009-02-19 19:48 EST, Bill Nottingham
no flags Details

  None (edit)
Description Bill Nottingham 2009-02-19 19:48:31 EST
Created attachment 332658 [details]
X log

Description of problem:

Xorg:2677 conflicting memory types d0000000-e0000000 uncached-minus<->write-combining
reserve_memtype failed 0xd0000000-0xe0000000, track uncached-minus, req uncached-minus
Xorg:2677 conflicting memory types d0000000-e0000000 uncached-minus<->write-combining
reserve_memtype failed 0xd0000000-0xe0000000, track uncached-minus, req uncached-minus
Xorg:2677 conflicting memory types d0000000-e0000000 uncached-minus<->write-combining
reserve_memtype failed 0xd0000000-0xe0000000, track uncached-minus, req uncached-minus
Xorg:2677 conflicting memory types d0000000-e0000000 uncached-minus<->write-combining
reserve_memtype failed 0xd0000000-0xe0000000, track uncached-minus, req uncached-minus
Xorg:2690 freeing invalid memtype d0000000-e0000000
Xorg:2677 conflicting memory types d0000000-e0000000 uncached-minus<->write-combining
reserve_memtype failed 0xd0000000-0xe0000000, track uncached-minus, req uncached-minus
Xorg:2691 freeing invalid memtype d0000000-e0000000
Xorg:2677 conflicting memory types d0000000-e0000000 uncached-minus<->write-combining
reserve_memtype failed 0xd0000000-0xe0000000, track uncached-minus, req uncached-minus
Xorg:2692 freeing invalid memtype d0000000-e0000000

00:00.0 Host bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express Memory Controller Hub (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)

/proc/mtrr says:

reg00: base=0x000000000 (    0MB), size= 2048MB, count=1: write-back
reg01: base=0x080000000 ( 2048MB), size= 1024MB, count=1: write-back
reg02: base=0x0bf700000 ( 3063MB), size=    1MB, count=1: uncachable
reg03: base=0x0bf800000 ( 3064MB), size=    8MB, count=1: uncachable
reg04: base=0x0d0000000 ( 3328MB), size=  256MB, count=2: write-combining


Version-Release number of selected component (if applicable):

xorg-x11-server-Xorg-1.5.99.903-3.fc11.x86_64
kernel-2.6.29-0.134.rc5.git2.fc11.x86_64

How reproducible:

Seems pretty consistent, at least as far back as 2.6.29-0.99.rc4.git1.fc11.x86_64
Comment 1 Chuck Ebbert 2009-02-21 01:39:34 EST

*** This bug has been marked as a duplicate of bug 484682 ***

Note You need to log in before you can comment on or make changes to this bug.