Bug 484682 - drm: X: "reserve_memtype failed/conflicting memory types d0000000-e0000000 uncached-minus<->write-combining" messages
drm: X: "reserve_memtype failed/conflicting memory types d0000000-e0000000 un...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
: 486499 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-09 09:58 EST by Tom London
Modified: 2009-10-14 10:47 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-14 10:47:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
'dmesg' from boot showing 'reserver_memtype', 'conflicting memory type' and 'freeing invalid memtype' messages (52.01 KB, text/plain)
2009-02-09 09:58 EST, Tom London
no flags Details
/var/log/messages from boot with lots of 'kernel: Xorg:2805 conflicting memory types'/'reserve_memtype failed' messages (147.49 KB, text/plain)
2009-02-13 22:17 EST, Tom London
no flags Details
dmesg output booting kernel-2.6.29-0.172.rc6.git4.fc11.x86_64 with "nomodeset nopat" (53.12 KB, text/plain)
2009-02-28 09:56 EST, Tom London
no flags Details

  None (edit)
Description Tom London 2009-02-09 09:58:08 EST
Created attachment 331313 [details]
'dmesg' from boot showing 'reserver_memtype', 'conflicting memory type' and 'freeing invalid memtype' messages

Description of problem:
Getting many of the following 2 messages reported in dmesg and /var/log/messages:

Xorg:2812 conflicting memory types d0000000-e0000000 uncached-minus<->write-combining
reserve_memtype failed 0xd0000000-0xe0000000, track uncached-minus, req uncached-minus
Xorg:2812 conflicting memory types d0000000-e0000000 uncached-minus<->write-combining
reserve_memtype failed 0xd0000000-0xe0000000, track uncached-minus, req uncached-minus
Xorg:2924 freeing invalid memtype d0000000-e0000000

Versions of Xorg:
[tbl@tlondon ~]$ rpm -qa xorg-x11-server\* xorg-x11-drv-i810
xorg-x11-server-Xorg-1.5.99.902-5.fc11.x86_64
xorg-x11-drv-i810-2.6.0-3.fc11.x86_64
xorg-x11-server-common-1.5.99.902-5.fc11.x86_64
xorg-x11-server-utils-7.4-4.fc11.x86_64
[tbl@tlondon ~]$ 

System is Thinkpad X200, Intel graphics.

Attaching output of 'dmesg'.

Not sure its important, but here is output of 'diff of /var/log/Xorg.0.log*' from previous boot with previous kernel (0.96 vs. 0.99) and xorg-x11-server (.902-4 vs. .902.5)

[root@tlondon ~]# diff /var/log/Xorg.0.log*
13,16c13,16
< Build Operating System: Linux 2.6.18-92.1.18.el5 x86_64 
< Current Operating System: Linux tlondon.innopath.com 2.6.29-0.99.rc4.git1.fc11.x86_64 #1 SMP Sun Feb 8 23:53:44 EST 2009 x86_64
< Build Date: 08 February 2009  07:49:04PM
< Build ID: xorg-x11-server 1.5.99.902-5.fc11 
---
> Build Operating System: Linux 2.6.18-107.el5xen x86_64 
> Current Operating System: Linux tlondon.innopath.com 2.6.29-0.96.rc3.git12.fc11.x86_64 #1 SMP Sun Feb 8 13:31:18 EST 2009 x86_64
> Build Date: 08 February 2009  02:14:32AM
> Build ID: xorg-x11-server 1.5.99.902-4.fc11 
22c22
< (==) Log file: "/var/log/Xorg.0.log", Time: Mon Feb  9 06:33:11 2009
---
> (==) Log file: "/var/log/Xorg.0.log", Time: Mon Feb  9 06:03:41 2009
24c24
< (II) Loader magic: 0xd40
---
> (II) Loader magic: 0xcc0
171c171
< (II) Failed to load module "i810" (already loaded, 17439632)
---
> (II) Failed to load module "i810" (already loaded, 22260624)
207d206
< (EE) open /dev/fb0: No such file or directory
512c511
< (II) config/hal: Adding input device AT Translated Set 2 keyboard
---
> (II) config/hal: Adding input device P.I. Engineering PC Keyboard/Mouse to USB  Adapter
519,527d517
< (**) AT Translated Set 2 keyboard: always reports core events
< (**) AT Translated Set 2 keyboard: Device: "/dev/input/event4"
< (II) AT Translated Set 2 keyboard: Found keys
< (II) AT Translated Set 2 keyboard: Configuring as keyboard
< (II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD)
< (**) Option "xkb_rules" "evdev"
< (**) Option "xkb_model" "pc105+inet"
< (**) Option "xkb_layout" "us"
< (II) config/hal: Adding input device P.I. Engineering PC Keyboard/Mouse to USB  Adapter
535a526,534
> (II) config/hal: Adding input device AT Translated Set 2 keyboard
> (**) AT Translated Set 2 keyboard: always reports core events
> (**) AT Translated Set 2 keyboard: Device: "/dev/input/event4"
> (II) AT Translated Set 2 keyboard: Found keys
> (II) AT Translated Set 2 keyboard: Configuring as keyboard
> (II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD)
> (**) Option "xkb_rules" "evdev"
> (**) Option "xkb_model" "pc105+inet"
> (**) Option "xkb_layout" "us"
611a611,631
> (II) P.I. Engineering PC Keyboard/Mouse to USB  Adapter: Close
> (II) UnloadModule: "evdev"
> (II) AT Translated Set 2 keyboard: Close
> (II) UnloadModule: "evdev"
> (II) ThinkPad Extra Buttons: Close
> (II) UnloadModule: "evdev"
> (II) TPPS/2 IBM TrackPoint: Close
> (II) UnloadModule: "evdev"
> (II) Macintosh mouse button emulation: Close
> (II) UnloadModule: "evdev"
> (II) P.I. Engineering PC Keyboard/Mouse to USB  Adapter: Close
> (II) UnloadModule: "evdev"
> (II) Sleep Button (CM): Close
> (II) UnloadModule: "evdev"
> (II) Video Bus: Close
> (II) UnloadModule: "evdev"
> (II) Power Button (FF): Close
> (II) UnloadModule: "evdev"
> (II) intel(0): [drm] removed 1 reserved context for kernel
> (II) intel(0): [drm] unmapping 8192 bytes of SAREA 0x1efff000 at 0x7f002081a000
> (II) intel(0): [drm] Closed DRM master.
[root@tlondon ~]# 

I'll try booting older kernel with this Xorg.....

Version-Release number of selected component (if applicable):
kernel-2.6.29-0.99.rc4.git1.fc11.x86_64

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Tom London 2009-02-09 10:08:26 EST
I don't get these booting kernel-2.6.29-0.96.rc3.git12.fc11.x86_64 with xorg-x11-server-Xorg-1.5.99.902-5.fc11.x86_64.
Comment 2 Tom London 2009-02-09 12:16:29 EST
Two subsequent boots with kernel-2.6.29-0.99.rc4.git1.fc11.x86_64 did not produce the above errors .....

I'm "... Dazed and confused ..." ;)

I'll continue to monitor.
Comment 3 Tom London 2009-02-11 09:36:33 EST
11 subsequent boots and this has not repeated.....
Comment 4 Tom London 2009-02-13 22:17:13 EST
Created attachment 331894 [details]
/var/log/messages from boot with lots of 'kernel: Xorg:2805 conflicting memory types'/'reserve_memtype failed' messages

Got these again.....

Feb 13 17:26:13 tlondon gdm-simple-slave[2804]: DEBUG(+): GdmServer: Got USR1 from X server - emitting READY
Feb 13 17:26:13 tlondon kernel: Xorg:2805 conflicting memory types d0000000-e0000000 uncached-minus<->write-combining
Feb 13 17:26:13 tlondon kernel: reserve_memtype failed 0xd0000000-0xe0000000, track uncached-minus, req uncached-minus
Feb 13 17:26:13 tlondon kernel: Xorg:2805 conflicting memory types d0000000-e0000000 uncached-minus<->write-combining
Feb 13 17:26:13 tlondon kernel: reserve_memtype failed 0xd0000000-0xe0000000, track uncached-minus, req uncached-minus
Feb 13 17:26:14 tlondon kernel: Xorg:2805 conflicting memory types d0000000-e0000000 uncached-minus<->write-combining
Feb 13 17:26:14 tlondon kernel: reserve_memtype failed 0xd0000000-0xe0000000, track uncached-minus, req uncached-minus

I attach a complete /var/log/messages from this run.

system appeared to function ok....
Comment 5 Tom London 2009-02-20 12:48:45 EST
Continue to get these (not every boot):

Feb 19 07:16:14 tlondon avahi-daemon[3806]: Registering new address record for 192.168.1.105 on eth1.IPv4.
Feb 19 07:16:14 tlondon dhclient: bound to 192.168.1.105 -- renewal in 36568 seconds.
Feb 19 07:16:15 tlondon kernel: Xorg:3926 conflicting memory types d0000000-e0000000 uncached-minus<->write-combining
Feb 19 07:16:15 tlondon kernel: reserve_memtype failed 0xd0000000-0xe0000000, track uncached-minus, req uncached-minus
Feb 19 07:16:15 tlondon nscd: 4038 Access Vector Cache (AVC) started
Feb 19 07:16:15 tlondon NetworkManager: <info>  (eth1): device state change: 7 -> 8
Feb 19 07:16:15 tlondon nscd: 4059 Access Vector Cache (AVC) started

and

Feb 19 07:16:16 tlondon gdm-simple-slave[3923]: DEBUG(+): GdmServer: Got USR1 from X server - emitting READY
Feb 19 07:16:16 tlondon kernel: Xorg:3926 conflicting memory types d0000000-e0000000 uncached-minus<->write-combining
Feb 19 07:16:16 tlondon kernel: reserve_memtype failed 0xd0000000-0xe0000000, track uncached-minus, req uncached-minus
Feb 19 07:16:16 tlondon kernel: Xorg:3926 conflicting memory types d0000000-e0000000 uncached-minus<->write-combining
Feb 19 07:16:16 tlondon kernel: reserve_memtype failed 0xd0000000-0xe0000000, track uncached-minus, req uncached-minus
Feb 19 07:16:16 tlondon kernel: Xorg:3926 conflicting memory types d0000000-e0000000 uncached-minus<->write-combining
Feb 19 07:16:16 tlondon kernel: reserve_memtype failed 0xd0000000-0xe0000000, track uncached-minus, req uncached-minus
Feb 19 07:16:16 tlondon kernel: Xorg:4160 freeing invalid memtype d0000000-e0000000
Feb 19 07:16:16 tlondon gdm-simple-slave[3923]: DEBUG(+): GdmSlave: Server is ready - opening display :0
Feb 19 07:16:16 tlondon kernel: Xorg:3926 conflicting memory types d0000000-e0000000 uncached-minus<->write-combining
Feb 19 07:16:16 tlondon kernel: reserve_memtype failed 0xd0000000-0xe0000000, track uncached-minus, req uncached-minus

Here's the boot line for this run:
Feb 19 07:15:52 tlondon kernel: Linux version 2.6.29-0.134.rc5.git2.fc11.x86_64 (mockbuild@x86-4.fedora.phx.redhat.com) (gcc version 4.4.0 20090217 (Red Hat 4.4.0-0.20) (GCC) ) #1 SMP Thu Feb 19 03:35:39 EST 2009
Comment 6 Tom London 2009-02-20 12:50:37 EST
I'm not 100% sure, but it appears from the "timestamps" that I only get these messages when I boot with an old LCD external monitor (system is Thinkpad X200) that "doesn't work" with KMS.  I have to boot with "nomodeset" to get the system up.

Could there be a connection?
Comment 7 Chuck Ebbert 2009-02-21 01:39:34 EST
*** Bug 486499 has been marked as a duplicate of this bug. ***
Comment 8 Kyle McMartin 2009-02-24 23:25:02 EST
Possibly? Try booting with enable_mtrr_cleanup mtrr_spare_reg_nr=2?

Otoh, I think I saw a clean up to use ioremap_wc in the DRM for this... adding airlied to CC.

cheers, Kyle
Comment 9 Tom London 2009-02-25 10:19:48 EST
I tried booting with "enable_mtrr_cleanup mtrr_spare_reg_nr=2" and I still get spew:

Initializing cgroup subsys cpuset
Initializing cgroup subsys cpu
Linux version 2.6.29-0.153.rc6.git2.fc11.x86_64 (mockbuild@x86-3.fedora.phx.redhat.com) (gcc version 4.4.0 20090219 (Red Hat 4.4.0-0.21) (GCC) ) #1 SMP Tue Feb 24 23:43:31 EST 2009
Command line: ro root=/dev/VolGroup00/LogVol00 rhgb quiet init=/sbin/bootchartd enable_mtrr_cleanup mtrr_spare_reg_nr=2 nomodeset
KERNEL supported cpus:
  Intel GenuineIntel
  AMD AuthenticAMD
  Centaur CentaurHauls
BIOS-provided physical RAM map:
 BIOS-e820: 0000000000000000 - 000000000009ec00 (usable)

<<<<<SNIP>>>>>>

Xorg:3831 conflicting memory types d0000000-e0000000 uncached-minus<->write-combining
reserve_memtype failed 0xd0000000-0xe0000000, track uncached-minus, req uncached-minus
Xorg:3831 conflicting memory types d0000000-e0000000 uncached-minus<->write-combining
reserve_memtype failed 0xd0000000-0xe0000000, track uncached-minus, req uncached-minus
Xorg:3984 freeing invalid memtype d0000000-e0000000
Xorg:3831 conflicting memory types d0000000-e0000000 uncached-minus<->write-combining
reserve_memtype failed 0xd0000000-0xe0000000, track uncached-minus, req uncached-minus
Xorg:3987 freeing invalid memtype d0000000-e0000000
Xorg:3831 conflicting memory types d0000000-e0000000 uncached-minus<->write-combining
reserve_memtype failed 0xd0000000-0xe0000000, track uncached-minus, req uncached-minus
Xorg:3992 freeing invalid memtype d0000000-e0000000
Xorg:3831 conflicting memory types d0000000-e0000000 uncached-minus<->write-combining
reserve_memtype failed 0xd0000000-0xe0000000, track uncached-minus, req uncached-minus
Xorg:3995 freeing invalid memtype d0000000-e0000000


Booting without "nomodeset": X does not detect my (old) Mitsubishi LCD monitor, only laptop screen.
Comment 10 Zdenek Kabelac 2009-02-26 10:44:13 EST
I'll few more comments about this problem.

I'm noticing this on my laptop T61 - I'm running vanilla kernel build from Linus tree (some post 2.6.29-rc6 atm.)

I've tried to use  both  UXA & EXA acceleration - also git build for drm libs and intel driver - and still getting the same problem.

It might help that my friend with similar hw configuration - but just running Ubuntu xserver 1.5.99.902, again with similar vanilla kernel and git versions for drm (1c381092a310af9b1b39b3a983ad5760b71a9025) and 
intel driver (668b2352a47bcfba75fe0492a5805726222755eb)
doesn't show such problem.


My mtrr looks like this:
reg00: base=0x000000000 (    0MB), size= 2048MB, count=1: write-back
reg01: base=0x080000000 ( 2048MB), size= 1024MB, count=1: write-back
reg02: base=0x0bf700000 ( 3063MB), size=    1MB, count=1: uncachable
reg03: base=0x0bf800000 ( 3064MB), size=    8MB, count=1: uncachable
reg04: base=0x100000000 ( 4096MB), size= 1024MB, count=1: write-back
reg05: base=0x13c000000 ( 5056MB), size=   64MB, count=1: uncachable
reg06: base=0x0e0000000 ( 3584MB), size=  256MB, count=2: write-combining
Comment 11 Chuck Ebbert 2009-02-27 00:57:23 EST
Does booting with the 'nopat' kernel option make this go away?
Comment 12 Tom London 2009-02-27 13:40:31 EST
Just to be clear:

I currently have to boot with "nomodeset" with this monitor.

You want me to try "nomodeset nopat"?  Or just "nopat"?  Both?

[I'll try tonight when I get home....]
Comment 13 Tom London 2009-02-28 09:56:08 EST
Created attachment 333606 [details]
dmesg output booting kernel-2.6.29-0.172.rc6.git4.fc11.x86_64 with "nomodeset nopat"

Booting with both "nomodeset" and "nopat" makes the "reserve_memtype" type messages "go away".

Attached is dmesg output from booting that way.....
Comment 14 Tom London 2009-02-28 10:11:54 EST
"nopat" also seems to "fix" the problem of compiz "white screening" on this monitor:  https://bugzilla.redhat.com/show_bug.cgi?id=486375
Comment 15 Bug Zapper 2009-06-09 07:10:49 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 16 Jérôme Glisse 2009-10-14 07:14:47 EDT
There was few bugs in kernel PAT support, testing newer kernel will likely fix your issues. Can you test with fedora 12 livecd and report if it works with it.
Comment 17 Tom London 2009-10-14 09:17:42 EDT
I've been running Rawhide, and haven't seen this in ages....

So yes, works with F12/Rawhide.
Comment 18 Jérôme Glisse 2009-10-14 10:47:57 EDT
Ok closing.

Note You need to log in before you can comment on or make changes to this bug.