Bug 486567 - No GDM login screen after completed boot sequence (intel modesetting)
No GDM login screen after completed boot sequence (intel modesetting)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
rawhide
i386 Linux
low Severity high
: ---
: ---
Assigned To: Kristian Høgsberg
Fedora Extras Quality Assurance
:
Depends On:
Blocks: IntelKMS
  Show dependency treegraph
 
Reported: 2009-02-20 06:17 EST by Tom Mannerhagen
Modified: 2009-02-26 11:53 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-26 11:53:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Xorg.0.log.old (30.31 KB, text/plain)
2009-02-20 19:42 EST, Will Woods
no flags Details
Xorg.0.log (31.41 KB, text/plain)
2009-02-22 09:57 EST, Tom Mannerhagen
no flags Details

  None (edit)
Description Tom Mannerhagen 2009-02-20 06:17:02 EST
Description of problem:
When booting the PC up, the new plymouth splash (or whatever it is called) is shown - means the boot progressbar is embedded in nice graphics.
After a while, when the GDM login normally should appear, the mousepointer is visible but the graphic splash with the now full progress bar, is still visible. No GDM login screen appears. 
I can however login by using the well known keys on my keyboard. Also the logon sound is played after I entered my password and press enter.

Moving to a terminal screen by pressing CTRL + ALT +F2 shows me a kind of error message:

[drm:intel_crtc_mode_set] *ERROR* Couldn't find PLL settings for mode!
[drm] LVDS-8: set mode kkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkk and then some garbage.

Version-Release number of selected component (if applicable):
Fedora Rawhide - Fedora 11 Alpha + all current updates.
The clean Alpha did not have this issue.

How reproducible:
Always! Tried 2 reinstalls (which works fine!) and then full updates via YUM which brings me here.

Steps to Reproduce:
1. Install Fedora 11 Alpha Live CD i386
2. Full update via Yum
3. Lean back and don't enjoy :)
  
Actual results:
No GDM login screen shown after boot sequence is completed.
Strange error message on all console / terminals.

Expected results:
Normal login screen.

Additional info:
Comment 1 Will Woods 2009-02-20 19:41:27 EST
You should be able to work around this problem by putting 'nomodeset' on the kernel commandline.

Could you attach your Xorg.0.log from the failed startup and perhaps give some details about the type of machine?

I have a similar problem with my Thinkpad T43 (Intel 915GM graphics). It looks like the modesetting driver is failing to find any modes for the laptop LCD, so it's attempting to use the TV output. 

Attaching Xorg.0.log; some interesting messages:

(II) intel(0): EDID for output LVDS1
(II) intel(0): Not using mode "<FF><FF><FF><FF>l$<B7><C0>" (height too large for
 virtual size)
...
(II) intel(0): No remaining probed modes for output LVDS1

meanwhile dmesg has:
Feb 19 22:28:23 localhost kernel: [drm:intel_crtc_mode_set] *ERROR* Couldn't find PLL settings for mode!
Feb 19 22:28:23 localhost kernel: [drm] LVDS-8: set mode NTSC 480i 16
Comment 2 Will Woods 2009-02-20 19:42:16 EST
Created attachment 332780 [details]
Xorg.0.log.old
Comment 3 Tom Mannerhagen 2009-02-22 09:50:18 EST
Hi

You're right. The "nomode" argument makes the loginscreen appear! 
The unit is a Toshiba Portégé R500-106 PPR50E-00L00NN5.

Here is the output from "lspci -v"

00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03) (prog-if 00 [VGA controller])
	Subsystem: Toshiba America Info Systems Device 0022
	Flags: bus master, fast devsel, latency 0, IRQ 16
	Memory at ffc80000 (32-bit, non-prefetchable) [size=512K]
	I/O ports at cff8 [size=8]
	Memory at e0000000 (32-bit, prefetchable) [size=256M]
	Memory at ffc40000 (32-bit, non-prefetchable) [size=256K]
	Expansion ROM at <unassigned> [disabled]
	Capabilities: <access denied>
	Kernel modules: i915

Attaching the log you ask for.

BR

Tom
Comment 4 Tom Mannerhagen 2009-02-22 09:57:36 EST
Created attachment 332858 [details]
Xorg.0.log

The log file as requested.

BR

Tom
Comment 5 Will Woods 2009-02-24 13:26:56 EST
This works for me with today's (20090224) rawhide. Hooray! Unfortunately X is unbearably slow with modeset on, but that's a different problem.

Tom, can you update to today's rawhide (incl. kernel-2.6.29-0.145) and try again?
Comment 6 Will Woods 2009-02-24 13:48:04 EST
For the record, bug 486682 is a very close match for the "X is really slow with modesetting" problem.
Comment 7 Tom Mannerhagen 2009-02-26 02:36:52 EST
Hi

You are right. After the latest update, the issue is resolved.
I can also agree that the GUI is quite sluggish now.

Thanks

Tom

Note You need to log in before you can comment on or make changes to this bug.