Bug 486592 - Click Filesystem tab -> Segmetation fault
Click Filesystem tab -> Segmetation fault
Status: CLOSED DUPLICATE of bug 456812
Product: Fedora
Classification: Fedora
Component: gnome-system-monitor (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Søren Sandmann Pedersen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-20 09:32 EST by sangu
Modified: 2014-06-18 05:10 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-24 10:33:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sangu 2009-02-20 09:32:56 EST
Description of problem:
Distribution: Fedora release 10.91 (Rawhide)
Gnome Release: 2.25.91 2009-02-19 (Red Hat, Inc)
BugBuddy Version: 2.25.2

System: Linux 2.6.29-0.131.rc5.git2.fc11.i686.PAE #1 SMP Wed Feb 18 19:24:36 EST 2009 i686
X Vendor: The X.Org Foundation
X Vendor Release: 10599903
Selinux: No
Accessibility: Disabled
GTK+ Theme: Clearlooks
Icon Theme: gnome
GTK+ Modules: canberra-gtk-module, gnomebreakpad

Memory status: size: 64352256 vsize: 64352256 resident: 22786048 share: 18505728 rss: 22786048 rss_rlim: 18446744073709551615
CPU usage: start_time: 1235139780 rtime: 401 utime: 217 stime: 184 cutime:1 cstime: 6 timeout: 0 it_real_value: 0 frequency: 100

Backtrace was generated from '/usr/bin/gnome-system-monitor'

[Thread debugging using libthread_db enabled]
0x00efb424 in __kernel_vsyscall ()
#0  0x00efb424 in __kernel_vsyscall ()
#1  0x013baa0b in waitpid () from /lib/libc.so.6
#2  0x01eee7d7 in IA__g_spawn_sync (working_directory=0x0, argv=0x8c329a0, 
    envp=0x0, flags=G_SPAWN_SEARCH_PATH, child_setup=0, user_data=0x0, 
    standard_output=0x0, standard_error=0x0, exit_status=0x0, 
    error=0xbf95a858) at gspawn.c:382
#3  0x01eeeaec in IA__g_spawn_command_line_sync (
    command_line=0x8c32940 "bug-buddy --appname=\"gnome-system-monitor\" --pid=6177", standard_output=0x0, standard_error=0x0, exit_status=0x0, 
    error=0xbf95a858) at gspawn.c:694
#4  0x01f965ae in run_bug_buddy (appname=0x8a2e0c8 "gnome-system-monitor", 
    pid=6177, minidump_path=0x0) at gnome-breakpad.cc:369
#5  0x01f96c38 in check_if_gdb () at gnome-breakpad.cc:440
#6  bugbuddy_segv_handle (signum=6) at gnome-breakpad.cc:223
#7  <signal handler called>
#8  0x00efb424 in __kernel_vsyscall ()
#9  0x013498d1 in raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#10 0x0134b1e4 in abort () at abort.c:88
#11 0x011350df in __gnu_cxx::__verbose_terminate_handler ()
    at ../../../../libstdc++-v3/libsupc++/vterminate.cc:98
#12 0x01132fc5 in __cxxabiv1::__terminate (
    handler=0x1134f90 <__gnu_cxx::__verbose_terminate_handler()>)
    at ../../../../libstdc++-v3/libsupc++/eh_terminate.cc:43
#13 0x01133002 in std::terminate ()
    at ../../../../libstdc++-v3/libsupc++/eh_terminate.cc:53
#14 0x01133141 in __cxa_throw (obj=0x8c32a50, tinfo=0x80816b0, 
    dest=0x10d64a0 <~logic_error>)
    at ../../../../libstdc++-v3/libsupc++/eh_throw.cc:88
#15 0x010ccddf in std::__throw_logic_error (
    __s=0x113cc34 "basic_string::_S_construct NULL not valid")
    at ../../../../libstdc++-v3/src/functexcept.cc:65
#16 0x0110f082 in std::string::_S_construct<char const*> (__beg=0x0, 
    __end=0xffffffff <Address 0xffffffff out of bounds>, __a=@0xbf95b2fd)
    at /usr/src/debug/gcc-4.4.0-20090219/obj-i586-redhat-linux/i586-redhat-linux/libstdc++-v3/include/bits/basic_string.tcc:139
#17 0x0110f1f6 in _S_construct_aux<const char*> ()
    at /usr/src/debug/gcc-4.4.0-20090219/obj-i586-redhat-linux/i586-redhat-linux/libstdc++-v3/include/bits/basic_string.h:1552
#18 _S_construct<const char*> ()
    at /usr/src/debug/gcc-4.4.0-20090219/obj-i586-redhat-linux/i586-redhat-linux/libstdc++-v3/include/bits/basic_string.h:1568
#19 basic_string (this=0xbf95b2f0, __s=0x0, __a=@0xbf95b2fd)
    at /usr/src/debug/gcc-4.4.0-20090219/obj-i586-redhat-linux/i586-redhat-linux/libstdc++-v3/include/bits/basic_string.tcc:221
#20 0x0806b94e in make_string (c_str=<value optimized out>) at util.h:48
#21 get_icon_for_path (path=<value optimized out>) at disks.cpp:85
#22 get_icon_for_device (mountpoint=<value optimized out>) at disks.cpp:98
#23 add_disk (show_all_fs=<value optimized out>, entry=<value optimized out>, 
    list=<value optimized out>) at disks.cpp:191
#24 cb_update_disks (data=0x8081700) at disks.cpp:232
#25 0x08058d58 in cb_change_current_page (nb=0x8b0a800, num=3, data=0x8081700)
    at callbacks.cpp:377
#26 0x00974d79 in _gtk_marshal_VOID__POINTER_UINT (closure=0x8b2cd48, 
    return_value=0x0, n_param_values=3, param_values=0x8b908e0, 
    invocation_hint=0xbf95b490, marshal_data=0x8058e00)
    at gtkmarshalers.c:2619
#27 0x00f05382 in IA__g_closure_invoke (closure=0x8b2cd48, return_value=0x0, 
    n_param_values=3, param_values=0x8b908e0, invocation_hint=0xbf95b490)
    at gclosure.c:767
#28 0x00f1c0c8 in signal_emit_unlocked_R (node=<value optimized out>, 
    detail=<value optimized out>, instance=0x8b0a800, emission_return=0x0, 
    instance_and_params=0x8b908e0) at gsignal.c:3244
#29 0x00f1d415 in IA__g_signal_emit_valist (instance=0x8b0a800, 
    signal_id=103, detail=0, var_args=0xbf95b654 "(ئ\b(ئ\b¹")
    at gsignal.c:2977
#30 0x00f1d8c6 in IA__g_signal_emit (instance=0x8b0a800, signal_id=103, 
    detail=0) at gsignal.c:3034
#31 0x00993fa4 in gtk_notebook_switch_page (notebook=0x8b0a800, 
    page=0x8b23328) at gtknotebook.c:5846
#32 0x0099c933 in gtk_notebook_button_press (widget=0x8b0a800, 
    event=0x8c7b950) at gtknotebook.c:2522
#33 0x00977738 in _gtk_marshal_BOOLEAN__BOXED (closure=0x8a707a0, 
    return_value=0xbf95b884, n_param_values=2, param_values=0x8c960f0, 
    invocation_hint=0xbf95b870, marshal_data=0x99c840) at gtkmarshalers.c:84
#34 0x00f039f9 in g_type_class_meta_marshal (closure=0x8a707a0, 
    return_value=0xbf95b884, n_param_values=2, param_values=0x8c960f0, 
    invocation_hint=0xbf95b870, marshal_data=0xb0) at gclosure.c:878
#35 0x00f05382 in IA__g_closure_invoke (closure=0x8a707a0, 
    return_value=0xbf95b884, n_param_values=2, param_values=0x8c960f0, 
    invocation_hint=0xbf95b870) at gclosure.c:767
#36 0x00f1bd47 in signal_emit_unlocked_R (node=0x8a70910, 
    detail=<value optimized out>, instance=0x8b0a800, 
    emission_return=0xbf95b9cc, instance_and_params=0x8c960f0)
    at gsignal.c:3282
#37 0x00f1d2d0 in IA__g_signal_emit_valist (instance=0x8b0a800, signal_id=30, 
    detail=0, var_args=0xbf95ba30 "\\º\225¿\030ï¤\bhº\225¿´üÆ")
    at gsignal.c:2987
#38 0x00f1d8c6 in IA__g_signal_emit (instance=0x8b0a800, signal_id=30, 
    detail=0) at gsignal.c:3034
#39 0x00aabcee in gtk_widget_event_internal (widget=<value optimized out>, 
    event=0x8c7b950) at gtkwidget.c:4761
#40 0x0096ef70 in IA__gtk_propagate_event (widget=0x8b0a800, event=0x8c7b950)
    at gtkmain.c:2396
#41 0x009703fa in IA__gtk_main_do_event (event=0x8c7b950) at gtkmain.c:1601
#42 0x00cbf99a in gdk_event_dispatch (source=0x8a55d28, callback=0, 
    user_data=0x0) at gdkevents-x11.c:2363
#43 0x01eb5198 in g_main_dispatch (context=<value optimized out>)
    at gmain.c:1814
#44 IA__g_main_context_dispatch (context=0x8a55d70) at gmain.c:2367
#45 0x01eb87a8 in g_main_context_iterate (context=0x8a55d70, 
    block=<value optimized out>, dispatch=1, self=0x8a605b0) at gmain.c:2448
#46 0x01eb8c5f in IA__g_main_loop_run (loop=0x8c5d560) at gmain.c:2656
#47 0x00970a39 in IA__gtk_main () at gtkmain.c:1205
#48 0x0069e537 in Gtk::Main::run_impl (this=0xbf95bd98) at main.cc:536
#49 0x0069e332 in Gtk::Main::run () at main.cc:483
#50 0x08055a61 in main (argc=1, argv=0xbf95be94) at procman.cpp:773
[New Thread 0xb6777b70 (LWP 6179)]


----------- .xsession-errors ---------------------
[Error 23:21:58.527] Could not load desktop item: libgnome-desktop-2.so.7
[Error 23:21:58.528] Could not load desktop item: libgnome-desktop-2.so.7
Greasemonkey getFirebugConsole() error:
(new TypeError("chromeWin.Firebug is undefined", "file:///home/sangu/.mozilla/firefox/u4ixlfxt.default/extensions/%7Be4a8a97b-f2ed-450b-b12d-ee082ba24781%7D/components/greasemonkey.js", 392))
** (gnome-system-monitor:6177): WARNING **: SELinux was found but is not enabled.
(gnome-system-monitor:6177): GLib-GObject-WARNING **: IA__g_object_get_valist: property `name' of object class `GThemedIcon' is not readable
terminate called after throwing an instance of 'std::logic_error'
  what():  basic_string::_S_construct NULL not valid
Error while reading shared library symbols:
Cannot enable thread event reporting for Thread 0xb7f31760 (LWP 6177): generic error
/usr/share/bug-buddy/gdb-cmd:3: Error in sourced command file:
Cannot enable thread event reporting for Thread 0xb6777b70 (LWP 6179): generic error
--------------------------------------------------


Version-Release number of selected component (if applicable):
2.25.91-1.fc11

How reproducible:
always

Steps to Reproduce:
1. Launch gnome-system-monitor
2. Click Filesystem monitor
3.
  
Actual results:


Expected results:


Additional info:
libstdc++-4.4.0-0.21.i586
Comment 1 Jon Dufresne 2009-02-24 10:33:00 EST

*** This bug has been marked as a duplicate of bug 456812 ***

Note You need to log in before you can comment on or make changes to this bug.