Bug 486613 - Not setting correct native display resolution
Not setting correct native display resolution
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-20 11:54 EST by Michael Monreal
Modified: 2009-02-25 12:42 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-25 12:42:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Log (31.25 KB, text/plain)
2009-02-24 14:44 EST, Michael Monreal
no flags Details

  None (edit)
Description Michael Monreal 2009-02-20 11:54:50 EST
When booting with a Intel-KMS-enabled kernel (0.137 here atm), GDM/GNOME are displayed in 1024x768 instead of the native 1280x800.

Xrandr reveals a strange thing:

TV1 connected
   1024x768
   800x600
   640x480

There's no TV connected at all. I can turn this TV1 display off using the GNOME resolution tool and set 1280x800 resolution. GDM is still 1280x800 though.
Comment 1 Matěj Cepl 2009-02-24 12:57:42 EST
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf, if available) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf (if you have one) whatsoever and let X11 autodetect your display and video card? Attach to this bug /var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 2 Will Woods 2009-02-24 13:46:15 EST
Cause seems similar to bug 486567; can you update to today's rawhide kernel (2.6.29-0.145...) and report whether it works better?
Comment 3 Michael Monreal 2009-02-24 14:40:03 EST
Update:

So first here's the whole xrandr output:

$ xrandr 
Screen 0: minimum 320 x 200, current 1024 x 768, maximum 8192 x 8192
VGA1 disconnected (normal left inverted right x axis y axis)
LVDS1 connected 1024x768+0+0 (normal left inverted right x axis y axis) 330mm x 210mm
   1280x800       60.0 +
   1024x768       60.0* 
   800x600        60.3  
   640x480        59.9  
TV1 disconnected 1024x768+0+0 (normal left inverted right x axis y axis) 0mm x 0mm

I'm running the lastest kernel from koji (0.148) now btw, still no change of situation. I don't think bug 486567 is related.

I don't use xorg.conf right now. I will attach the log as requested.
Comment 4 Michael Monreal 2009-02-24 14:44:07 EST
Created attachment 333082 [details]
Log

X log without xorg.conf
Comment 5 Michael Monreal 2009-02-24 17:52:59 EST
Good news: after updating to the new *-7 package from koji, this seems to be fixed. Feel free to close (I'm not sure about the resolution so I leave it up to you).
Comment 6 Matěj Cepl 2009-02-25 12:42:57 EST
Thansk for letting us know.

Note You need to log in before you can comment on or make changes to this bug.