Bug 486877 - don't send blank passwords to NM
don't send blank passwords to NM
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: knetworkmanager (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Dennis Gilmore
Fedora Extras Quality Assurance
:
: 485097 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-22 16:35 EST by Stefan Neufeind
Modified: 2009-03-08 15:33 EDT (History)
10 users (show)

See Also:
Fixed In Version: 0.7.0.99-1.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-08 15:33:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stefan Neufeind 2009-02-22 16:35:35 EST
I can successfully login to some WPA2-protected networks with latest stable (NetworkManager-0.7.0-1.git20090102.fc10). Moving to updates-testing (0.7.0-2.git20090207.fc10) that unfortunately fails. Up-/downgrading NetworkManager and NetworkManager-glib makes the difference.

PS: I use KDE and it's knetworkmanger together with the NetworkManager-core.
Comment 1 Joshua Covington 2009-02-26 14:35:53 EST
I have slightly different problem. I cannot connect to any hidden wpa/wpa2 network. I updated to the latest
NetworkManager-0.7.0.98-1.git20090225.fc11
NetworkManager-gnome-0.7.0.98-1.git20090225.fc11
NetworkManager-glib-0.7.0.98-1.git20090225.fc11
wpa_supplicant-0.6.7-4.fc11
wpa_supplicant-gui-0.6.7-4.fc11
and as long as the network doesn't broadcast its ssid I cannot connect to it. NetworkManager asks all the time about wep key. When the network broadcasts its ssid there is no problem with the connection and wpa works fine.
Comment 2 Stefan Neufeind 2009-02-26 14:50:25 EST
Both WPA2-networks I tested with also have disabled SSID. Unfortunately I didn't have a chance to try with enabled broadcast. So your description might be the same for me.

Works fine after downgrading to 0.7.0-1.git20090102.fc10.x86_64 again.
Comment 3 Dan Williams 2009-02-28 10:08:18 EST
What drivers are people using where NM will not connect to hidden SSID networks?  What kernel versions?
Comment 4 Joshua Covington 2009-03-01 11:05:09 EST
kernel-2.6.29-0.172.fc11-x86_64
ath5k
NetworkManager-0.7.0.98-1.git20090225.fc11
and the network is wpa2 with aes encrypted.
Comment 5 Stefan Neufeind 2009-03-01 11:15:51 EST
2.6.27.19-170.2.35.fc10.x86_64
iwlagn-driver with Intel 4965AGN hardware

works fine with NetworkManager-0.7.0-1.git20090102.fc10.x86_64
doesn't work with 0.7.0.98-1.git20090225.fc10
Comment 6 Joshua Covington 2009-03-01 13:39:05 EST
In my case when I try to connect to the hidden network NM is asking about a WEP key, although the real key is a 63bit ASCII pass phrase. NM see the encryption but cannot determin the type/lenght of the key.
Comment 7 Joshua Covington 2009-03-02 17:56:12 EST
This is a strange behaviour from NM. Right now everything with NM is ok. I have 
kernel.2.6.27.19-78.2.30.fc9.i686
ath5k
NetworkManager-gnome-0.7.0.98-1.git20090225.fc9.i386
NetworkManager-glib-0.7.0.98-1.git20090225.fc9.i386
NetworkManager-0.7.0.98-1.git20090225.fc9.i386
I also tried this it with my f11 box (see specs above) it works with it, too. The only change that I did was switching on the ssid on my router and then swiching it back off. Now everything seems to be back to normal: no ssid broadcast and NM doesn't have any problems with it either.

I've not updated any packages on the boxes and this bug doesn't showup now.
Comment 8 Dan Williams 2009-03-03 13:59:34 EST
(In reply to comment #0)
> I can successfully login to some WPA2-protected networks with latest stable
> (NetworkManager-0.7.0-1.git20090102.fc10). Moving to updates-testing
> (0.7.0-2.git20090207.fc10) that unfortunately fails. Up-/downgrading
> NetworkManager and NetworkManager-glib makes the difference.
> 
> PS: I use KDE and it's knetworkmanger together with the NetworkManager-core.

knetworkmanager has a bug where it passes blank passphrases along with the connection, which wasn't actually allowed before but now breaks with the NM update.  Will update knetworkmanager to fix that.
Comment 9 Dan Williams 2009-03-03 14:27:23 EST
*** Bug 485097 has been marked as a duplicate of this bug. ***
Comment 10 Dan Williams 2009-03-03 14:28:15 EST
Koji builds to try while waiting for the official update:

http://koji.fedoraproject.org/koji/taskinfo?taskID=1217796

Let me know if they work.
Comment 11 Stefan Neufeind 2009-03-03 15:57:41 EST
upgraded to latest NetworkManager (f10, updates-testing) and used the above mentioned knetworkmanager-build. Works fine on x86_64. Thanks a lot!
Comment 12 Joshua Covington 2009-03-03 18:34:55 EST
It works fine here, too. Why I didn't see the bug anymore? Except for the day I experienced it, I couldn't reproduce it after that.
Comment 13 Fedora Update System 2009-03-08 15:32:37 EDT
NetworkManager-0.7.0.99-1.fc10, knetworkmanager-0.7-0.8.20080926svn.fc10, NetworkManager-vpnc-0.7.0.99-1.fc10, NetworkManager-openvpn-0.7.0.99-1.fc10, NetworkManager-pptp-0.7.0.99-1.fc10, NetworkManager-openconnect-0.7.0.99-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.