Bug 486987 - cifs ignores fsync
cifs ignores fsync
Status: CLOSED DUPLICATE of bug 465143
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.3
All Linux
low Severity high
: rc
: ---
Assigned To: Jeff Layton
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-23 10:56 EST by Robert Hell
Modified: 2014-06-18 03:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-22 14:57:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Hell 2009-02-23 10:56:04 EST
Description of problem:
In contrast to the now-obsolete smbfs, cifs ignores fsync to guarantee that all volatile data is written to stable storage on the server side, provided the server honors the request (which, to my knowledge, is true for Windows and Samba with 'strict sync' enabled).

A patch was submitted this week:
http://thread.gmane.org/gmane.linux.kernel/797589

It would be nice to have fsync in cifs as soon as possible in RHEL.
Comment 1 Jeff Layton 2009-03-03 11:02:24 EST
I've already got the patches for this in my test kernels:

http://people.redhat.com/jlayton

...if you have a place to do so, please test them and verify that they fix this problem for you.
Comment 2 RHEL Product and Program Management 2009-03-03 11:13:19 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 3 Robert Hell 2009-03-08 13:37:17 EDT
I tested kernel-xen-2.6.18-133.el5.jtltest.66.x86_64.rpm from http://people.redhat.com/jlayton in our test environment. Looks very good - fsync seems to be sent by cifs client.

What are the next steps for this patch?
Comment 4 Jeff Layton 2009-03-08 15:48:18 EDT
I propose it internally (most likely as part of the larger CIFS update on which I'm working). Unless something goes wrong, this patch will most likely be in the RHEL 5.4 kernel.
Comment 6 Jeff Layton 2009-04-22 14:57:08 EDT

*** This bug has been marked as a duplicate of bug 465143 ***

Note You need to log in before you can comment on or make changes to this bug.