Bug 465143 - update CIFS for RHEL5.4
Summary: update CIFS for RHEL5.4
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel-xen
Version: 5.4
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Xen Maintainance List
QA Contact: Virtualization Bugs
URL:
Whiteboard:
: 239678 239685 239691 450015 462150 481233 482872 484193 486987 487362 490887 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-10-01 19:36 UTC by Jeff Layton
Modified: 2018-10-20 02:50 UTC (History)
17 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-02 08:47:51 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2009:1243 0 normal SHIPPED_LIVE Important: Red Hat Enterprise Linux 5.4 kernel security and bug fix update 2009-09-01 08:53:34 UTC

Description Jeff Layton 2008-10-01 19:36:05 UTC
Placeholder bug for the CIFS backport for 5.4. There are already some patches that have gone upstream that we'll want. My goal this time around is to keep my test kernels reasonably up to date with respect to upstream code (and with patches that I have queued for upstream).

Comment 1 RHEL Program Management 2009-02-16 15:32:38 UTC
Updating PM score.

Comment 2 Jeff Layton 2009-02-17 18:06:15 UTC
*** Bug 239678 has been marked as a duplicate of this bug. ***

Comment 3 Jeff Layton 2009-02-17 18:06:46 UTC
*** Bug 239685 has been marked as a duplicate of this bug. ***

Comment 4 Jeff Layton 2009-02-17 18:07:07 UTC
*** Bug 239691 has been marked as a duplicate of this bug. ***

Comment 5 Jeff Layton 2009-02-17 18:08:58 UTC
*** Bug 484193 has been marked as a duplicate of this bug. ***

Comment 6 RHEL Program Management 2009-02-17 18:11:12 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 8 Don Zickus 2009-04-20 17:10:57 UTC
in kernel-2.6.18-140.el5
You can download this test kernel from http://people.redhat.com/dzickus/el5

Please do NOT transition this bugzilla state to VERIFIED until our QE team
has sent specific instructions indicating when to do so.  However feel free
to provide a comment indicating that this fix has been verified.

Comment 11 Jeff Layton 2009-04-22 17:01:43 UTC
*** Bug 462150 has been marked as a duplicate of this bug. ***

Comment 12 Jeff Layton 2009-04-22 18:56:22 UTC
*** Bug 450015 has been marked as a duplicate of this bug. ***

Comment 13 Jeff Layton 2009-04-22 18:56:43 UTC
*** Bug 481233 has been marked as a duplicate of this bug. ***

Comment 14 Jeff Layton 2009-04-22 18:57:00 UTC
*** Bug 482872 has been marked as a duplicate of this bug. ***

Comment 15 Jeff Layton 2009-04-22 18:57:09 UTC
*** Bug 486987 has been marked as a duplicate of this bug. ***

Comment 16 Jeff Layton 2009-04-22 18:57:20 UTC
*** Bug 487362 has been marked as a duplicate of this bug. ***

Comment 17 Jeff Layton 2009-04-22 18:57:35 UTC
*** Bug 490887 has been marked as a duplicate of this bug. ***

Comment 25 Chris Ward 2009-07-03 18:10:05 UTC
~~ Attention - RHEL 5.4 Beta Released! ~~

RHEL 5.4 Beta has been released! There should be a fix present in the Beta release that addresses this particular request. Please test and report back results here, at your earliest convenience. RHEL 5.4 General Availability release is just around the corner!

If you encounter any issues while testing Beta, please describe the issues you have encountered and set the bug into NEED_INFO. If you encounter new issues, please clone this bug to open a new issue and request it be reviewed for inclusion in RHEL 5.4 or a later update, if it is not of urgent severity.

Please do not flip the bug status to VERIFIED. Only post your verification results, and if available, update Verified field with the appropriate value.

Questions can be posted to this bug or your customer or partner representative.

Comment 26 Sandro Mathys 2009-07-23 13:44:07 UTC
I didn't have time to set up any RHEL 5.4 beta system yet, but what I can say is that the kernel from [1] does not fix bz484193 (on RHEL 5.3 Server i386).

[1] http://people.redhat.com/dzickus/el5/159.el5/i686/kernel-PAE-2.6.18-159.el5.i686.rpm

Comment 27 Jeff Layton 2009-07-23 14:01:59 UTC
Ok, do you happen to have a copy of the oops message from such a crash? Could you also test the kernels on my people.redhat.com page and let me know if they fix it?

http://people.redhat.com/jlayton/

Comment 28 Sandro Mathys 2009-07-23 14:15:58 UTC
Sorry, my bad - I should have been a bit more clearly.

There's no oops with the above mentioned kernel (but there's a oops with the kernel on your page which I tried as well). There's just that mount error msg 

mount error 66 = Object is remote

That's what I meant with my bugreport not being fixed - I didn't open the bug because I wanted the oops being extinguished but because I actually want to mount that share...and that's what still doesn't work.

Comment 29 Jeff Layton 2009-07-23 14:28:13 UTC
Ok, that's expected behavior for the 5.4 kernel -- bug 484193 is specifically about an oops when mounting. Support for chasing DFS referrals at mount time is targeted for 5.5.

If you see an oops with the kernels on my people.redhat.com page though, could you open a new bug for it (and post the oops message there)? If you do this, please cc me on the bug so that I can pick it up.

Comment 32 errata-xmlrpc 2009-09-02 08:47:51 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHSA-2009-1243.html


Note You need to log in before you can comment on or make changes to this bug.