Bug 487105 - launchpad scripts have insufficient permissions
launchpad scripts have insufficient permissions
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: java-1.6.0-ibm (Show other bugs)
4.7
All Linux
low Severity medium
: rc
: ---
Assigned To: Lillian Angel
BaseOS QE
: Reopened
Depends On:
Blocks: 528037
  Show dependency treegraph
 
Reported: 2009-02-24 04:18 EST by Radek Bíba
Modified: 2009-10-12 09:17 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 528037 (view as bug list)
Environment:
Last Closed: 2009-10-12 09:17:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Radek Bíba 2009-02-24 04:18:38 EST
Description of problem:
/usr/share/doc/java-1.6.0-ibm-devel-1.6.0.3/launchpad.sh is missing 'executable' permission bits so it can't be executed directly. However, running it as a parameter of 'sh' doesn't help, either:

$ sh /usr/share/doc/java-1.6.0-ibm-devel-1.6.0.3/launchpad.sh
/usr/share/doc/java-1.6.0-ibm-devel-1.6.0.3/launchpad.sh: line 136: /usr/share/doc/java-1.6.0-ibm-devel-1.6.0.3/launchpad/SetArchitecture.sh: Permission denied
/usr/share/doc/java-1.6.0-ibm-devel-1.6.0.3/launchpad.sh: line 169: /usr/share/doc/java-1.6.0-ibm-devel-1.6.0.3/launchpad/jclp.sh: Permission denied
/usr/share/doc/java-1.6.0-ibm-devel-1.6.0.3/launchpad.sh: line 169: /usr/share/doc/java-1.6.0-ibm-devel-1.6.0.3/launchpad/SeaMonkey.sh: Permission denied
/usr/share/doc/java-1.6.0-ibm-devel-1.6.0.3/launchpad.sh: line 169: exec: /usr/share/doc/java-1.6.0-ibm-devel-1.6.0.3/launchpad/SeaMonkey.sh: cannot execute: Permission denied

and nothing happens, the script exits. When 'x' is added to all .sh files in the launchpad directory, it's much better. A special seamonkey profile is created and a seamonkey window is launched with the desired IBM SDK documentation.

Please make lanchpad.sh and all lanuchpad/*.sh files executable for all.
Comment 1 Lillian Angel 2009-02-24 10:54:48 EST
hmm seems like this is a common problem.

would you like a respin or to wait for the next update?
Comment 2 Radek Bíba 2009-02-24 11:01:08 EST
Next update is fine. In fact, if the permissions could be fixed in the tarball, we wouldn't have to do any hacking in .spec. Can you bring this to IBM's attention?
Comment 3 Lillian Angel 2009-02-24 11:11:48 EST
yes, i will direct them to this bz.

Also, note that gtkhelper has the same permission issues:

-rw-r--r--  1 root root 10934 Nov 28 23:38 /usr/lib/jvm/java-1.5.0-ibm-1.5.0.9.x86_64/jre/lib/gtkhelper
Comment 4 Radek Bíba 2009-02-25 02:45:00 EST
Actually, I was wrong, the permissions are correct in the tarballs. Sorry. Looks like this line in the .spec file is too greedy (and likely not needed at all):

find docs -type f | xargs chmod 644

As for /usr/lib/jvm/java-1.5.0-ibm-1.5.0.9.x86_64/jre/lib/gtkhelper, that's the 1.5.0 java, while launchpad (this bug report) is 1.6.0-only. BTW, it has 644 in the tarball. But then again, it's probably okay.
Comment 5 Lillian Angel 2009-09-17 11:34:49 EDT
These files should be removed because they are arch dependent. marking as a duplicate

*** This bug has been marked as a duplicate of bug 487107 ***
Comment 6 Radek Bíba 2009-09-17 11:45:36 EDT
I don't think these files are arch dependent. They're just shell scripts. Please investigate.
Comment 7 Radek Bíba 2009-09-30 03:57:32 EDT
Reopening since the .sh files (scripts) are supposed to be executable. See comment 4 for an explanation why they aren't.
Comment 13 errata-xmlrpc 2009-10-12 09:17:05 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1492.html

Note You need to log in before you can comment on or make changes to this bug.