Bug 487225 - ALSA woke us up to write new data to the device, but there was actually nothing to write
ALSA woke us up to write new data to the device, but there was actually nothi...
Status: CLOSED DUPLICATE of bug 486068
Product: Fedora
Classification: Fedora
Component: alsa-lib (Show other bugs)
10
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Jaroslav Kysela
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-24 16:29 EST by D. Wagner
Modified: 2009-08-23 12:38 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-02 20:25:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description D. Wagner 2009-02-24 16:29:36 EST
Description of problem:

I found these messages in my logs (/var/log/messages) on F10.  I'm including everything Pulseaudio/ALSA-related over the last day or so, but see the last two messages; apparently I'm requested to report this to Pulseaudio developers.

Feb 22 05:48:59 mundy pulseaudio[2838]: module-alsa-sink.c: Increasing wakeup watermark to 68.03 ms
Feb 22 21:04:08 mundy pulseaudio[2838]: module-alsa-sink.c: Increasing wakeup watermark to 136.05 ms
Feb 23 11:39:17 mundy pulseaudio[2838]: module-alsa-sink.c: Increasing wakeup watermark to 272.11 ms
Feb 23 20:46:18 mundy pulseaudio[2838]: module-alsa-sink.c: Increasing wakeup watermark to 34.01 ms
Feb 23 23:07:33 mundy pulseaudio[2838]: module-alsa-sink.c: Increasing wakeup watermark to 68.03 ms
Feb 24 00:37:02 mundy pulseaudio[2838]: module-alsa-sink.c: Increasing wakeup watermark to 136.05 ms
Feb 24 11:25:26 mundy pulseaudio[2838]: module-alsa-sink.c: Increasing wakeup watermark to 272.11 ms
Feb 24 11:38:38 mundy pulseaudio[2838]: module-alsa-sink.c: ALSA woke us up to write new data to the device, but there was actually nothing to write! Most likely this is an ALSA driver bug. Please report this issue to the PulseAudio developers.
Feb 24 12:46:20 mundy pulseaudio[2838]: module-alsa-sink.c: ALSA woke us up to write new data to the device, but there was actually nothing to write! Most likely this is an ALSA driver bug. Please report this issue to the PulseAudio developers.

I was listening to MP3's using Exaile at the time.


Version-Release number of selected component (if applicable):

pulseaudio-0.9.14-1.fc10.x86_64
pulseaudio-core-libs-0.9.14-1.fc10.x86_64
alsa-plugins-pulseaudio-1.0.18-2.fc10.x86_64
alsa-lib-1.0.19-2.fc10.i386
kernel-2.6.27.15-170.2.24.fc10.x86_64
exaile-0.2.14-1.fc10.x86_64

I've installed debuginfo packages associated with some of these packages and will report if this provides any further information to help in debugging the problem.


P.S. How do I get someone who maintains this Bugzilla web site to pay attention to bugs reported about the web site?  Interacting with this web site to file new bugs is a major annoyance, due to issues that should be easily fixable by someone with the proper access.  I've filed a bug but got no response.

https://bugzilla.redhat.com/show_bug.cgi?id=481080
Comment 1 D. Wagner 2009-02-24 16:42:32 EST
Perhaps I should mention some additional information in case it is helpful to developers:

I didn't notice any disruption to the audio.

lspci -v excerpt:

00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller
 (rev 02)
        Subsystem: Dell Device 01dd
        Flags: bus master, fast devsel, latency 0, IRQ 16
        Memory at dffdc000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: [50] Power Management version 2
        Capabilities: [60] Message Signalled Interrupts: Mask- 64bit+ Count=1/1 
Enable-
        Capabilities: [70] Express Root Complex Integrated Endpoint, MSI 00
        Capabilities: [100] Virtual Channel <?>
        Capabilities: [130] Root Complex Link <?>
        Kernel driver in use: HDA Intel
        Kernel modules: snd-hda-intel

lsmod shows that I have the snd_hda_intel module loaded (along with many others).

See also bug #475236, bug #478394, bug #471941 which appear to refer to similar log messages but in different audio cards (I believe).  Where should this be reported to ensure that the appropriate developers have a chance to see this bug?

I'm noticing that perhaps this should be assigned to ALSA, not Pulseaudio, so I'm changing the component this is associated with (hope the new choice is a bit better; sorry that I wasn't sure which component is the one for ALSA device drivers)...
Comment 2 Lennart Poettering 2009-02-24 21:02:48 EST
This is more like
Comment 3 Lennart Poettering 2009-02-24 21:40:08 EST
Please ignore that comment of mine, sorry.
Comment 4 Lennart Poettering 2009-03-02 20:25:09 EST

*** This bug has been marked as a duplicate of bug 486068 ***

Note You need to log in before you can comment on or make changes to this bug.