Bug 487257 - abort with tab completion
abort with tab completion
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: bash (Show other bugs)
rawhide
i586 Linux
high Severity high
: ---
: ---
Assigned To: Roman Rakus
Fedora Extras Quality Assurance
:
: 487350 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-24 23:28 EST by Mamoru TASAKA
Modified: 2014-01-12 19:08 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-25 09:59:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gdb log of bash 4.0-1.fc11 (4.74 KB, text/plain)
2009-02-24 23:29 EST, Mamoru TASAKA
no flags Details
Possible patch (332 bytes, text/plain)
2009-02-25 06:52 EST, Roman Rakus
no flags Details

  None (edit)
Description Mamoru TASAKA 2009-02-24 23:28:53 EST
Description of problem:
With bash-4.0-1.fc11 when I type

$ ls -la a[TAB]
bash immediately aborts.

Version-Release number of selected component (if applicable):
bash-4.0-1.fc11.i586

How reproducible:
100%

Steps to Reproduce:
1. gdb bash
2. (gdb) run
3. (when running) ls -al ba[TAB]
  
Actual results:
bash abort

Expected results:
bash-4.0-0.5.rc1.fc11 does not have this issue

Additional info:
gdb log attached
Comment 1 Mamoru TASAKA 2009-02-24 23:29:35 EST
Created attachment 333132 [details]
gdb log of bash 4.0-1.fc11
Comment 2 Roman Rakus 2009-02-25 06:52:37 EST
Created attachment 333152 [details]
Possible patch

I can't reproduce it. Can you please try this patch?
Comment 3 Mamoru TASAKA 2009-02-25 07:41:06 EST
(In reply to comment #2)
> Created an attachment (id=333152) [details]
> Possible patch
> 
> I can't reproduce it. Can you please try this patch?

With this patch I cannot reproduce this issue
(without this patch this issue is reproducible for me)
Comment 4 Vallimar 2009-02-25 09:53:59 EST
I had the same problem: tab-completion == instant death!
Installed the freshly built bash-4.0-2.fc11.x86_64.rpm and problem is fixed.
Comment 5 Roman Rakus 2009-02-25 09:59:56 EST
Patch included in bash-4.0-2.fc11, which is now built in rawhide.
Comment 6 Tom London 2009-02-25 10:56:56 EST
*** Bug 487350 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.