Bug 487350 - completions cause SEGFAULTs, crashing bash
completions cause SEGFAULTs, crashing bash
Status: CLOSED DUPLICATE of bug 487257
Product: Fedora
Classification: Fedora
Component: bash (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Roman Rakus
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-25 10:51 EST by Tom London
Modified: 2014-01-12 19:08 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-25 10:56:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom London 2009-02-25 10:51:37 EST
Description of problem:
Since installing bash-4.0-1.fc11.x86_64, each time I ask bash to "complete", it segfaults.

Here is a typical crash:

Core was generated by `bash'.
Program terminated with signal 11, Segmentation fault.
#0  restore_token_state () at ./parse.y:1631
1631	  last_read_token = ts[0];
(gdb) where
#0  restore_token_state () at ./parse.y:1631
#1  restore_parser_state (ps=0x7fffe29a6dd0) at ./parse.y:5560
#2  0x0000000000463f80 in gen_shell_function_matches (
    cw=<value optimized out>, nw=<value optimized out>, 
    lwords=<value optimized out>, ind=<value optimized out>, 
    line=<value optimized out>, text=<value optimized out>, 
    cs=<value optimized out>) at pcomplete.c:1043
#3  gen_compspec_completions (cs=0x114c9d0, cmd=<value optimized out>, 
    word=<value optimized out>, start=0, end=<value optimized out>)
    at pcomplete.c:1286
#4  0x00000000004647a2 in programmable_completions (cmd=0x114c9b0 "cd", 
    word=0x114c990 "str", start=0, end=<value optimized out>, 
    foundp=<value optimized out>) at pcomplete.c:1444
#5  0x000000000045d03a in attempt_shell_completion (text=0x114c990 "str", 
    start=3, end=6) at bashline.c:1334
#6  0x00000000004859ff in gen_completion_matches (text=0x114c990 "str", 
    start=0, end=-48, our_func=0x484590 <rl_filename_completion_function>, 
    found_quote=18253648, quote_char=97) at complete.c:1023
#7  0x0000000000486e88 in rl_complete_internal (what_to_do=9)
    at complete.c:1746
#8  0x000000000047eec3 in _rl_dispatch_subseq (key=9, map=0x6d0da0, 
    got_subseq=0) at readline.c:820
#9  0x000000000047f627 in readline_internal_char () at readline.c:599
---Type <return> to continue, or q <return> to quit---
#10 0x000000000047fa45 in readline_internal_charloop () at readline.c:626
#11 readline_internal () at readline.c:640
#12 e (prompt=<value optimized out>) at readline.c:384
#13 0x000000000041e55d in yy_readline_get () at ./parse.y:1314
#14 0x000000000041f6e6 in yy_getc () at ./parse.y:1247
#15 shell_getc (remove_quoted_newline=1) at ./parse.y:2094
#16 0x0000000000421cea in read_token (command=<value optimized out>, 
    command=<value optimized out>) at ./parse.y:2727
#17 0x0000000000424ade in yylex () at ./parse.y:2360
#18 yyparse () at y.tab.c:2010
#19 0x000000000041d09a in parse_command () at eval.c:229
#20 0x000000000041d166 in read_command () at eval.c:273
#21 0x000000000041d3c8 in reader_loop () at eval.c:138
#22 0x000000000041caaf in main (argc=0, argv=<value optimized out>, 
    env=<value optimized out>) at shell.c:751
(gdb) 

[tbl@tlondon ~]$ 

Version-Release number of selected component (if applicable):
ash-completion-20080705-3.20090211git47d0c5b.noarch
bash-4.0-1.fc11.x86_64
bash-debuginfo-4.0-1.fc11.x86_64


How reproducible:
Every time

Steps to Reproduce:
1. Hit tab key.... watch window go away ....
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Tom London 2009-02-25 10:56:56 EST
Sorry, didn't see #487257

Closing this one.

*** This bug has been marked as a duplicate of bug 487257 ***

Note You need to log in before you can comment on or make changes to this bug.