Bug 487264 - yum doesn't handle i386->i586 update for glibc
yum doesn't handle i386->i586 update for glibc
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
: 489127 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-25 01:10 EST by Michel Alexandre Salim
Modified: 2014-01-21 18:08 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-06 16:01:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Will Woods' yum log (3.78 KB, text/plain)
2009-02-25 01:10 EST, Michel Alexandre Salim
no flags Details

  None (edit)
Description Michel Alexandre Salim 2009-02-25 01:10:21 EST
Created attachment 333135 [details]
Will Woods' yum log

Description of problem:
Rawhide has recently switched the 32-bit arch from "i386" (actually i486) to i586. Systems with the pre-i586 32-bit glibc, it appears, cannot be upgraded directly using yum, because yum does not recognise glibc.i586 as an update to glibc.i386, and thus the glibc-common upgrade is misflagged as causing a dependency problem for the old glibc.i386

Pure 64-bit installs are not affected; however, 64-bit systems where glibc.i386 is installed for running 32-bit apps, and 32-bit systems, are.

Version-Release number of selected component (if applicable):
yum-3.2.21-9.fc11

How reproducible:
Always (?)

Steps to Reproduce:
1. Install F11 alpha 32-bit
2. yum update glibc

  
Actual results:
Error: Missing Dependency: glibc-common = 2.9.90-3 is needed by package
glibc-2.9.90-3.i386 (installed)

Note: version number might vary as my system has been updated between the alpha release and the i586 change landing.

Expected results:
yum should recognise that glibc.i586/i686 replaces glibc.i386, and thus glibc-common-oldversion.i386 is now not needed and can be replaced by glibc-common-newversion.i586 without causing dependency problems.


Additional info:
yum log attached
Comment 1 marco crosio 2009-03-01 05:11:21 EST
This bug has been triaged
Comment 2 seth vidal 2009-03-06 09:59:53 EST
I'm confused - if you're running f11alpha 32bit - why do you have glibc.i386 installed and not glibc.i686?
Comment 3 seth vidal 2009-03-06 10:23:29 EST
replicated this one.
Comment 4 Michel Alexandre Salim 2009-03-06 10:25:51 EST
Can't speak for Will, but in my case, I'm actually running F11 alpha x86_64, and installed glibc.i386 by hand for 32-bit apps. I guess I forgot that I could have installed .i686 instead
Comment 5 seth vidal 2009-03-06 16:01:52 EST
This is a result of glibc being in the exactarchlist

you can either wait for the rawhide update or set exactarchlist=kernel
in your yum.conf under [main]

it's fixed in upstream.
Comment 6 seth vidal 2009-03-07 20:37:28 EST
*** Bug 489127 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.