Bug 487422 - Xorg fails to start without xorg.conf: Internal error: invalid bpp (32) in S3VScreenInit
Xorg fails to start without xorg.conf: Internal error: invalid bpp (32) in S3...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-s3virge (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-25 16:47 EST by Pavel Roskin
Modified: 2009-07-02 01:44 EDT (History)
1 user (show)

See Also:
Fixed In Version: 1.10.2-1.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-08 14:03:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
full log in the failure case (23.34 KB, text/plain)
2009-02-25 16:50 EST, Pavel Roskin
no flags Details
minimal xorg.conf that works around the problem (115 bytes, text/plain)
2009-02-25 16:51 EST, Pavel Roskin
no flags Details

  None (edit)
Description Pavel Roskin 2009-02-25 16:47:11 EST
Description of problem:
Xorg refuses to start without /etc/X11/xorg.conf if an S3 Virge card is used.

Version-Release number of selected component (if applicable):
1.10.0-1.fc9.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Make sure /etc/X11/xorg.conf doesn't exist
2. Install an S3 Virge video card
3. Boot at runlevel 2 (just to avoid X failing and restarting)
4. Run Xorg
  
Actual results:
# Xorg 
_XSERVTransSocketOpenCOTSServer: Unable to open socket for inet6
_XSERVTransOpen: transport open failed for inet6/dv.roinet.com:0
_XSERVTransMakeAllCOTSServerListeners: failed to open listener for inet6

X.Org X Server 1.5.3
Release Date: 5 November 2008
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.18-107.el5xen x86_64 
Current Operating System: Linux dv.roinet.com 2.6.29-rc6-wl #126 SMP Wed Feb 25 13:23:09 EST 2009 x86_64
Build Date: 16 February 2009  01:59:09AM
Build ID: xorg-x11-server 1.5.3-13.fc10 
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Wed Feb 25 16:44:26 2009
(EE) Unable to locate/open config file
New driver is "s3virge"
(==) Using default built-in configuration (30 lines)
(EE) open /dev/fb0: No such file or directory
(EE) S3VIRGE(0): Internal error: invalid bpp (32) in S3VScreenInit

Fatal server error:
AddScreen/ScreenInit failed for driver 0


Expected results:
Xorg starts

Additional info:
Comment 1 Pavel Roskin 2009-02-25 16:48:33 EST
The problem is mentioned in bug #444174, but it's not the main focus of that bug.  A comment refers to this commit:
http://gitweb.freedesktop.org/?p=xorg/driver/xf86-video-s3virge.git;a=commitdiff;h=aa4708390fb18a7089de66ef71c93745c856f6f4
Comment 2 Pavel Roskin 2009-02-25 16:50:26 EST
Created attachment 333246 [details]
full log in the failure case
Comment 3 Pavel Roskin 2009-02-25 16:51:23 EST
Created attachment 333247 [details]
minimal xorg.conf that works around the problem
Comment 4 Fedora Update System 2009-05-08 11:40:58 EDT
xorg-x11-drv-s3virge-1.10.2-1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/xorg-x11-drv-s3virge-1.10.2-1.fc10
Comment 5 Pavel Roskin 2009-05-08 14:03:24 EDT
I confirm that the Virge driver on the same system is working fine without xorg.conf with xorg-x11-drv-s3virge-1.10.2-1.fc10.  The bug can be closed now.
Comment 6 Fedora Update System 2009-07-02 01:44:42 EDT
xorg-x11-drv-s3virge-1.10.2-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.