Bug 487456 - gdm does not start
gdm does not start
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau (Show other bugs)
11
i686 Linux
high Severity high
: ---
: ---
Assigned To: Ben Skeggs
Fedora Extras Quality Assurance
https://fedoraproject.org/wiki/Common...
: CommonBugs
Depends On:
Blocks: 518893
  Show dependency treegraph
 
Reported: 2009-02-26 00:18 EST by pgaltieri
Modified: 2014-06-09 15:37 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-28 07:21:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gdm log file (6.46 KB, text/plain)
2009-02-26 00:18 EST, pgaltieri
no flags Details
gdm log file (3.29 KB, text/plain)
2009-02-26 00:20 EST, pgaltieri
no flags Details
output from messages file (27.69 KB, text/plain)
2009-02-26 00:22 EST, pgaltieri
no flags Details
X log file (10.12 KB, text/plain)
2009-02-27 13:47 EST, pgaltieri
no flags Details
debug info (6.12 KB, text/plain)
2009-03-16 12:59 EDT, pgaltieri
no flags Details
debug info 2 (3.26 KB, text/plain)
2009-03-16 13:00 EDT, pgaltieri
no flags Details
debug info 3 (10.11 KB, text/plain)
2009-03-16 13:00 EDT, pgaltieri
no flags Details
log file (10.07 KB, text/plain)
2009-03-18 00:00 EDT, pgaltieri
no flags Details
x log file (6.18 KB, text/plain)
2009-03-18 00:04 EDT, pgaltieri
no flags Details
driver messages (14.38 KB, text/plain)
2009-03-18 00:15 EDT, pgaltieri
no flags Details
Latest xorg log (11.50 KB, text/plain)
2009-03-18 16:27 EDT, pgaltieri
no flags Details
lates Xorg log (27.35 KB, text/plain)
2009-03-23 01:27 EDT, pgaltieri
no flags Details
strace output (12.58 KB, text/plain)
2009-03-23 01:28 EDT, pgaltieri
no flags Details
xorg log file (27.35 KB, text/plain)
2009-03-23 01:37 EDT, pgaltieri
no flags Details
radeontool-nv output for nv (8.78 KB, text/plain)
2009-03-23 19:48 EDT, pgaltieri
no flags Details
radeontool-nv output for nouveau (8.78 KB, text/plain)
2009-03-23 19:51 EDT, pgaltieri
no flags Details
radeontool-nv output for nouveau (8.78 KB, text/plain)
2009-04-07 20:12 EDT, pgaltieri
no flags Details
xorg log file (27.47 KB, text/plain)
2009-04-07 20:13 EDT, pgaltieri
no flags Details
radeontool-nv output for nouveau (8.78 KB, text/plain)
2009-04-08 22:32 EDT, pgaltieri
no flags Details
xorg log file (38.06 KB, text/plain)
2009-04-08 22:32 EDT, pgaltieri
no flags Details
messages file (274.66 KB, text/plain)
2009-04-09 09:18 EDT, pgaltieri
no flags Details
X log file (49.55 KB, text/plain)
2009-04-09 09:20 EDT, pgaltieri
no flags Details

  None (edit)
Description pgaltieri 2009-02-26 00:18:59 EST
Created attachment 333281 [details]
gdm log file

Description of problem:
X does not start on boot


Version-Release number of selected component (if applicable):
gdm-2.25.2-7.fc11.i586


How reproducible:
Always


Steps to Reproduce:
1.Boot the system
2.
3.
  
Actual results:
gdm fails to start - respawning too rapidly


Expected results:
That gdm starts

Additional info:
This started to happen after latest round of updates (Feb 25)

System is a Dell Inspiron 8600 with the following video:
01:00.0 VGA compatible controller: nVidia Corporation NV28 [GeForce4 Ti 4200 Go AGP 8x] (rev a1)
Comment 1 pgaltieri 2009-02-26 00:20:59 EST
Created attachment 333282 [details]
gdm log file
Comment 2 pgaltieri 2009-02-26 00:22:23 EST
Created attachment 333283 [details]
output from messages file

This is an excerpt of messages from /var/log/messages
Comment 3 Matthias Clasen 2009-02-26 00:45:39 EST
Your X server is crashing, from the looks of it. Would be good to get your Xorg.0.log
Comment 4 pgaltieri 2009-02-27 13:47:57 EST
Created attachment 333516 [details]
X log file

I have attached the log file
Comment 5 cje 2009-03-04 21:41:40 EST
looks like this is the problem then:

(II) NOUVEAU(0): Found Display Configuration Block version 2.2
(!!) NOUVEAU(0): Raw DCB entry 0: 01000100 000088b8
(!!) NOUVEAU(0): Raw DCB entry 1: 02110223 00000064
(EE) NOUVEAU(0): Unknown LVDS configuration bits, please report

(WW) NOUVEAU(0): No outputs definitely connected, trying again...
(WW) NOUVEAU(0): Unable to find initial modes
(EE) NOUVEAU(0): 1384: No valid modes.

doesn't look like your graphics card is particularly unusual or anything.

we should probably change the component of this bug to xorg-x11-drv-nouveau.
Comment 6 pgaltieri 2009-03-04 23:34:23 EST
The card worked fine with the Alpha install image from the F11 Live CD image so it should work.
Comment 7 Ben Skeggs 2009-03-08 19:01:42 EDT
The alpha install image was using the nv driver, which doesn't attempt to program your panel, it just reuses what your VBIOS has setup.  Nouveau, in order to do randr 1.2, has to be able to program the panel, and this is one of the safety checks to make sure we don't do anything bad to it.

I've packaged a tool which traces your VBIOS.  If you can install the package and run the following commands from a *console*, if you're in X things will likely go very wrong.

vbtracetool -d 2>post.log (this will take a *long* time)
vbtracetool -l 2>post.iolog
vbtracetool -w 2>bios.rom

If you can compress the resulting files, and either attach them here, or mail to mmio.dumps@gmail.com I'll have a look and see how to handle the flags nouveau is complaining about.

You can find packages for vbtracetool at http://koji.fedoraproject.org/scratch/bskeggs/task_1230375/

Thanks,
Ben.
Comment 8 Ben Skeggs 2009-03-08 22:42:40 EDT
Sorry, I made a small mistake in the above instructions.  The first two commands should be:

vbtracetool -dp 2>post.log
vbtracetool -lp 2>post.iolog

Thanks!
Comment 9 pgaltieri 2009-03-16 12:59:50 EDT
Created attachment 335375 [details]
debug info

I ran the 2 commands you suggested but the files generated are huge:

-rw-r--r--. 1 root root   74428802 2009-03-13 21:19 /tmp/post.iolog
-rw-r--r--. 1 root root 1356167991 2009-03-13 21:21 /tmp/post.log

How do you want me to provide them to you?

I am attaching X.org files from latest attempt
Comment 10 pgaltieri 2009-03-16 13:00:21 EDT
Created attachment 335377 [details]
debug info 2
Comment 11 pgaltieri 2009-03-16 13:00:47 EDT
Created attachment 335378 [details]
debug info 3
Comment 12 Ben Skeggs 2009-03-16 18:06:18 EDT
They should compress down quite a lot with "bzip -9 post.log > post.log.bz2".  If you mail them to mmio.dumps@gmail.com, myself and other nouveau developers will be able to access them.
Comment 13 Ben Skeggs 2009-03-17 21:04:12 EDT
Can you install the xorg-x11-drv-nouveau rpm for your arch from http://koji.fedoraproject.org/scratch/bskeggs/task_1247307/xorg-x11-drv-nouveau-0.0.12-11.20090313git79d23d8.fc11.i586.rpm and see if the driver works for you?

Also, can you run "vbtracetool -w 2>bios.rom" and mail it to the same address as the others?

Thanks!
Ben.
Comment 14 pgaltieri 2009-03-18 00:00:40 EDT
Created attachment 335647 [details]
log file
Comment 15 pgaltieri 2009-03-18 00:04:54 EDT
Created attachment 335648 [details]
x log file

I tried the rpm and it did not work.

I got a lot of the following message:

[drm] nouveau_fifo_free: freeing fifo 0

I have attached the Xorg log files

I also get a lot of these messages:

Mar 17 21:04:26 peglaptop192 kernel: atkbd.c: Unknown key pressed (raw set 2, code 0x11d on isa0060/serio0).
Mar 17 21:04:26 peglaptop192 kernel: atkbd.c: Use 'setkeycodes 1d <keycode>' to make it known.

I sent the bios.rom file as well
Comment 16 pgaltieri 2009-03-18 00:15:40 EDT
Created attachment 335649 [details]
driver messages

I have attached the messages I got out of the new driver

Paolo
Comment 18 pgaltieri 2009-03-18 10:34:33 EDT
I tried the latest nouveau package and I get the same problem.  perfdm terminates because it respawns too rapidly.

The issue is always:

(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found

Paolo
Comment 19 Ben Skeggs 2009-03-18 16:11:19 EDT
Can I have a full log of that please?  The issue that was last in the logs should be gone, maybe something else!
Comment 20 pgaltieri 2009-03-18 16:27:25 EDT
Created attachment 335760 [details]
Latest xorg log

I have attached the latest Xorg.5.log using latest package
Comment 21 Ben Skeggs 2009-03-23 00:59:13 EDT
Thanks for that.  Stuart Bennett made some changes upstream which should fix the issue seen in your latest log.  xorg-x11-drv-nouveau-0.0.12-15.20090323git4067ab4.fc11 contains all the fixes to date, so is worth a try.  I'll link you to the rpm of the build in case you don't want to wait until it hits the update repos.

http://koji.fedoraproject.org/scratch/bskeggs/task_1253659/xorg-x11-drv-nouveau-0.0.12-15.20090323git4067ab4.fc11.i586.rpm
Comment 22 pgaltieri 2009-03-23 01:27:30 EDT
Created attachment 336245 [details]
lates Xorg log

An improvement, but still no gdm login.  Both the server and gdm start but the screen is blank.  I ran strace on the running server and I get:

2754  --- SIGALRM (Alarm clock) @ 0 (0) ---
2754  sigreturn()                       = ? (mask now [])
2754  --- SIGALRM (Alarm clock) @ 0 (0) ---
2754  sigreturn()                       = ? (mask now [])
2754  --- SIGALRM (Alarm clock) @ 0 (0) ---

See the next attachment.
Comment 23 pgaltieri 2009-03-23 01:28:49 EDT
Created attachment 336246 [details]
strace output

This show a ps output of gdm and the X server allong with strace output of all the related processes
Comment 24 pgaltieri 2009-03-23 01:37:04 EDT
Created attachment 336247 [details]
xorg log file

FYI,
  after I installed the package I did an init 3 followed by an init 5, the screen went through a weird pattern as if it was trying to start graphics but eventually the screen went blank - no gdm login screen.  I then tried doing an init 3 again to stop graphics to make sure the new driver was in fact loaded, but the X server never terminated.  I eventually rebooted.  The first Xorg log file is from the initial attempt to start graphics.  The strace output is from the second attempt. I have attached the Xorg log file from the second attempt.
Comment 25 Ben Skeggs 2009-03-23 01:37:59 EDT
Thanks.  What resolution is your laptop's panel supposed to be?  X is running correctly, but your display just isn't lighting up still.  Can you ssh in from somewhere and run "xrandr --output LVDS-0 --mode 1400x1050" ?

The SIGALRM is normal, X uses it as a timer of sorts.
Comment 26 pgaltieri 2009-03-23 09:23:31 EDT
Ruuning:

xrandr --output LVDS-0 --mode 1400x1050

reults in:

Xlib:  extension "Generic Event Extension" missing on display "localhost:12.0".
Comment 27 Ben Skeggs 2009-03-23 18:31:37 EDT
Okay.  Can you install http://koji.fedoraproject.org/scratch/bskeggs/task_1255481/radeontool-nv-20080818gitca77362a-1.fc11.i586.rpm, and run

sudo radeontool-nv regs

both while running a (working) nv, and the same with nouveau sitting at the black screen (over ssh?) and post the output from both here.

We'll get this eventually!
Comment 28 pgaltieri 2009-03-23 19:48:05 EDT
Created attachment 336413 [details]
radeontool-nv output for nv
Comment 29 pgaltieri 2009-03-23 19:51:00 EDT
Created attachment 336414 [details]
radeontool-nv output for nouveau

Attached the two requested files.

BTW, I really appreciate the effort you've been doing to try to solve my problem. If there is any additional info you need let me know.  I'll help in any way I can to get this working.

Thanks,
Paolo
Comment 30 Michael Monreal 2009-03-26 10:13:21 EDT
I just tried the LiveCD provided for the Nouveau test day and I think I have the same issue:

(EE) open /dev/fb0: No such file or directory
(EE) NOUVEAU(0): 14111: No valid modes.
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found

[...]

[drm] nouveau_fifo_free: freeing fifo 0
giving up.



The nouveau version is git4067ab4. My card is a GeForce 7950 and the monitor is an Eizo FlexScan S1910 (1280x1024) connected via DVI-1.
Comment 31 pgaltieri 2009-03-31 20:19:15 EDT
I just installed the latest updates and the problem is still present.  I have downloaded the beta DVD and will try that as well
Comment 32 pgaltieri 2009-03-31 20:42:58 EDT
The F11 Beta DVD failed to start graphics and went to text mode for the install
Comment 33 Ben Skeggs 2009-04-07 06:10:29 EDT
There's a build of the xorg-x11-drv-nouveau up at http://koji.fedoraproject.org/scratch/bskeggs/task_1282023/ which has fixes from Stuart Bennett (malc0 on irc) which he thinks may help.  Can you give it a try and report back please?
Comment 34 Ben Skeggs 2009-04-07 06:11:23 EDT
Also, if this doesn't help at all, can you do another dump with radeontool-nv and attach it here.

Thanks!
Comment 35 pgaltieri 2009-04-07 20:11:14 EDT
I'm attaching the info

/var/log/messages showed:

Apr  7 17:00:18 peglaptop192 kernel: agpgart-intel 0000:00:00.0: AGP 2.0 bridge
Apr  7 17:00:18 peglaptop192 kernel: agpgart-intel 0000:00:00.0: putting AGP V2 device into 4x mode
Apr  7 17:00:18 peglaptop192 kernel: pci 0000:01:00.0: putting AGP V2 device into 4x mode
Apr  7 17:00:18 peglaptop192 kernel: nouveau 0000:01:00.0: Allocating FIFO number 0
Apr  7 17:00:18 peglaptop192 kernel: nouveau 0000:01:00.0: nouveau_fifo_alloc: initialised FIFO 0
Apr  7 17:00:18 peglaptop192 kernel: nouveau 0000:01:00.0: Allocating FIFO number 1
Apr  7 17:00:18 peglaptop192 kernel: nouveau 0000:01:00.0: nouveau_fifo_alloc: initialised FIFO 1
Apr  7 17:00:19 peglaptop192 kernel: nouveau 0000:01:00.0: PFIFO_DMA_PUSHER - Ch 1

Paolo
Comment 36 pgaltieri 2009-04-07 20:12:54 EDT
Created attachment 338634 [details]
radeontool-nv output for nouveau
Comment 37 pgaltieri 2009-04-07 20:13:26 EDT
Created attachment 338635 [details]
xorg log file
Comment 38 Ben Skeggs 2009-04-08 02:20:54 EDT
Ok, seems we're out of the woods now regarding display issues (you did see the display come up this time?).. now the graphics engine is playing up..  Does this still occur if you boot with nouveau.noagp=1 on the kernel commandline?
Comment 39 pgaltieri 2009-04-08 09:31:09 EDT
oops, I forgot to mention the fact that I still have no display.  I thought things had worked, but that was because I went back to the nv driver.  I have not tried setting nouveau.noagp=1 on the kernel command line.  I will try that tonight.

One thing I'll mention, just FYI, is that when I was running the nv driver and had my display set to 1440 x 1050, which is the normal setting for my laptop, the root window did not use the entire physical display.  There was about 1 inch of blank screen on either side of the root window.
Comment 40 pgaltieri 2009-04-08 22:31:20 EDT
Well we have progress.  If I run with nouveau.noagp=1 I get the gdm login displayed (YAAAYYY! :-)

I am attaching the output of radeontool-nv regs and the Xorg.0.log files.

Thanks
Comment 41 pgaltieri 2009-04-08 22:32:15 EDT
Created attachment 338833 [details]
radeontool-nv output for nouveau
Comment 42 pgaltieri 2009-04-08 22:32:48 EDT
Created attachment 338836 [details]
xorg log file
Comment 43 Ben Skeggs 2009-04-09 00:49:38 EDT
Ok, awesome.  I'm not really certain what we'll be able to do regarding AGP issues.  They tend to be very card/chipset specific.  The only likely option is going to be to instruct people to disable AGP all-together.

I'll be changing noagp to agpmode at some point in the future however.  One of my cards at home has issues running in AGP 4x mode, but 2x is fine.
Comment 44 pgaltieri 2009-04-09 01:55:56 EDT
There still may be an issue.  After the gdm login prompt I logged in and everything seemed to be OK.  I walked a way for a while and when I cam back I got the password prompt popup after the screen locked, but it's not taking any keystrokes.  The mouse moves around fine but no keyboard response.  Restarting the Xserver corrected the problem.
Comment 45 Ben Skeggs 2009-04-09 02:11:33 EDT
Can you post /var/log/Xorg.0.log.old and /var/log/messages from after you restarted X?
Comment 46 pgaltieri 2009-04-09 09:18:59 EDT
Created attachment 338902 [details]
messages file

/var/log/messages
Comment 47 pgaltieri 2009-04-09 09:20:00 EDT
Created attachment 338903 [details]
X log file

Xorg.0.log.old
Comment 48 Ben Skeggs 2009-04-10 19:22:38 EDT
Not strictly related to your latest issue, but are you able to grab a radeontool dump while using LVDS and DVI at the same time.  Doing this with the binary driver would be ideal, but if this isn't possible and the VBIOS sets up both if you boot with DVI plugged in, from a console will be fine.

Have you had any more recurrences of the issue you mention in #44?  I didn't see anything revealing in the latest logs unfortunately.
Comment 49 pgaltieri 2009-04-11 13:15:27 EDT
I have not seen a re-occurrence of the problem so don't spend any time worrying about it.

However, I just booted up the snapshot live cd and I get no graphics, just a black screen and no way to change any kernel parameters.  I'll check to see if a bug has already been filed against this and if there isn't one I'll file one.  I hope this issue gets resolved in some way before the final release.
Comment 50 Ben Skeggs 2009-04-30 20:36:16 EDT
Did you ever manage to grab those radeontool-nv dumps mentioned in comment 48?
Comment 51 Bug Zapper 2009-06-09 07:39:27 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 52 Matěj Cepl 2009-11-05 13:22:21 EST
Since this bugzilla report was filed, there have been several major updates in various components of the Xorg system, which may have resolved this issue. Users who have experienced this problem are encouraged to upgrade their system to the latest version of their packages. For packages from updates-testing repository you can use command

yum upgrade --enablerepo='*-updates-testing'

Alternatively, you can also try to test whether this bug is reproducible with the upcoming Fedora 12 distribution by downloading LiveMedia of F12 Beta available at http://alt.fedoraproject.org/pub/alt/nightly-composes/ . By using that you get all the latest packages without need to install anything on your computer. For more information on using LiveMedia take a look at https://fedoraproject.org/wiki/FedoraLiveCD .

Please, if you experience this problem on the up-to-date system, let us now in the comment for this bug, or whether the upgraded system works for you.

If you won't be able to reply in one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.

[This is a bulk message for all open Fedora Rawhide Xorg-related bugs. I'm adding myself to the CC list for each bug, so I'll see any comments you make after this and do my best to make sure every issue gets proper attention.]
Comment 53 Matěj Cepl 2010-02-26 07:23:02 EST
Could you please reply to the previous question? If you won't reply in one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.

[Note please, that this is machine generated comment for large amount of bugs; due to some technical issues, it is possible we've missed some of the responses -- it is happens, please, just a make a comment about that; that we will see. Thank you]
Comment 54 Bug Zapper 2010-04-27 09:03:15 EDT
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 55 Bug Zapper 2010-06-28 07:21:09 EDT
Fedora 11 changed to end-of-life (EOL) status on 2010-06-25. Fedora 11 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.
Comment 56 pgaltieri 2014-06-09 15:35:56 EDT
I got the following email:

The following is a list of requests people have made of you, which have been
outstanding more than 7 days. To avoid disappointing others, please deal with
them as quickly as possible.

needinfo

The bug is closed, I'm fine with that, what am I supposed to do?
Comment 57 Adam Williamson 2014-06-09 15:37:42 EDT
by posting a comment, you just did it :) sorry about that.

Note You need to log in before you can comment on or make changes to this bug.