Bug 487550 - kdeedu libs conflict with yum update of 2009-02-25
kdeedu libs conflict with yum update of 2009-02-25
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kdeedu (Show other bugs)
10
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
http://www.graphics-muse.org/wp/?p=455
: Reopened
: 487815 497915 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-26 12:13 EST by Michael J. Hammel
Modified: 2014-01-21 01:12 EST (History)
14 users (show)

See Also:
Fixed In Version: 4.2.1-2.fc10.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-02 13:17:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael J. Hammel 2009-02-26 12:13:56 EST
Description of problem:

Yum update on 2009-02-25 on x86-64 system encountered following error:
Transaction Check Error:
file /usr/lib64/libmarblewidget.so.4 conflicts between attempted installs of kdeedu-libs-4.1.2-2.fc10.x86_64 and kdeedu-marble-4.2.0-7.fc10.x86_64

How reproducible:
I believe this will only occur if you have digikam-libs installed.

Additional info:
Remove digikam-libs first, then do the update and the kdeedu libs conflict goes away.  digikam-libs cannot be reinstalled after this.
Comment 1 Rex Dieter 2009-02-26 12:34:21 EST
Seth, any ideas why yum isn't including kdeedu-libs-4.2.0 in the tranaction when installing/upgrading kdeedu-marble-4.2.0?  

(I'll go double check to see if we have any horked Obsoletes or something).

I'd really hate to have to put into kdeedu-marble:
Conflicts: kdeedu-libs < 4.2.0
Comment 2 Kevin Kofler 2009-02-26 12:40:24 EST
I suspect there's simply some broken mirror which does not have the current kdeedu-libs package.
Comment 3 Rex Dieter 2009-02-26 12:47:14 EST
Maybe has something to do with kdeedu-libs-4.1.x and kdeedu-marble-4.2.0 both Providing libmarblewidget.so.4
Comment 4 Rex Dieter 2009-02-26 12:48:09 EST
Michael, do you recall what was installed prior to the update?
rpm -q kdeedu kdeedu-libs digikam
so that I can see if I can reproduce what's going on.
Comment 5 Michael J. Hammel 2009-02-26 13:06:02 EST
Unfortunately I don't.  That's also the only 64bit box I have installed at the moment. If I run the rpm query now I just get that none of those packages are currently installed.  I have one other F10 box at home that has not been updated yet and that has digikam installed but no kdeedu libs.  It reports:

mjhammel(tty1)$ rpm -q kdeedu kdeedu-libs digikam
package kdeedu is not installed
package kdeedu-libs is not installed
digikam-0.10.0-0.12.beta8.fc10.i386

If you check the URL for this report it points to my blog entry about this issue. You'll find a link to the German FedoraForum entry where I found the tip about removing digikam.  The person who posted there might have additional information on how they figured out it was digikam that needed to be removed.
Comment 6 Rex Dieter 2009-02-26 13:06:26 EST
Minimal reproducer:
install kdeedu-libs-4.1.2 ,  from f10 release
yum install digikam
pulls latest digikam, kdeedu-marble into transaction -> boom.


I can't find any scenario where just:  yum update  
fails.
Comment 7 Rex Dieter 2009-02-26 13:13:59 EST
shrug, the forum posts seem inconclusive, mentioning even that the problem went away in subsequent reboots/updates, so let's consider the matter closed... unless we see any new evidence to the contrary.
Comment 8 Rex Dieter 2009-03-03 15:43:58 EST
*** Bug 487815 has been marked as a duplicate of this bug. ***
Comment 9 Rex Dieter 2009-03-03 15:47:29 EST
reopening, got details in #fedora-kde today.

An initial f10 kde install with kdeedu will exhibit this.

[14:20] <Tuju_> Transaction Check Error:
[14:20] <Tuju_>   file /usr/lib/kde4/plugins/marble/CompassFloatItem.so conflicts between attempted installs of kdeedu-marble-4.2.0-7.fc10.i386 and kdeedu-libs-4.1.2-2.fc10.i386
[14:20] <Tuju_>  inchi                        i386   1.0.2-0.3.fc9              fedora    563 k
[14:20] <Tuju_>  kdeedu-libs                  i386   4.1.2-2.fc10               fedora    998 k
[14:20] <Tuju_>  kdeedu-marble                i386   4.2.0-7.fc10               updates    18 M
[14:20] <Tuju_>  libmsn                       i386   4.0-0.10.beta4.fc10        updates   316 k

Not sure how/why yum isn't trying to update kdeedu-libs-4.2.0 as well here.

A workaround is to first:
yum update yum

Seth, would adding 
Conflicts: kdeedu-libs < 4.2.0 
to kdeedu-marble help f10's stock yum resolve this?
Comment 10 Rex Dieter 2009-03-03 15:49:36 EST
Details are that we split marble into a subpackage (in kde-4.2.0 update) so that other apps could depend on it, see bug #470577
Comment 11 Rex Dieter 2009-03-25 10:08:09 EDT
Shrug, workaround known (comment #9, "yum update yum" first)

and, I'll add the Conflicts mentioned there too (not sure if it'll help...) for the upcoming kde-4.2.2 update.
Comment 12 Rex Dieter 2009-03-25 10:18:18 EDT
Maybe a less-bad solution (which I'll try first) is to add to -marble:
Requires: kdeedu-libs = %{version}-%[release}
at the expense of adding (almost) ~2mb of not-strictly-required bloat
Comment 13 Rex Dieter 2009-03-25 10:20:08 EDT
reopen, pending update.
Comment 14 Fedora Update System 2009-03-25 13:20:49 EDT
kdeedu-4.2.1-2.fc10.1 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/kdeedu-4.2.1-2.fc10.1
Comment 15 Fedora Update System 2009-03-25 13:20:59 EDT
kdeedu-4.2.1-2.fc9.1 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/kdeedu-4.2.1-2.fc9.1
Comment 16 Fedora Update System 2009-03-26 10:54:05 EDT
kdeedu-4.2.1-2.fc10.1 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kdeedu'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-3059
Comment 17 Fedora Update System 2009-03-27 10:55:51 EDT
gpsd-2.39-3.fc10, kdeedu-4.2.1-3.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gpsd kdeedu'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-3059
Comment 18 Fedora Update System 2009-04-02 13:11:13 EDT
kdeedu-4.2.1-2.fc9.1 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 19 Fedora Update System 2009-04-02 13:17:27 EDT
kdeedu-4.2.1-2.fc10.1 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 20 Frank Schmizz 2009-04-15 12:17:24 EDT
I just installed Fedora 10 X64 and after installation wanted to do a yum update but was still bitten by this bug.
Comment 21 Rex Dieter 2009-04-27 16:37:20 EDT
*** Bug 497915 has been marked as a duplicate of this bug. ***
Comment 22 Rex Dieter 2009-04-27 16:39:05 EDT
rats, it's down to yum not handling the update, our only/best workaround is to 

yum update yum
first, before doing subsequent updating.
Comment 23 Ian Collier 2009-04-29 11:06:45 EDT
I have a similar bug where just "yum update" breaks:

$ yum update
kdeedu-marble-4.2.1-2.fc10.1.x86_64 from updates has depsolving problems
  --> kdeedu-marble conflicts with kdeedu-libs
Error: kdeedu-marble conflicts with kdeedu-libs
$ rpm -qa | egrep kdeedu
[no output]
$ rpm -q digikam
digikam-0.10.0-0.11.beta7.fc10.x86_64

However, this seems to be nondeterministic.  I have a few global excludes which ought to be irrelevant:

exclude=xorg-x11-server-Xorg xorg-x11-drv-* kmod-* kernel* cups*

but if I use a yum config which omits this line (and is otherwise identical) then it manages to solve the dependencies.

It's weirder than that.  With the exact same config file (including the exclusions), "yum -d7 update" fails but "yum -d8 update" succeeds.  I'll attach the logs of those two commands - they are remarkably dissimilar.

Would "obsoletes" not be better than "conflicts"?
Comment 24 Ian Collier 2009-04-29 11:11:50 EDT
OK, I won't attach the logs because I've just read comment #22.

# yum list yum
Loaded plugins: refresh-packagekit
Excluding Packages in global exclude list
Finished
Installed Packages
yum.noarch                        3.2.20-5.fc10                        installed
Available Packages
yum.noarch                        3.2.21-2.fc10                        updates

As it seems to be fixed in the newer version of yum I guess not much point in worrying about it.
Comment 25 Jimmy Dorff 2009-09-08 16:39:28 EDT
I hit this issue with on Fedora 10 installs. My kickstart enables the update repo and installs the KDE desktop, which causes an installation error due to the above conflicts. 

As a workaround, I've removed KDE from kickstart and install it later. Not ideal but it works.
Comment 26 Jeroen van Meeuwen 2009-09-11 10:55:23 EDT
You can --exclude one of the two conflicting packages, maybe? Put the --exclude in the "repo" configuration directive.
Comment 27 Landon Kelsey 2009-10-02 13:54:04 EDT
great...fantastic...however I have no idea what a kickstart is

and I need to install F10...I had no such problem during the last install of F10

I tried leaving off kdedu from the install menu to no avail.

What can I leave off to allow F10 to install???

Ive tried 5-6 times already
Comment 28 johnc.floridaspam 2009-10-10 11:24:32 EDT
Landon -

Not sure if you have been successful in installing Fedora 10.  Here is what I did.  During the install sequence deselect the Fedora 10 updates repository and complete the install.

Once the system is running you can execute 'yum update yum' in a terminal.  The system should prompt you to update automatically which seems to add the packages in the Fedora 10 updates repository.

Note that if you do not execute the 'yum update yum' prior to the system update, you get the same error.

Anyway, worked for me.
Comment 29 Landon Kelsey 2009-10-24 13:03:29 EDT
simple : I just selected "configure later" and downloaded KDE later!

after much work, I have Fedora 10 as it was before the mess and for that matter even better.

Note You need to log in before you can comment on or make changes to this bug.