Bug 487815 - gpk lists excessive file conflicts when trying to update various KDE packages on 27 Feb 2009
gpk lists excessive file conflicts when trying to update various KDE packages...
Status: CLOSED DUPLICATE of bug 487550
Product: Fedora
Classification: Fedora
Component: gnome-packagekit (Show other bugs)
10
All Linux
low Severity high
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-27 19:10 EST by William M. Quarles
Modified: 2009-03-03 15:43 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-03 15:43:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
List of RPMs initially installed on my system + the two rpmfusion meta-packages (52.90 KB, text/plain)
2009-02-27 19:12 EST, William M. Quarles
no flags Details

  None (edit)
Description William M. Quarles 2009-02-27 19:10:10 EST
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.4) Gecko/2008111217 Fedora/3.0.4-1.fc10 Firefox/3.0.4

Last night I installed Fedora 10 via DVD+R on my entertainment PC. Today I tried updating via both the update service in GNOME as well as yum at the commandline with the same (expected yet unexpected) result.

I have maintained updates on my laptop running Fedora 10 for quite a while, with no errors, and I recall basically making the same package selections when installing on my entertainment PC. I haven't installed any extra packages yet (with the exception of the yum repository meta packages from RPMfusion). From what I could read in the error messages, it seemed to be centered around an rpm that I actually did not have installed before that yum was trying to add: kdeedu-marble. Trying to install that package on it's own using yum at the commandline also failed miserably.

I'm not sure if the problem lies in yum, gnome-packagekit, the Fedora Project yum repositories, or the in the KDE rpms themselves. I have attached a list of all rpms installed on my machine.

Reproducible: Sometimes

Steps to Reproduce:
1. Install my list of packages
2. Let gnome-packagekit find all updates on its own
3. Tell it to install all updates for today
4. Watch it barf on you
5. Move kdeedu-marble and kernel packages out of the yum cache, run rpm -Uvh *.rpm
6. See a bunch of unrelated dependency errors pop up.
7. Try installing kdeedu-marble on it's own using yum at the commandline and watch it barf on you, too.
8. Beat the computer a bit and just run "yum update".
9. Watch everything work fine?
Actual Results:  
Gnome-packagekit or yum screwed something up, but the above resolved it all. I don't understand how.

Expected Results:  
I should not have had to go to all of this trouble! I left my computer open to security leaks for way too long. I'm unsure if the respin of the Fedora Unity Project would have helped due to all of this... stuff...
Comment 1 William M. Quarles 2009-02-27 19:12:13 EST
Created attachment 333566 [details]
List of RPMs initially installed on my system + the two rpmfusion meta-packages

I hope that this helps!
Comment 2 Rex Dieter 2009-03-02 09:41:58 EST
> Trying to install kdeedu-marble on it's own using yum at the
commandline also failed miserably.

Details please.  How so?
Comment 3 Rex Dieter 2009-03-02 09:43:29 EST
May be related to similar report in bug #487550
Comment 4 William M. Quarles 2009-03-02 12:08:15 EST
Rex,

In regards to your Comment #2, it seemed that when trying to install kdeedu-marble alone using yum at the commandline, at this point with all of the packages downloaded into my yum cache, resulted in a very long list of file conflicts between two lists of similar KDE pacakges that came from different versions of KDE. The only fix I was able to find was to just run "yum update" from the commandline. I don't recall whether or not I went to the trouble of clearing out the package cache directories, but that might have been a necessary step as well.

Recall however, that this all started by trying to install the updates using gnome-packagekit in GNOME instead of running "yum update" from the commandline.
Comment 5 Rex Dieter 2009-03-02 14:30:31 EST
So... is it still a problem?  If so, the details regarding the conflicts would be much appreciated.
Comment 6 William M. Quarles 2009-03-02 20:03:33 EST
Apparently it is not (as much of) a problem when using "yum update" from the commandline, but may be a problem when using gnome-packagekit for the first time after installing with a DVD+R made from the original 10 iso at this point. Doing a network install or using a DVD+R of the Fedora Unity Project Respin for 10 might be easy workarounds. Then again, I haven't tried doing a network install yet, so I won't swear by that yet.

I'd rather not recreate it, but in the greater interest of the Project I will do it. This will be the first time that I have ever used a Kickstart file, so I will need to read up on that first.

*What would be a good way to pipe the output from yum and gnome-packagekit into text files in this case?* The output from gnome-packagekit might be small, but getting the output from "yum install kdeedu-marble" is absolutely huge (I'm pretty sure that the list exceeded the number of lines allowed by the terminal window settings I had at the time), so just doing a middle-click might not cut it in this case (i.e. it likely would be more difficult, so I would prefer something a little more automated).
Comment 7 Rex Dieter 2009-03-03 08:51:26 EST
To be clear, doing
yum install kdeedu-marble
on a non-current machine is known-broken (but is mitigated by preceding that with 'yum update).

I'm more interested in conflicts related to simple updates, e.g.  yum update
Comment 8 Rex Dieter 2009-03-03 15:43:58 EST
OK, another person in #fedora-kde saw this and we were able to narrow it down.  definitely a dup of the aforementioned bug.

*** This bug has been marked as a duplicate of bug 487550 ***

Note You need to log in before you can comment on or make changes to this bug.