This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 487563 - RFE: on|off switch for snapshotting
RFE: on|off switch for snapshotting
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
520
All Linux
high Severity medium
: ---
: ---
Assigned To: Justin Sherrill
wes hayutin
:
: 487279 (view as bug list)
Depends On:
Blocks: sat530-snapshots 456995
  Show dependency treegraph
 
Reported: 2009-02-26 13:41 EST by Todd Warner
Modified: 2009-09-10 15:58 EDT (History)
3 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 15:58:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Todd Warner 2009-02-26 13:41:13 EST
Need config option to turn snapshotting on and off. Default should be ON.
Comment 2 Justin Sherrill 2009-02-27 13:44:30 EST
commit	f3648dc8d5ea1b40fd3f9dcf2da2060ef0038571

tree	29e22ba6994d6f83b9aacd3e2270f8d7f8bf3390	tree | snapshot

parent	c72c16026703f6d869793a25b5a51572e3f76654	commit | diff
Comment 3 Justin Sherrill 2009-02-27 13:46:43 EST
commit	fc31da1e7ca310cea2971e26a96dcb474048956a

tree	a895e64c2545c836d02db63c1c8e2fd80591ab27	tree | snapshot

parent	f3648dc8d5ea1b40fd3f9dcf2da2060ef0038571	commit | diff
Comment 4 Todd Warner 2009-02-27 15:54:03 EST
*** Bug 487279 has been marked as a duplicate of this bug. ***
Comment 6 Justin Sherrill 2009-02-27 17:13:49 EST
John,

This is an option in rhn.conf:


take_snapshots = 1

set to 0 to disable snapshots.
Comment 7 Justin Sherrill 2009-02-27 17:30:17 EST
Actually,

change that to:

enable_snapshots = 1


taw pointed out that it is more consistent.
Comment 8 John Ha 2009-02-28 23:52:14 EST
Okay, I've added the following to the release notes. Thanks for working out the details!

 A new configuration option, enable_snapshots, has been added to the 
 /etc/rhn/rhn.conf file. This allows administrators to enable or disable
 capturing system snapshots. By default, snapshots are enabled; to disable it,
 edit the enable_snapshots option to the following:

 enable_snapshots=0
Comment 9 Justin Sherrill 2009-03-04 20:51:14 EST
commit	e21a89a899233c95628c825e25eea6b3efacaab0
tree	3fce0aca978ae7f9df00867c67396179792851ff	tree | snapshot
parent	66e2235ca17df598dfbce505179ab12905745e37	commit | diff

changed to enable_snapshots
Comment 10 wes hayutin 2009-03-26 16:23:40 EDT
didnt make it into 3/23 build.. will wait until next build

[root@grandprix ~]# cat /etc/rhn/rhn.conf | grep snap
[root@grandprix ~]# ls /root/Satellite-5.3.0-RHEL5-re20090323.0-i386-embedded-oracle.iso 
/root/Satellite-5.3.0-RHEL5-re20090323.0-i386-embedded-oracle.iso
[root@grandprix ~]#
Comment 11 wes hayutin 2009-03-30 15:05:59 EDT
not in build yet..
Comment 12 wes hayutin 2009-04-06 15:12:48 EDT
# system snapshots enabled
enable_snapshots = 1

its there.. on 4/3 just need to test it
Comment 13 wes hayutin 2009-04-09 12:25:28 EDT
tested w/ snapshots on.. passes..
turned snapshot off.. restart
installed packages, config channels, files..

no new snapshots taken..
passes
Comment 14 Pradeep Kilambi 2009-08-10 14:24:51 EDT
$ cat /etc/rhn/rhn.conf |grep snapshot
# system snapshots enabled
enable_snapshots = 1

flipped to 0 and restarted satellite and see no noew snapshots being added to the page.

moving to release pending.
Comment 15 Brandon Perkins 2009-09-10 15:58:45 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.