Bug 487651 - Wine compiled without 64bit support
Wine compiled without 64bit support
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: wine (Show other bugs)
11
All Linux
low Severity low
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
:
: 505803 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-27 04:30 EST by The Source
Modified: 2009-09-11 19:30 EDT (History)
2 users (show)

See Also:
Fixed In Version: 1.1.29-1.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-11 19:30:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description The Source 2009-02-27 04:30:19 EST
Description of problem:
Current wine (1.1.15) supports 64bit executables. However, wine packages in repository are compiled without that support.
"Trying to load PE image for unsupported architecture (AMD-64)".
I thing now it has sense to compile wine for 64bit.

Version-Release number of selected component (if applicable):
1.1.15

How reproducible:
always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Andreas Bierfert 2009-02-28 02:23:15 EST
It is not as easy as you might think:

Wine can either do 64bit xor 32bit. Also only the gcc version which is in rawhide now could do the 64bit compile.

It is planned for the future to build both 32bit and 64bit versions for the x86_64 repos but this will take some more time and might not happen for F11.

Thanks for submitting the bug. Will use as feature tracker.
Comment 2 Bug Zapper 2009-06-09 07:41:28 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Shawn Starr 2009-06-14 07:53:28 EDT
*** Bug 505803 has been marked as a duplicate of this bug. ***
Comment 4 Fedora Update System 2009-09-01 14:06:50 EDT
wine-1.1.28-1.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update wine'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-9220
Comment 5 Fedora Update System 2009-09-04 00:08:37 EDT
wine-1.1.29-1.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update wine'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-9304
Comment 6 Fedora Update System 2009-09-11 19:29:38 EDT
wine-1.1.29-1.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.