Bug 487760 - spurious message: tar: Record size = 8 blocks
spurious message: tar: Record size = 8 blocks
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: tar (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Ondrej Vasik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-27 14:12 EST by Mads Kiilerich
Modified: 2009-07-16 03:02 EDT (History)
4 users (show)

See Also:
Fixed In Version: 1.22-3.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-16 03:02:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mads Kiilerich 2009-02-27 14:12:44 EST
Description of problem:

tar in F11 occasionally prints strange messages to stderr


Version-Release number of selected component (if applicable):

tar-1.21-1.fc11.i386


Steps to Reproduce:

100% reproducible for me with

$ cat slowcat.py 
import sys
for c in file(sys.argv[1]).read(): sys.stdout.write(c)
$ python slowcat.py test2.tar | tar tf - > /dev/null
tar: Record size = 8 blocks
$

It might make sense to warn when data come in strange chunks from a tape device, but when data arrives on a stream it must accept all chunk sizes silently.
 
That is a regression from F10. Currently it causes spurios failures in the Mercurial test suite.
Comment 1 Mads Kiilerich 2009-02-28 21:04:22 EST
I have reported this upstream: http://lists.gnu.org/archive/html/bug-tar/2009-02/msg00010.html

IMHO Fedora should have a fix for this in F11.
Comment 2 Ondrej Vasik 2009-03-01 04:46:18 EST
Thanks for both reports, F11 is still far enough to analyze/fix that ... I planned to look at this on Monday, but maybe Sergey will fix it meanwhile upstream :).
Comment 3 Ondrej Vasik 2009-03-02 11:48:59 EST
From 1.21 NEWS:
** Fixed record size autodetection.  If detected record size differs from
the expected value (either default, or set on the command line), tar
always prints a warning if verbosity level is set to 1 or greater,
i.e. if either -t or -v option is given.

As reading through pipe doesn't guarantee record size and it would almost always differ from expected value, the easiest way would be to fix Mercurial test suite. 

But maybe Sergey will find something acceptable - I'll wait for his reaction and then decide what to do with that bugzilla.
Comment 4 Bug Zapper 2009-06-09 07:42:55 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Ondrej Vasik 2009-06-25 16:17:02 EDT
While checking upstream git, I spotted commit http://git.savannah.gnu.org/cgit/tar.git/commit/?id=be34933b638b75a40513ea2b724c756b1f8e3b85 , which should solve the issue, I'll use it in rawhide. Tried to built as tar-1.22-4.fc12, testsuite failed mysteriously, so not done yet. Anyway will wait for upstream approval of other patch - then will make update for f11 with both fixes.
Comment 6 Ralf Corsepius 2009-07-01 07:39:19 EDT
This bug breaks rpmbuild:

When building a package I work on (on F11)

# make dist
...
# rpmbuild -ts rtems-mock-0.20090701.1.tar.bz2
Wrote: /home/rtems/src/rpms/linux/SRPMS/rtems-mock-0.20090701.1-0.fc11.src.rpm

# rpm -qlvp /home/rtems/src/rpms/linux/SRPMS/rtems-mock-0.20090701.1-0.fc11.src.rpm

rpm -qlp /home/rtems/src/rpms/linux/SRPMS/rtems-mock-0.20090701.1-0.fc11.src.rpm
rtems-mock-0.20090701.1.tar.bz2
tar: Record size = 8 blocks

=> This bug causes rpmbuild -ts to add the warning to the *.src.rpm instead of adding the *.spec => the src.rpm is broken.
Comment 7 Ondrej Vasik 2009-07-01 08:23:18 EDT
F-12 build still not working, I guess it's gcc issue with FORTIFY_SOURCE(as the tar testsuite failure backtrace points there). The same tar srpm build just fine with dist-f11 - https://koji.fedoraproject.org/koji/taskinfo?taskID=1436136 ... could you try those rpm? Maybe I could do F-11 update meanwhile (before F-12 troubles solved).
Comment 8 Ralf Corsepius 2009-07-01 12:05:44 EDT
(In reply to comment #7)
> https://koji.fedoraproject.org/koji/taskinfo?taskID=1436136 ... could you try
> those rpm?
I rebuilt the rpms from Fedora's devel CVS repository on FC11 and gave them a try (tar-1.22-4.fc11.x86_64).

So far, things look promissing - At least, my rpmbuild issue hasn't reappeared since then ;)
Comment 9 Fedora Update System 2009-07-02 03:02:36 EDT
tar-1.22-3.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/tar-1.22-3.fc11
Comment 10 Fedora Update System 2009-07-03 15:42:41 EDT
tar-1.22-3.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update tar'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-7338
Comment 11 Fedora Update System 2009-07-16 03:02:11 EDT
tar-1.22-3.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.