Bug 487795 - (gcc?) RED! gnome-terminal displays all text with red background
(gcc?) RED! gnome-terminal displays all text with red background
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Fedora Extras Quality Assurance
:
: 488104 (view as bug list)
Depends On:
Blocks: F11Target
  Show dependency treegraph
 
Reported: 2009-02-27 16:57 EST by Warren Togami
Modified: 2009-03-04 15:11 EST (History)
22 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-04 15:11:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNU Compiler Collection 39339 None None None Never

  None (edit)
Description Warren Togami 2009-02-27 16:57:59 EST
After the mass rebuild, upgraded 32bit laptop to all packages.  All text in gnome-terminal suddenly became black with red background.  Huh?

gnome-terminal-2.25.91-2.fc11.i586
vte-0.19.4-4.fc11.i586
Comment 1 Mamoru TASAKA 2009-02-28 01:26:12 EST
Recompiling with replacing "-O2" with "-O0" seems to work
for me, so I guess this is related to gcc optimization.
Comment 2 Mamoru TASAKA 2009-02-28 01:29:49 EST
And also this affects Terminal in XFCE.
Comment 3 Matthias Clasen 2009-02-28 14:16:02 EST
After some bisecting with #pragma optimize "O0", I found that
adding 

__attribute__((optimize (0)))

to _vte_terminal_insert_char is enough to fix vte.
Comment 4 Matthias Clasen 2009-02-28 14:17:55 EST
that function is in src/vte.c
Comment 5 Horst H. von Brand 2009-03-01 13:34:44 EST
I see the same mess with x86_64.
Comment 6 Kyle McMartin 2009-03-01 14:19:21 EST
My guess is a mis-optimization of the structure copies of defaults.attr, going to do a few builds and compare with 4.3 to test.
Comment 7 Jakub Jelinek 2009-03-01 14:48:40 EST
Can you please retry with __attribute__((noinline)) instead of optimize (0) on that function to make sure the problem is really in that function and not in the callers?
Comment 8 Horst H. von Brand 2009-03-01 18:35:21 EST
On x86_64 going back to vte-0.19.4-3.fc11.x86_64 doesn't help.

Also, ncursesw gets colors very wrong on gnome-terminal.
Comment 9 Ben Gamari 2009-03-01 18:44:43 EST
(In reply to comment #8)
> On x86_64 going back to vte-0.19.4-3.fc11.x86_64 doesn't help.
> 
> Also, ncursesw gets colors very wrong on gnome-terminal.
That's odd. I'm on x86_64 and reverting to 0.19.4-3.fc11 worked fine for me.
Comment 10 Ray Strode [halfline] 2009-03-01 21:55:27 EST
When reverting to older vte's, make sure to run:

gnome-terminal --disable-factory

(or pkill -f gnome-terminal)

to make sure new terminal windows aren't just a new instance from the old gnome-terminal process (with the old vte loaded).
Comment 11 Matthias Clasen 2009-03-01 22:36:08 EST
Jakub, with __attribute__((noinline)) it is still broken.
Comment 12 Jakub Jelinek 2009-03-02 05:23:21 EST
Apparently SRA messes things up, temporary workaround -fno-tree-sra.
Comment 13 Horst H. von Brand 2009-03-02 07:19:24 EST
(In reply to comment #9)
> (In reply to comment #8)
> > On x86_64 going back to vte-0.19.4-3.fc11.x86_64 doesn't help.
> > 
> > Also, ncursesw gets colors very wrong on gnome-terminal.
> That's odd. I'm on x86_64 and reverting to 0.19.4-3.fc11 worked fine for me.

Right. After rebooting with the old vte it does work. Sorry.
Comment 14 Matthias Clasen 2009-03-02 11:01:26 EST
I've built 0.19.4-5.f11 with a workaround now.
Comment 15 Dan Young 2009-03-02 15:40:16 EST
*** Bug 488104 has been marked as a duplicate of this bug. ***
Comment 16 sean 2009-03-02 21:03:00 EST
gnome-terminal-2.25.91-2.fc11.i586    WFM

Thanks for a quick response.
Comment 17 Jakub Jelinek 2009-03-04 15:11:53 EST
Should be fixed in gcc-4.4.0-0.22.

Note You need to log in before you can comment on or make changes to this bug.