Bug 487853 - [nvidia driver] Plasma stops responding to user input
[nvidia driver] Plasma stops responding to user input
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: kdebase-workspace (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
: 489268 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-28 05:04 EST by Pavel Zhukov
Modified: 2009-03-09 17:21 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-09 17:21:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/Xorg.0.log (21.85 KB, text/plain)
2009-02-28 05:04 EST, Pavel Zhukov
no flags Details
screenshot (332.95 KB, image/png)
2009-03-01 07:33 EST, Pavel Zhukov
no flags Details

  None (edit)
Description Pavel Zhukov 2009-02-28 05:04:35 EST
Created attachment 333596 [details]
/var/log/Xorg.0.log

After today updates
Plazma buzzies immediately after launch konsole from right-click menu
Comment 1 Rex Dieter 2009-02-28 07:56:00 EST
rpm -q kdelibs kdebase-workspace
please.

And what does "buzzies" mean exactly?
Comment 2 Pavel Zhukov 2009-02-28 09:44:08 EST
rpm -q kdelibs kdebase-workspace
kdelibs-4.2.0-17.fc11.i586
kdebase-workspace-4.2.0-16.fc11.i586


Panel, kicker. taskbar, Desktop not response on clicks (Alt+Tab and Alt+F2 work only). 
I has tried remove ~/.kde too
Comment 3 Pavel Zhukov 2009-03-01 07:33:00 EST
Created attachment 333642 [details]
screenshot
Comment 4 Pavel Zhukov 2009-03-01 07:34:23 EST
Comment on attachment 333642 [details]
screenshot

Taskbar and panel are not response (new launch application do not display on taskbar)
Comment 5 Jacek Nowosielski 2009-03-09 09:03:57 EDT
*** Bug 489268 has been marked as a duplicate of this bug. ***
Comment 6 Rex Dieter 2009-03-09 09:08:13 EDT
We've seen a plethora of nvidia-related issues, all due to driver bugs.

Please try to reproduce without the nvidia drivers, and if so, we'd be happy to explore this further.
Comment 7 Jacek Nowosielski 2009-03-09 11:00:08 EDT
In my case it is reproducable on binary NVidia and regular nv as well.
Comment 8 Klaus-Peter Schrage 2009-03-09 13:26:33 EDT
(In reply to comment #7)
> In my case it is reproducable on binary NVidia and regular nv as well.  

I can't confirm that. Changing the driver in xorg.conf from 'nvidia' to 'nv' wasn't enough for me, the freezing persisted. But after completely removing the nvidia binary driver from my system (running the installer with the '--uninstall' option), plasma seems to be stable with the nv driver.
Comment 9 Rex Dieter 2009-03-09 13:36:36 EDT
True, My understanding is that nvidia's driver installs custom (opengl and other?) libraries, which override the default fedora ones.  So, even if the driver isn't currently enabled, it's mere presence can still have a debilitating effect on system stability.
Comment 10 Kevin Kofler 2009-03-09 17:21:14 EDT
Right, especially if you use the broken installer from NVidia's web page. Never use that installer! The only safe way to clean up its mess is to reinstall Fedora.

RPM Fusion's packages are more respectful of Fedora's system libraries, so at least they uninstall properly.

But neither Fedora (which doesn't even ship the buggy driver) nor RPM Fusion (which can only ship the binaries NVidia provides and has no access to the source code) can fix your issue, because it's a driver bug. Please report to NVidia.

Note You need to log in before you can comment on or make changes to this bug.