Bug 487906 - ICH10 AHCI with Existing RAID0 not detected for install. F10 x86_64 release DVD.
ICH10 AHCI with Existing RAID0 not detected for install. F10 x86_64 release ...
Status: CLOSED DUPLICATE of bug 488961
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
10
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-01 04:32 EST by Jeffrey R. Evans
Modified: 2009-03-06 11:43 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 488961 (view as bug list)
Environment:
Last Closed: 2009-03-06 11:43:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeffrey R. Evans 2009-03-01 04:32:30 EST
Description of problem:
Attempt to install F10 x86_64 release on system that has ICH10 AHCI RAID0 Array.  No storage device available

Version-Release number of selected component (if applicable):
F10 X86_64 Release DVD.  Also occurs with F10 X86_64 Live Spins.

How reproducible:
100%

Steps to Reproduce:
1.Insert F10x86_64 install DVD into bootable DVD.
2.Boot to DVD.
3.Select any settings until you get to the partitioning options.
4.Attempt to configure partitions of any type on existing RAID0 Array.
  
Actual results:
The AHCI ICH10 RAID0 is not detected.

Expected results:
Expect choices available to create a partition, and select created partition for Fedora installation.

Additional info:
Gigabyte GA-EP45-DS3R Motherboard HW rev 2.0
F9 BIOS
Intel QX9650 Core 2 Extreme processor
WDC5000AAKKS SATAII drives 2ea. in RAID0 from the Intel ICH10r AHCI RAID controller.  3 Existing NTFS partitions. 125G 125G and 500G in that order.
2G DDR2 Corsair PC6400 (2x1)
Evga 7900GT video
Lite-On LH201AL SATA DVD burner


Note: F8 x86_64 Release DVD works.  Then upgrade to F9 gets ugly.
Comment 2 Chris Lumens 2009-03-02 09:26:02 EST
If you switch to tty2 and run lshal, does it see the device?
Comment 3 Jeffrey R. Evans 2009-03-03 10:18:30 EST
To switch to tty2 use CTR+ALT+F2 and then run lshal?   I'll give that a try.
Comment 4 Jeffrey R. Evans 2009-03-03 11:43:22 EST
I piped the lshal output to a txt file and the Intel 82801 SATA RAID Controller was listed in that txt file.

While in tty2:
I checked in the /dev/mapper directory and found only Control.  No entries for the RAID partitions. 

I ran "dmraid -ay".  Rechecked /dev/mapper and the entries for the RAID partitions were there as expected.

Moving back to tty1:
I attempted to proceed with Anaconda to partition or use one of the existing partitions.   In the storage device selection window of Anaconda the RAID and it's existing partitions are still not shown.   It does find the first of the two 500G drives that comprise the RAID and asks if I would like to initialize an LVM.  It warns that this would erase any existing data on the devices.  I click NO.  

Install stalls at that point, lacking any viable storage media to install upon.
Comment 5 Chris Lumens 2009-03-06 11:43:21 EST
I see you've opened a clone of this bug against rawhide.  I'm going to close this one out then as we have totally new storage code to work with since F10 and that's where we should be pursuing this problem.  Thanks for the information.

*** This bug has been marked as a duplicate of bug 488961 ***

Note You need to log in before you can comment on or make changes to this bug.