Bug 488961 - ICH10 AHCI with Existing RAID0 not detected for install. F11 x86_64 Alpha DVD.
ICH10 AHCI with Existing RAID0 not detected for install. F11 x86_64 Alpha DVD.
Status: CLOSED DUPLICATE of bug 489148
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
: 487906 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-06 10:06 EST by Jeffrey R. Evans
Modified: 2009-03-08 04:25 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 487906
Environment:
Last Closed: 2009-03-08 04:25:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeffrey R. Evans 2009-03-06 10:06:18 EST
+++ This bug was initially created as a clone of Bug #487906 +++

Description of problem:
Attempt to install F11 x86_64 Alpha release on system that has ICH10 AHCI RAID0 Array.  No storage device available

Version-Release number of selected component (if applicable):
F11 X86_64 Alpha Release DVD.  Also occurs with F11 X86_64 Alpha netinst.iso spin.

How reproducible:
100%

Steps to Reproduce:
1.Insert F11x86_64 install DVD into bootable DVD.
2.Boot to DVD.
3.Select any settings until you get to the partitioning options.
4.Attempt to configure partitions of any type on existing RAID0 Array.
  
Actual results:
The AHCI ICH10 RAID0 is not detected.

Expected results:
Expect choices available to create a partition, and select created partition for Fedora installation.

Additional info:
Gigabyte GA-EP45-DS3R Motherboard HW rev 2.0
F9 BIOS
Intel QX9650 Core 2 Extreme processor
WDC5000AAKKS SATAII drives 2ea. in RAID0 from the Intel ICH10r AHCI RAID controller.  3 Existing NTFS partitions. 125G 125G and 500G in that order.
2G DDR2 Corsair PC6400 (2x1)
Evga 7900GT video
Lite-On LH201AL SATA DVD burner


Note: F8 x86_64 and F9 x86_64 Releases work.  

Public SMOLTs Link:
http://www.smolts.org/show?uuid=pub_20248e1a-d721-4b67-b984-a18de88fcf20
Comment 1 Chris Lumens 2009-03-06 11:43:21 EST
*** Bug 487906 has been marked as a duplicate of this bug. ***
Comment 2 Hans de Goede 2009-03-08 04:25:55 EDT
Hi All,

dmraid support in anaconda / mkinitrd unfortunately is not in a good shape in F-10 (nor in F-11 alpha). I've been working very hard lately to fix this, and F-11 will be much better!

There are a number of underlying causes to these problems, all of which have been identified and fixed in rawhide I believe.

Unfortunately rawhide is currently not in a good shape to ask you to test it. We hope to organize a dmraid test day, within 2 weeks, where we will ask the community to test dmraid support in rawhide (the upcoming F-11 development version).

In the mean time I'm closing all the open anaconda dmraid bugs, against a single master bug, for easier tracking, as all the open bugs have the same underlying cause (2 bugs in pyblock, which have been fixed).

If you're interested in participating in the test day, please add yourself to the CC of the master bug, I will add a comment there with a pointer to the announcement for the test day as soon as the date has been fixed.

*** This bug has been marked as a duplicate of bug 489148 ***

Note You need to log in before you can comment on or make changes to this bug.