Bug 487924 - GNOME Packagekit service fails to cancel search
GNOME Packagekit service fails to cancel search
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-packagekit (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
: 496061 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-01 09:02 EST by Emanuele Bellini
Modified: 2009-06-02 10:19 EDT (History)
5 users (show)

See Also:
Fixed In Version: 0.3.15-3.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-02 10:19:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
An example of error message all listed programs give (1.23 KB, text/plain)
2009-03-01 09:02 EST, Emanuele Bellini
no flags Details

  None (edit)
Description Emanuele Bellini 2009-03-01 09:02:27 EST
Created attachment 333645 [details]
An example of error message all listed programs give

Description of problem:
When I cancel a search of a packet, I can begin another search while the other is cancelling. The result is that the package database isn't closed and I can't search/install/update packages unless I restart my computer.


Version-Release number of selected component (if applicable):
gnome-packagekit-0.3.14-1.fc10.i386
(I've taken this with the RPM -q command... Strange, this does work unlike gnome-packagekit, Yum extender and System update)


How reproducible:
always


Steps to Reproduce:
1.open System\Administration\Add/Remove software...
2.search for something;
3.when the search is running, stop it with the Cancel button;
4.while under the list of the categories there is written "Cancelling...", start the search again;


Actual results:
a message box appears, saying that the process had to be killed to be canceled.
Now I can't use the programs I said above: gnome-packagekit, Yum extender and System update: they say the package database is corrupted.


Expected results:
the search button should be disabled while the search is cancelling, preventing the error to take place.


Additional info:
other related bugs (they have the same error as mine, but they haven't given other details): 430108 , 219579
Comment 1 Emanuele Bellini 2009-03-01 09:04:54 EST
Moreover, it seems after rebooting the system the error disappears.
Comment 2 Richard Hughes 2009-03-02 05:17:36 EST
We've added some code in yum to be more proactive closing package references, and also allowing the backend more time to close gracefully. have you tried with the packages in rawhide?
Comment 3 Emanuele Bellini 2009-03-04 10:20:57 EST
To avoid messing up my computer I've just tried to reproduce that in the Fedora 11 Alpha snapshot. I can reproduce the bug.
When I threw another search before the old had been closed, I had the same error message saying the thread had to be killed etc. After, when the search had finished, it appeared an error message, but it hasn't seemed important. I could see the results of the search. Now I tried another search and in a notification window it says:

Package manager: backend warning
rpmdb: Thread/process 3354/3087300288 failed: thread died in Berkeley DB library.

And I can see the old results, but the program is waiting for the launching of the searching service (so it seems the new search hasn't been launched) and it's stuck.
What? I need an English course? Sorry, I agree.
Comment 4 Emanuele Bellini 2009-03-07 06:49:16 EST
Here it is the correct error message when I try to make a search when the provious one was cancelling:

The task was forcibly cancelled
The task was cancelled successfully and no packages were changed. The backend did not exit cleanly.
More details --> Process had to be killed to be cancelled.

Now I start another search, I have the same error message as above (I'm copying it):

Package manager: backend warning
rpmdb: Thread/process 3354/3087300288 failed: thread died in Berkeley DB
library.

And it's endless.
I can't make other searches because the queries don't end up.
Now if I go to, for example, System Update I have the same error message and the program can't go on.
Comment 5 Emanuele Bellini 2009-04-10 09:28:54 EDT
I had the same backtrace when I tried to update my system... There should be something wrong...
Comment 6 Christoph Wickert 2009-05-12 18:10:30 EDT
*** Bug 496061 has been marked as a duplicate of this bug. ***
Comment 7 Christoph Wickert 2009-05-12 18:23:26 EDT
I'm seeing this to, even if I have not canceled a search in gnome-packagekit or even used it. Only gkp-update-icon was running.

In bug #479818 comment #18 someone reported exactly the same problem with caneling searches.

In bug #495087 comment #14 Panu pointed out that it's probably caused by packagekit sending SIGKILL.

Last but not least I think bug # 498328 is the same for rawhide.
Comment 8 Richard Hughes 2009-05-13 03:54:52 EDT
In rawhide and f11, we are not sending SIGKILL to rpm processes any more. It was just too dangerous. This probably just needs backporting to F10.
Comment 9 Richard Hughes 2009-05-13 04:31:28 EDT
Can you all give the following F10 rpm's a try please: http://koji.fedoraproject.org/koji/taskinfo?taskID=1352133

This is patched to never do SIGKILL, just like the F11 version.
Comment 10 Emanuele Bellini 2009-05-13 09:08:02 EDT
That's fine, it does work!
Of course it takes more time to cancel a search now (about 15 seconds), anyway it's better than before! Moreover, my computer is old, so that's OK!
Comment 11 Christoph Wickert 2009-05-13 11:16:26 EDT
Seems to work reliable so far. I have canceled a lot of searches and didn't manage do get my system into a state where I had to reboot. gpk-application interface remains responsive to new commands.
Comment 12 Fedora Update System 2009-05-13 12:15:30 EDT
PackageKit-0.3.15-3.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/PackageKit-0.3.15-3.fc10
Comment 13 Fedora Update System 2009-05-13 22:53:09 EDT
PackageKit-0.3.15-3.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update PackageKit'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-4933
Comment 14 Fedora Update System 2009-06-02 10:19:21 EDT
PackageKit-0.3.15-3.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.