Bug 498328 - Package Kit Manager Crashes
Package Kit Manager Crashes
Status: CLOSED DUPLICATE of bug 430108
Product: Fedora
Classification: Fedora
Component: gnome-packagekit (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
: 498101 498340 498827 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-29 17:03 EDT by Jerry Purvis
Modified: 2009-06-03 05:31 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-03 05:31:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jerry Purvis 2009-04-29 17:03:32 EDT
Description of problem:

rror Type: <type 'exceptions.TypeError'>
Error Value: rpmdb open failed
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 2316, in <module>
    main()
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 2312, in main
    backend = PackageKitYumBackend('', lock=True)
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 182, in __init__
    self.yumbase = PackageKitYumBase(self)
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 2255, in __init__
    self.repos.confirm_func = self._repo_gpg_confirm
  File : /usr/lib/python2.5/site-packages/yum/__init__.py, line 589, in <lambda>
    repos = property(fget=lambda self: self._getRepos(),
  File : /usr/lib/python2.5/site-packages/yum/__init__.py, line 395, in _getRepos
    self._getConfig() # touch the config class first
  File : /usr/lib/python2.5/site-packages/yum/__init__.py, line 192, in _getConfig
    self._conf = config.readMainConfig(startupconf)
  File : /usr/lib/python2.5/site-packages/yum/config.py, line 774, in readMainConfig
    yumvars['releasever'] = _getsysver(startupconf.installroot, startupconf.distroverpkg)
  File : /usr/lib/python2.5/site-packages/yum/config.py, line 844, in _getsysver
    idx = ts.dbMatch('provides', distroverpkg)



Version-Release number of selected component (if applicable):


How reproducible:  Attempted uninstall of rubygem sqlite3 interface through Gnome's Package Kit Manager.


Steps to Reproduce:
1.System, Administration, Add/Remove Programs
2.Search Ruby
3.Uninstall RubyGem sqlite3 interface
  
Actual results:


Expected results:


Additional info:
Comment 1 Christoph Wickert 2009-05-12 17:35:03 EDT
*** Bug 498101 has been marked as a duplicate of this bug. ***
Comment 2 Christoph Wickert 2009-05-12 17:36:49 EDT
*** Bug 498340 has been marked as a duplicate of this bug. ***
Comment 3 Christoph Wickert 2009-05-12 17:51:08 EDT
*** Bug 498827 has been marked as a duplicate of this bug. ***
Comment 4 Christoph Wickert 2009-05-12 18:01:22 EDT
Note that this is not necessarily a PackageKit bug but an rpm but, because it also affects pup, yum and rpm itself as described in bug # 498827 and # 430108.
Comment 5 Richard Hughes 2009-06-03 05:31:14 EDT

*** This bug has been marked as a duplicate of bug 430108 ***

Note You need to log in before you can comment on or make changes to this bug.