Bug 487963 - Options Error: Error parsing 'packages\n': "packages " is not an allowed value
Options Error: Error parsing 'packages\n': "packages " is not an allowed value
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: python-iniparse (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Tim Lauridsen
Fedora Extras Quality Assurance
:
: 488214 (view as bug list)
Depends On:
Blocks: F11Target
  Show dependency treegraph
 
Reported: 2009-03-01 14:46 EST by Nicolas Mailhot
Modified: 2009-03-03 05:13 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-02 15:36:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Nicolas Mailhot 2009-03-01 14:46:27 EST
python-iniparse = 0.3.0-1.fc11 breaks yum

================================================================================
 Package              Arch        Version            Repository            Size
================================================================================
Updating:
 python-iniparse      noarch      0.3.0-1.fc11       rawhide               38 k
Skipped (dependency problems):
 yum-utils            noarch      1.1.20-1.fc11      koji-f11-builds       72 k

Transaction Summary
================================================================================
Install      0 Package(s)         
Update       1 Package(s)         
Remove       0 Package(s)         

Total download size: 38 k
Downloading Packages:
python-iniparse-0.3.0-1.fc11.noarch.rpm                  |  38 kB     00:00     
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Updating       : python-iniparse                                          1/2 
  Cleanup        : python-iniparse                                          2/2 

Updated:
  python-iniparse.noarch 0:0.3.0-1.fc11                                         

Skipped (dependency problems):
  yum-utils.noarch 0:1.1.20-1.fc11                                              

Complete!
#  yum clean all;yum --skip-broken -y update -x apanov-edrip-fonts -x apanov-heuristica-fonts
Loaded plugins: dellsysidplugin2, refresh-packagekit
Options Error: Error parsing 'packages\n': "packages
" is not an allowed value
Loaded plugins: dellsysidplugin2, refresh-packagekit
Options Error: Error parsing 'packages\n': "packages
" is not an allowed value
Comment 1 Tim Lauridsen 2009-03-02 06:30:12 EST
I can reproduce the error, it look like it breaks som yum plugins option code.

yum --noplugins <some cmd> is still working

I will track down the issue, and come back with more information
Comment 2 Tim Lauridsen 2009-03-02 07:21:52 EST
Ok, it was an regreation from upstream iniparse

I have made a new build with an upstream patch (0.3.0-2)

you can update using

yum update python-iniparse --noplugins

when the build hits rawhide or get the koji rpm here:
http://kojipkgs.fedoraproject.org/packages/python-iniparse/0.3.0/2.fc11/noarch/python-iniparse-0.3.0-2.fc11.noarch.rpm
Comment 3 Tim Lauridsen 2009-03-03 05:13:41 EST
*** Bug 488214 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.