Bug 488214 - yum does not start any more since yesterdays updates (March, 2nd 2009)
yum does not start any more since yesterdays updates (March, 2nd 2009)
Status: CLOSED DUPLICATE of bug 487963
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
low Severity urgent
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-03 04:05 EST by Thomas Schweikle
Modified: 2014-01-21 18:08 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-03 05:13:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Schweikle 2009-03-03 04:05:36 EST
Description of problem:
yum does not start any more since yesterdays updates (March, 2nd 2009).
Only "options error: illegal boolean value" is exausted. This even if I only type "yum" on the command line!

Version-Release number of selected component (if applicable):
anaconda-yum-plugins-1.0-4.fc11.noarch
PackageKit-yum-0.4.4-4.fc11.i586
PackageKit-yum-plugin-0.4.4-4.fc11.i586
yum-3.2.21-11.fc11.noarch
yum-aliases-1.1.19-3.fc11.noarch
yum-allowdowngrade-1.1.19-3.fc11.noarch
yum-arch-2.2.2-5.fc11.noarch
yum-changelog-1.1.19-3.fc11.noarch
yum-cron-0.8.3-2.fc11.noarch
yum-downloadonly-1.1.19-3.fc11.noarch
yumex-2.0.5-6.fc11.noarch
yum-fastestmirror-1.1.19-3.fc11.noarch
yum-fedorakmod-1.1.19-3.fc11.noarch
yum-kernel-module-1.1.19-3.fc11.noarch
yum-list-data-1.1.19-3.fc11.noarch
yum-merge-conf-1.1.19-3.fc11.noarch
yum-metadata-parser-1.1.2-12.fc11.i586
yum-presto-0.4.5-3.fc11.noarch
yum-priorities-1.1.19-3.fc11.noarch
yum-protectbase-1.1.19-3.fc11.noarch
yum-protect-packages-1.1.19-3.fc11.noarch
yum-refresh-updatesd-1.1.19-3.fc11.noarch
yum-security-1.1.19-3.fc11.noarch
yum-tmprepo-1.1.19-3.fc11.noarch
yum-tsflags-1.1.19-3.fc11.noarch
yum-updateonboot-1.1.19-3.fc11.noarch
yum-updatesd-0.9-2.fc11.noarch
yum-upgrade-helper-1.1.19-3.fc11.noarch
yum-utils-1.1.19-3.fc11.noarch
yum-versionlock-1.1.19-3.fc11.noarch


How reproducible:
Every time

Steps to Reproduce:
1. Upgrade via "yum update" to the March, 3rd 2009 release
2. yum breaks
3.
  
Actual results:
yum exausting "Options error: illegal boolean value"

Expected results:
yum working

Additional info:
Comment 1 Tim Lauridsen 2009-03-03 05:13:41 EST

*** This bug has been marked as a duplicate of bug 487963 ***
Comment 2 Tim Lauridsen 2009-03-03 05:14:54 EST
yum update python-iniparse --noplugins

should fix the issue
Comment 3 Thomas Schweikle 2009-03-03 06:20:40 EST
No, does not, since python-iniparse is already the latest version! I've tried to to remove python-iniparse and then reistall it. Same.

# yum update
Options error: illegal boolean value

# yum
Options error: illegal boolean value

# yum update --noplugins
Setting up update process
No Packages marked for Update

# yum update python-iniparse --noplugins
Setting up update process
No Packages marked for Update

# yum reinstall python-iniparse --noplugins
Settion up Reinstall process
Error: Problem in reinstall: no package matched to install

# yum install python-iniparse --noplugins
Setting up Install process
Package matching python-iniparse-0.2.4-1.fc11.noarch already installed. Checking for update. Nothing to do.

# rpm -qa | grep -i iniparse
python-iniparse-0.3.0-1.fc11.noarch

Hmmmmmmmm....

Looking at ftp://mirrors.kernel.org/fedora/development/i386/Packages:
no rpm for "python-iniparse"!

Looking on some other mirrors I couldn't find python-iniparse or I only found the old version 0.2.4. Tried to install this old one from switch with "rpm -vhiftp://mirror.switch.ch/mirror/fedora/linux/releases/test/11-Alpha/Fedora/i386/os/Packages/python-iniparse-0.2.4-1.fc11.noarch.rpm"

After that it started working again ...
Comment 4 Tim Lauridsen 2009-03-03 08:32:44 EST
Look like rawhide has not hit all the mirrors yet

Check this for info about getting the updated python-iniparse from koji
https://bugzilla.redhat.com/show_bug.cgi?id=487963#c2
Comment 5 Thomas Schweikle 2009-03-03 16:44:26 EST
What ist buggin me a bit is, that yum did not realy install 0.3.0, but reporting it being installed, while rpm reported 0.2.4, but not 0.3.0!

There seems to be a difference in how yum finds the version versus how rpm finds the installed version. Sometimes this leads to an inconsistent system.
I tested my system for further differences in versions yum ./. rpm sees and found some more. Most of them not being fatal in any way, some broke applications. It could be difficult to find out why yum refuses to install a pacakge, while rpm reorts the old one installed ...!

Note You need to log in before you can comment on or make changes to this bug.