This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 487976 - anaconda 11.5.0.23 failing
anaconda 11.5.0.23 failing
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pyparted (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-01 17:43 EST by Matthieu Araman
Modified: 2009-03-07 12:19 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-02 09:23:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthieu Araman 2009-03-01 17:43:55 EST
Description of problem:
Can't install with latest rawhide.
Can't even do a rescue mode.

Version-Release number of selected component (if applicable):
using boot.iso /cdrom from rawhide 20090227 8h00
Anaconda 11.5.0.23

How reproducible:
Always

Steps to Reproduce:
1. boot 
2. select install or rescue mode
3. install process launch anaconda 
  
Actual results:
anaconda exit and the system ask for reboot
same thing with normal install or even rescue mode

Expected results:
should run

Additional info:
I could initialy install a system succesfully on this pc with the Fedora 11 alpha dvd x64. 
the pc has two 1To Disk configured with Linux raid in mirroring mode.
partition :
/dev/md0  -> /boot ext3 200MB
/dev/md1 : the reste
/dev/md1 contain :
LVM  
only a part of /dev/md1 is allocated
there are 4 partitions : 
/ (ext4) , /home(ext4) ,/var(ext4) and swap

The Fedora 11 alpha broke after a rawhide update and a reboot.
looks like there was a problem finding md0 or /  

So I tried to reinstall completely with a recent rawhide boot.iso and got stuck by this.

Error message

anaconda 11.5.0.23
Traceback (most recent call last):
 File "/usr/bin/anaconda", line 622, in <module>
   from exception import handleException
 File "/usr/lib/anaconda/exception.py", line 38, in <module>
   import partedUtils
 File "/usr/lib/anaconda/partedUtils.py", line 29
   import parted
 File "/usr/lib64/python2.6/site-packages/parted/__init__.py", line 46, in <module>
   from disk import Disk
 File "/usr/lib64/python2.6/site-packages/parted/disk.py", line 27, in <module> from cachedlist import CachedList
ImportError: No module named cachedlist
install exited abnormally [1/1]
Comment 1 Chris Lumens 2009-03-02 09:23:53 EST
This is fixed in the current build of pyparted.  Please update your tree and it should be working for you.
Comment 2 Matthieu Araman 2009-03-02 17:18:43 EST
I can't find a more recent boot.iso in any of the active fedora mirrors.(I think I tried at least 10 different...)
looks like they either don't mirror rawhide, have excluded the images directory or have a low frequency update.
Do you know any mirror really mirroring rawhide with fresh thing ?
In the negative, I will wait for several more days until updated thing reach the mirrors...
Comment 3 Matthieu Araman 2009-03-07 12:19:51 EST
found a more recent boot.iso from 20090306
I don't knwow if this is fixed as I'm now stuck with another message from pyparted, for which I opened bug 489105

Note You need to log in before you can comment on or make changes to this bug.