Bug 489105 - Can't install rawhide 20090306 on a pc with usb multi card reader
Can't install rawhide 20090306 on a pc with usb multi card reader
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pyparted (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-07 12:17 EST by Matthieu Araman
Modified: 2009-03-30 07:10 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-30 07:10:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthieu Araman 2009-03-07 12:17:38 EST
Description of problem:
anaconda/pyparted tries to access virtual partition of usb card reader and stuck on it (there's no card in the slots)

Version-Release number of selected component (if applicable):
boot.iso from 20090306

How reproducible:
100%

Steps to Reproduce:
1. download boot.iso rawhide 20090306
2. use a pc with two sata disk and a usb/multi card reader internally connected
3. launch install
  
Actual results:
error after detecting partition 
error include 
File "/usr/lib64/python2.6/site-packages/parted/device.py", line 48, in __init__
self.__device = _ped.device_get(path)
_ped.DeviceException: Could not find device for path /dev/sdc

sda and sdb are the two real hard disk

dmesg extract gives
usb-storage: device scan complete
scsi 4:0:0:0: Direct-Access    Generic  USB SD Reader    1.00 PQ: 0 ANSI: 0
scsi 4:0:0:1: Direct-Access    Generic  USB CF Reader    1.01 PQ: 0 ANSI: 0
scsi 4:0:0:2: Direct-Access    Generic  USB SM Reader    1.02 PQ: 0 ANSI: 0
scsi 4:0:0:3: Direct-Access    Generic  USB MS Reader    1.03 PQ: 0 ANSI: 0
sd 4:0:0:0: [sdc] Attached SCSI removable disk
sd 4:0:0:0: Attached scsi generic sg3 type 0
sd 4:0:0:1: [sdd] Attached SCSI removable disk
sd 4:0:0:1: Attached scsi generic sg4 type 0
sd 4:0:0:2: [sde] Attached SCSI removable disk
sd 4:0:0:2: Attached scsi generic sg5 type 0
sd 4:0:0:3: [sdf] Attached SCSI removable disk
sd 4:0:0:3: Attached scsi generic sg6 type 0

There is no card inside the reader

Expected results:
should be able to install rawhide on a pc with card reader!

Additional info:
same setup than bug 487976
Comment 1 Matthieu Araman 2009-03-07 13:25:29 EST
I removed the card reader and the message disappeared 
I can now go further in the installation process but I'm stuck by ther unrelated bug 488987
Comment 2 Matthieu Araman 2009-03-16 19:02:52 EDT
I did another try and replicate it with a recent build and uploaded an automatic trace to bugzilla.
It was automatically added to bug 489918, which is a duplicate of bug 488800.
So may be they are related.
Comment 3 Matthieu Araman 2009-03-30 07:10:00 EDT
looks fixed, with anaconda from 20090326 boot.iso.
I can go completely through the installation without unplugging my usb card reader.

Note You need to log in before you can comment on or make changes to this bug.