Bug 488091 - Files in tetex-perltex conflict with files in texlive-texmf-latex in rawhide
Files in tetex-perltex conflict with files in texlive-texmf-latex in rawhide
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: tetex-perltex (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
: 502200 502202 (view as bug list)
Depends On:
Blocks: F12Blocker/F12FinalBlocker
  Show dependency treegraph
 
Reported: 2009-03-02 11:21 EST by Jonathan Kamens
Modified: 2009-11-18 09:07 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-27 21:25:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2009-03-02 11:21:22 EST
$ sudo yum update tetex-perltex texlive-texmf-latex
...
================================================================================
 Package                   Arch         Version             Repository     Size
================================================================================
Updating:
 tetex-perltex             noarch       1.7-2.fc11          rawhide       253 k
 texlive-texmf-latex       noarch       2007-28.fc11        rawhide       6.1 M
Updating for dependencies:
 texlive-texmf             noarch       2007-28.fc11        rawhide       3.5 M
 texlive-texmf-afm         noarch       2007-28.fc11        rawhide       6.3 M
 texlive-texmf-dvips       noarch       2007-28.fc11        rawhide       391 k
 texlive-texmf-fonts       noarch       2007-28.fc11        rawhide        57 M

Transaction Summary
================================================================================
Install      0 Package(s)         
Update       6 Package(s)         
Remove       0 Package(s)         

Total size: 73 M
Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test


Transaction Check Error:
  file /usr/share/texmf/dvipdfm/config/config from install of texlive-texmf-2007-28.fc11.noarch conflicts with file from package dvipdfm-0.13.2d-39.fc10.i386
  file /usr/share/texmf/doc/latex/perltex/perltex.pdf from install of tetex-perltex-1.7-2.fc11.noarch conflicts with file from package texlive-texmf-doc-2007-26.fc10.noarch
  file /usr/share/texmf/tex/latex/bytefield/bytefield.sty from install of texlive-texmf-latex-2007-28.fc11.noarch conflicts with file from package tetex-bytefield-1.2a-4.fc10.noarch
  file /usr/share/texmf/tex/latex/prosper/PPRalienglow.sty from install of texlive-texmf-latex-2007-28.fc11.noarch conflicts with file from package tetex-prosper-1.5-4.fc10.noarch
  file /usr/share/texmf/tex/latex/prosper/PPRautumn.sty from install of texlive-texmf-latex-2007-28.fc11.noarch conflicts with file from package tetex-prosper-1.5-4.fc10.noarch
  file /usr/share/texmf/tex/latex/prosper/PPRazure.sty from install of texlive-texmf-latex-2007-28.fc11.noarch conflicts with file from package tetex-prosper-1.5-4.fc10.noarch
  file /usr/share/texmf/tex/latex/prosper/PPRcontemporain.sty from install of texlive-texmf-latex-2007-28.fc11.noarch conflicts with file from package tetex-prosper-1.5-4.fc10.noarch
  file /usr/share/texmf/tex/latex/prosper/PPRdarkblue.sty from install of texlive-texmf-latex-2007-28.fc11.noarch conflicts with file from package tetex-prosper-1.5-4.fc10.noarch
  file /usr/share/texmf/tex/latex/prosper/PPRdefault.sty from install of texlive-texmf-latex-2007-28.fc11.noarch conflicts with file from package tetex-prosper-1.5-4.fc10.noarch
  file /usr/share/texmf/tex/latex/prosper/PPRframes.sty from install of texlive-texmf-latex-2007-28.fc11.noarch conflicts with file from package tetex-prosper-1.5-4.fc10.noarch
  file /usr/share/texmf/tex/latex/prosper/PPRlignesbleues.sty from install of texlive-texmf-latex-2007-28.fc11.noarch conflicts with file from package tetex-prosper-1.5-4.fc10.noarch
  file /usr/share/texmf/tex/latex/prosper/PPRnuancegris.sty from install of texlive-texmf-latex-2007-28.fc11.noarch conflicts with file from package tetex-prosper-1.5-4.fc10.noarch
  file /usr/share/texmf/tex/latex/prosper/PPRtroispoints.sty from install of texlive-texmf-latex-2007-28.fc11.noarch conflicts with file from package tetex-prosper-1.5-4.fc10.noarch
  file /usr/share/texmf/tex/latex/prosper/prosper.cls from install of texlive-texmf-latex-2007-28.fc11.noarch conflicts with file from package tetex-prosper-1.5-4.fc10.noarch
  file /usr/share/texmf/tex/latex/perltex/perltex.sty conflicts between attempted installs of texlive-texmf-latex-2007-28.fc11.noarch and tetex-perltex-1.7-2.fc11.noarch
Comment 1 Jonathan Kamens 2009-03-02 11:22:58 EST
You can ignore the error messages there about obsolete packages; the relevant ones are the messages about texlive-texmf-latex and tetex-perltex, which are not obsolete and conflict with each other.
Comment 2 Jonathan Kamens 2009-03-02 11:25:55 EST
Actually, those errors aren't completely irrelevant.  I think they indicate dependency issues, since the packages that yum ended up installing should have had dependencies in them to pull in the newer versions of the other packages to fix the file conflicts.
Comment 3 Bug Zapper 2009-06-09 07:47:30 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Gregory Lee Bartholomew 2009-08-31 23:17:12 EDT
Bump -- I have a multilingual document that I would like to be able to compose with fontwrap. Fontwrap depends on this perltex package, however, which I cannot install because of this bug.
Comment 5 Jonathan Kamens 2009-10-25 23:03:03 EDT
I'm marking this an F12blocker, since I don't think F12 should ship with packages that can't be installed at the same time.  Please unmark if this doesn't meet the criteria.
Comment 6 Jonathan Kamens 2009-10-25 23:04:10 EDT
*** Bug 502200 has been marked as a duplicate of this bug. ***
Comment 7 Tom "spot" Callaway 2009-10-27 19:16:02 EDT
*** Bug 502202 has been marked as a duplicate of this bug. ***
Comment 8 Tom "spot" Callaway 2009-10-27 21:25:14 EDT
Fixed in F12, rawhide.

tetex-perltex was updated (it was rather outdated).
tetex-prosper and tetex-bytefield were Retired, since texlive-texmf-latex provides the same bits (texlive-texmf-latex now properly Provides/Obsoletes them).
Comment 9 Joel 2009-11-16 15:29:37 EST
Not fixed in F11.  Today's update yielded:

Total size: 380 M
Is this ok [y/N]: Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test


Transaction Check Error:
  file /usr/share/texmf/doc/latex/bytefield/bytefield.pdf from install of texlive-texmf-doc-2007-31.fc11.noarch conflicts with file from package tetex-bytefield-1.2a-5.fc11.noarch
  file /usr/share/texmf/tex/latex/bytefield/bytefield.sty from install of texlive-texmf-latex-2007-31.fc11.noarch conflicts with file from package tetex-bytefield-1.2a-5.fc11.noarch

Error Summary
-------------
Comment 10 Tom "spot" Callaway 2009-11-16 15:52:00 EST
It's fixed in F-12 and rawhide.
Comment 11 Joel 2009-11-16 15:58:20 EST
ITS BROKEN IN F-11!  For which borken packages 

  strace.x86_64 0:4.5.19-1.fc11                                 texlive.x86_64 0:2007-46.fc11                                 
  texlive-afm.x86_64 0:2007-46.fc11                             texlive-doc.x86_64 0:2007-46.fc11                             
  texlive-dvips.x86_64 0:2007-46.fc11                           texlive-dviutils.x86_64 0:2007-46.fc11                        
  texlive-latex.x86_64 0:2007-46.fc11                           texlive-texmf.noarch 0:2007-31.fc11                           
  texlive-texmf-afm.noarch 0:2007-31.fc11                       texlive-texmf-doc.noarch 0:2007-31.fc11                       
  texlive-texmf-dvips.noarch 0:2007-31.fc11                     texlive-texmf-fonts.noarch 0:2007-31.fc11                     
  texlive-texmf-latex.noarch 0:2007-31.fc11   

Were just foisted on us.  Those packages should have obsoleted the bytefiled stuff.

Do I need to file a F-11 bug?
Comment 12 Fedora Update System 2009-11-16 17:18:55 EST
tetex-perltex-1.9-1.fc11,texlive-texmf-2007-32.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/tetex-perltex-1.9-1.fc11,texlive-texmf-2007-32.fc11
Comment 13 Fedora Update System 2009-11-18 09:07:32 EST
tetex-perltex-1.9-1.fc11, texlive-texmf-2007-32.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.