Bug 488095 - aisexec assertion in message_handler_req_lib_cpg_mcast
aisexec assertion in message_handler_req_lib_cpg_mcast
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: openais (Show other bugs)
All Linux
high Severity high
: rc
: ---
Assigned To: Steven Dake
Cluster QE
Depends On:
Blocks: 489455
  Show dependency treegraph
Reported: 2009-03-02 11:54 EST by Alan Conway
Modified: 2016-04-26 11:56 EDT (History)
3 users (show)

See Also:
Fixed In Version: openais-0.80.5-4.el5_4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 489455 (view as bug list)
Last Closed: 2009-09-02 07:30:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Alan Conway 2009-03-02 11:54:33 EST
Description of problem:

aisexec crashes with this assertion:

aisexec: cpg.c:1106: message_handler_req_lib_cpg_mcast: Assertion `result == 0' 

Version-Release number of selected component (if applicable):
openais-0.80.5-2.el5 + patches provided by Steve Dake

Steps to Reproduce:

I reproduced on 4 nodes: mrg7,8.9,.10 lab.bos.redhat.com
I run a qpidd cluster on all nodes. Then on 1 node I run two 
qpidd tests concurrently in a loop:

while ~/qpid/cpp/src/tests/run_failover_soak ; do true; done
while benchmark; do true; done

benchmark is a script that alternates perftest and tsxtest with these parameters:

 perftest --nsub 4 --npub 4 --count 30000 -s
 tsxtest --rate 2000 --messages 5000 --run --report
Comment 1 Steven Dake 2009-03-10 11:46:21 EDT
Comment 5 errata-xmlrpc 2009-09-02 07:30:18 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.