Bug 489455 - aisexec assertion in message_handler_req_lib_cpg_mcast
aisexec assertion in message_handler_req_lib_cpg_mcast
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: openais (Show other bugs)
5.3
All Linux
high Severity high
: rc
: ---
Assigned To: Steven Dake
Cluster QE
:
Depends On: 488095
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-10 03:53 EDT by Steven Dake
Modified: 2016-04-26 10:00 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 488095
Environment:
Last Closed: 2009-03-10 09:36:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steven Dake 2009-03-10 03:53:43 EDT
+++ This bug was initially created as a clone of Bug #488095 +++

Description of problem:

aisexec crashes with this assertion:

aisexec: cpg.c:1106: message_handler_req_lib_cpg_mcast: Assertion `result == 0' 

Version-Release number of selected component (if applicable):
 
openais-0.80.5-2.el5 + patches provided by Steve Dake


Steps to Reproduce:

I reproduced on 4 nodes: mrg7,8.9,.10 lab.bos.redhat.com
I run a qpidd cluster on all nodes. Then on 1 node I run two 
qpidd tests concurrently in a loop:

while ~/qpid/cpp/src/tests/run_failover_soak ; do true; done
while benchmark; do true; done

benchmark is a script that alternates perftest and tsxtest with these parameters:

 perftest --nsub 4 --npub 4 --count 30000 -s
 tsxtest --rate 2000 --messages 5000 --run --report
Comment 1 Steven Dake 2009-03-10 09:35:31 EDT
incorrect process

Note You need to log in before you can comment on or make changes to this bug.