Bug 488173 - Package Review: ibus-table-erbi
Package Review: ibus-table-erbi
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Parag AN(पराग)
Fedora Extras Quality Assurance
: i18n
Depends On: 488010
Blocks: 484650
  Show dependency treegraph
 
Reported: 2009-03-02 19:11 EST by Caius Chance
Modified: 2009-05-20 01:38 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 488175 496757 (view as bug list)
Environment:
Last Closed: 2009-04-07 04:03:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
panemade: fedora‑review+
kevin: fedora‑cvs+


Attachments (Terms of Use)

  None (edit)
Description Caius Chance 2009-03-02 19:11:41 EST
+++ This bug was initially created as a clone of Bug #488172 +++

A split from ibus-table-chinese, which was sub-package of ibus-table.

Uploading srpm and spec.
Comment 1 Caius Chance 2009-04-02 01:48:04 EDT
SRPM URL:
http://cchance.fedorapeople.org/packaging/ibus-table-erbi-1.1.0.20090402-1.fc11.src.rpm
Spec URL: http://cchance.fedorapeople.org/packaging/ibus-table-erbi.spec
Description: A split from ibus-table-chinese, which was sub-package of
ibus-table.
Comment 2 Parag AN(पराग) 2009-04-03 01:44:03 EDT
Review:
+ package builds in mock (rawhide i586).
koji build => http://koji.fedoraproject.org/koji/taskinfo?taskID=1274696
+ rpmlint output for SRPM and for RPM.
ibus-table-erbi.noarch: E: zero-length /usr/share/doc/ibus-table-erbi-1.1.0.20090402/AUTHORS
==> can be fixed by removing AUTHORS file.

+ source files match upstream url
5b36a300b07cb6eb74be84f74ae63a4b  ibus-table-erbi-1.1.0.20090402.tar.gz
+ package meets naming and packaging guidelines.
+ specfile is properly named, is cleanly written
+ Spec file is written in American English.
+ Spec file is legible.
+ dist tag is present.
+ build root is correct.
+ license is open source-compatible.
+ License text is included in package.
+ BuildRequires are proper.
+ defattr usage is correct.
+ %clean is present.
+ package installed properly.
+ Macro use appears rather consistent.
+ Package contains code, not content.
+ no headers or static libraries.
+ no .pc file present.
+ no -devel subpackage
+ no .la files.
+ no translations are available.
+ Does owns the directories it creates.
+ ibus-table-createdb scriptlet used.
+ file permissions are appropriate.
+ Not a GUI App.  

Suggestions:
1) Drop AUTHORS files from %doc as rpmlint message reported as
ibus-table-erbi.noarch: E: zero-length /usr/share/doc/ibus-table-erbi-1.1.0.20090402/AUTHORS
2) try adding contents to Changelog file in upstream and add it as %doc
Comment 3 Caius Chance 2009-04-03 02:50:00 EDT
SRPM URL:
http://cchance.fedorapeople.org/packaging/ibus-table-erbi-1.1.0.20090403-1.fc11.src.rpm
Spec URL: http://cchance.fedorapeople.org/packaging/ibus-table-erbi.spec
Description: A split from ibus-table-chinese, which was sub-package of
ibus-table.
Comment 4 Caius Chance 2009-04-06 01:09:56 EDT
ping
Comment 5 Parag AN(पराग) 2009-04-06 01:26:51 EDT
Can you add Changelog as %doc as asked already in comment#2 ?
Comment 6 Caius Chance 2009-04-06 01:37:46 EDT
SRPM URL:
http://cchance.fedorapeople.org/packaging/ibus-table-erbi-1.1.0.20090403-2.fc11.src.rpm
Spec URL: http://cchance.fedorapeople.org/packaging/ibus-table-erbi.spec
Description: A split from ibus-table-chinese, which was sub-package of
ibus-table.
Comment 7 Parag AN(पराग) 2009-04-06 01:42:21 EDT
APPROVED.
Comment 8 Caius Chance 2009-04-06 02:09:17 EDT
 Package Name: ibus-table-erbi
 Short Description: Erbi input method for ibus-table
 Owners: cchance
 Branches: devel
 InitialCC: i18n-team
Comment 9 Jens Petersen 2009-04-06 03:34:04 EDT
What about search on license/origin of the Erbi table?
Comment 10 Parag AN(पराग) 2009-04-06 06:06:00 EDT
license is GPLv3+ from COPYING file as erbi_qs.txt file mentions only "GPL" license.
Comment 11 Jens Petersen 2009-04-06 22:48:53 EDT
cvs admin done
Comment 12 Parag AN(पराग) 2009-04-06 23:49:15 EDT
I too had discussion with upstream and he said correct license is GPLv2. Can you correct that in upstream tarball and then build new SRPM and import that in cvs as cvs module is ready now?
Comment 13 Caius Chance 2009-04-07 01:50:42 EDT
SRPM URL:
http://cchance.fedorapeople.org/packaging/ibus-table-erbi-1.1.0.20090407-1.fc11.src.rpm
Spec URL: http://cchance.fedorapeople.org/packaging/ibus-table-erbi.spec
Description: A split from ibus-table-chinese, which was sub-package of
ibus-table.
Comment 14 Caius Chance 2009-04-07 02:03:12 EDT
FYI it couldn't be built atm because dependency problems of its depending packages. Tested in mock.
Comment 15 Caius Chance 2009-04-07 02:28:34 EDT
SRPM URL:
http://cchance.fedorapeople.org/packaging/ibus-table-erbi-1.1.0.20090407-2.fc11.src.rpm
Spec URL: http://cchance.fedorapeople.org/packaging/ibus-table-erbi.spec
Description: A split from ibus-table-chinese, which was sub-package of
ibus-table.
Comment 16 Caius Chance 2009-04-07 04:03:10 EDT
built to rawhide
Comment 18 Caius Chance 2009-05-19 20:44:06 EDT
Package Change Request
======================
Package Name: ibus-table-erbi
New Branches: F-10
Owners: cchance
Comment 19 Kevin Fenzi 2009-05-20 01:38:10 EDT
cvs done.

Note You need to log in before you can comment on or make changes to this bug.