Bug 488182 - please update perl-XML-LibXML to 1.69_2
please update perl-XML-LibXML to 1.69_2
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: perl-XML-LibXML (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Marcela Mašláňová
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 490781
  Show dependency treegraph
 
Reported: 2009-03-02 21:14 EST by bruce
Modified: 2009-04-17 22:59 EDT (History)
3 users (show)

See Also:
Fixed In Version: 1.69-1.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-14 11:56:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description bruce 2009-03-02 21:14:59 EST
Description of problem:
Please update to release 1.69_2 of perl-XML-LibXML.
version 1.66 is over a year old and causes
difficult to isolate segfaults.
Note that you will also need to update
perl-XML-LibXSLT to 1.68

Version-Release number of selected component (if applicable):
1.66

How reproducible:
difficult... but not necessary.

Steps to Reproduce:
1. run a complex perl/XML application
2.
3.
  
Actual results:
segfaults (sometimes)
valgrind reports errors

Expected results:
no segfaults, valgrind happy.

Additional info:
Comment 1 Fedora Update System 2009-03-03 03:00:22 EST
perl-XML-LibXML-1.69-1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/perl-XML-LibXML-1.69-1.fc10
Comment 2 bruce 2009-03-03 03:21:55 EST
Thanks!

Is this actually version 1.69_2, or just 1.69
(the former incorporates a few more minor patches).

Also, will you also be updating perl-XML-LibXSLT
as well, or should I enter a separate request for that?

Thanks again!
Comment 3 Marcela Mašláňová 2009-03-03 03:32:30 EST
Yes, they must be updated both modules. These version are already in rawhide, but if you have trouble with F-10, I will update also F-10.
I suppose 1.69_2 is development version and 1.69 is the released version...
Comment 4 Fedora Update System 2009-03-13 14:38:57 EDT
perl-XML-LibXML-1.69-1.fc10, perl-XML-LibXSLT-1.68-1.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update perl-XML-LibXML perl-XML-LibXSLT'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-2660
Comment 5 Stepan Kasal 2009-03-18 09:58:05 EDT
(In reply to comment #2)
> Is this actually version 1.69_2, or just 1.69
> (the former incorporates a few more minor patches).

As Marcela explained, we prefer to wait for the maintainer until he declares that set of patches are mature by making a stable release.

If any of those patches fixes a problem that you experience, please tell us (e.g., by reopening this bug); we'll consider including that particular patch.
Comment 6 Fedora Update System 2009-03-18 15:00:33 EDT
perl-XML-LibXML-1.69-1.fc10, perl-XML-LibXSLT-1.68-3.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update perl-XML-LibXML perl-XML-LibXSLT'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-2660
Comment 7 Fedora Update System 2009-04-14 11:56:42 EDT
perl-XML-LibXML-1.69-1.fc10, perl-XML-LibXSLT-1.68-3.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 bruce 2009-04-17 22:59:46 EDT
got the upgrade; everything's fine now! Thanks!!

Note You need to log in before you can comment on or make changes to this bug.