Bug 490781 - Segfault in XML::LibXSLT due to reference counting bug
Segfault in XML::LibXSLT due to reference counting bug
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: perl-XML-LibXSLT (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Stepan Kasal
Fedora Extras Quality Assurance
:
Depends On: 488182
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-17 19:46 EDT by Jim Radford
Modified: 2009-09-25 15:04 EDT (History)
3 users (show)

See Also:
Fixed In Version: 1.69-1.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-18 09:49:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to fix reference counting bug in XML::LibXSLT 1.68 (1.16 KB, patch)
2009-03-17 19:46 EDT, Jim Radford
no flags Details | Diff

  None (edit)
Description Jim Radford 2009-03-17 19:46:18 EDT
Created attachment 335621 [details]
patch to fix reference counting bug in XML::LibXSLT 1.68

XML::LibXSLT has a reference counting bug that leads to segfaults.  There is an upstream bug report with no action, so I'm attaching a patch which fixes the bug.

   http://rt.cpan.org/Ticket/Display.html?id=40844

The patch is for 1.68 since it's in f10 testing, but the bug is also present in 1.66.
Comment 1 Stepan Kasal 2009-03-18 09:49:52 EDT
Fixed in perl-XML-LibXSLT-3, both in rawhide and (eventually) in F-10 updates.
Comment 2 Fedora Update System 2009-04-14 11:56:46 EDT
perl-XML-LibXML-1.69-1.fc10, perl-XML-LibXSLT-1.68-3.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 3 Jim Radford 2009-09-25 15:04:45 EDT
FYI, this patch has been applied upstream.

  https://rt.cpan.org/Public/Bug/Display.html?id=40844

Note You need to log in before you can comment on or make changes to this bug.