Bug 488332 - [enh] ifcfg-rh: handle routes-* files
[enh] ifcfg-rh: handle routes-* files
Status: CLOSED DUPLICATE of bug 507307
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-03 13:39 EST by Phillip Sorensen
Modified: 2010-07-22 08:30 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-22 08:30:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Phillip Sorensen 2009-03-03 13:39:12 EST
Description of problem:

Static routes placed in /etc/sysconfig/network-scripts/route-<interface> files are not added when the interface is added by NetworkManager.

Version-Release number of selected component (if applicable):
0.7.0-1.git20090102.fc10

How reproducible:
Alawys

Steps to Reproduce:
1. Create a route-eth0 file by hand or through system-config-network
2. Select the interface with NetworkManager
  
Actual results:
No static route


Expected results:
static routes added

Additional info:

I can make this work by addind a script to /etc/NetworkManager/dispatcher.d/
like this (found on a forum):

# START SCRIPT

##!/bin/bash

if [ -x /usr/bin/logger ]; then
	LOGGER="/usr/bin/logger -s -p user.notice -t NetworkManager"
else
	LOGGER=echo
fi

if [ ! -x /etc/sysconfig/network-scripts/ifup-routes ]; then
	$LOGGER "script ifup-routes missing or nor executable"
	return
fi
if [ -n $1 ] && [ $2 == "up" ]; then
	$LOGGER "adding statis routes for $1"
	/etc/sysconfig/network-scripts/ifup-routes $1
fi

# END SCRIPT
Comment 1 Albert Castillo 2009-09-28 13:54:33 EDT
The static route can also be added by using the "Routes" button in the Network Manager dialog windows. In any case, it still doesn't work and the static route is not added during cold boot.

But, from within Gnome, if you use network manager to disconnect and then connect to the same network, the static route is added correctly to the routing table. You can also restart the "Network" service and it will be added.

In my case, I have both the "Network" service enabled and Network manager is controlling the eth0 interface. I have a dual NIC and maybe this is related to the problem? My eth1 interface is disabled and not being used. I read somewhere on the net that there are problems related to using Network manager in a dual-NIC configuration.
Comment 2 Bug Zapper 2009-11-16 04:50:25 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Jirka Klimes 2009-11-22 19:26:14 EST
A patch adding route-<interface> handling functionality attached to
https://bugzilla.redhat.com/show_bug.cgi?id=507307
Comment 4 Jirka Klimes 2010-07-22 08:30:45 EDT

*** This bug has been marked as a duplicate of bug 507307 ***

Note You need to log in before you can comment on or make changes to this bug.