Bug 507307 - [enh] support routes in ifcfg files
[enh] support routes in ifcfg files
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
: 488332 networkmanager_route (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-22 05:46 EDT by Tomasz Torcz
Modified: 2010-07-22 08:30 EDT (History)
5 users (show)

See Also:
Fixed In Version: 0.7.2-2.git20091223.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-02 16:27:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Support for handling route-file by ifcfg-rh plugin (80.37 KB, patch)
2009-11-22 19:21 EST, Jirka Klimes
no flags Details | Diff

  None (edit)
Description Tomasz Torcz 2009-06-22 05:46:31 EDT
Description of problem:
I'm using NM with system configuration and permament IP addres for wired network. When I add additional routes for multicast (why isn't it added by default, BTW?), and reconnect interface, the route is applied. But when I go into connection editor again, the route is missing.

Version-Release number of selected component (if applicable):
NetworkManager-0.7.1-4.git20090414.fc11.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. Have static IP configured. Go into connection editor and add route "224.0.0.0/4"
2. Open nm applet and click edited connection. Use "ip r" to confirm that multicast route is added to interface.
3. Go into connection editor → additional routes.
  
Actual results:
Empty set of additional routes.

Expected results:
"224.0.0.0/4" added in step 1. should be there.

Additional info:
Comment 1 Tomasz Torcz 2009-11-20 03:36:20 EST
Enhancement? Inability to add multicast route breaks thing like NTP multicast and ZeroConf. I really think this should be little more prioritised.
Comment 2 Dan Williams 2009-11-20 17:06:25 EST
It is not a regression in NetworkManager itself since that functionality has never existed in NM.  It is a regression if you switch from the network service to NetworkManager and we fully expect to fix it.  But given that it's not a regression in NM itself, it's actually an enhancement request to support this feature.  That does not mean the issue is not important.
Comment 3 Jirka Klimes 2009-11-22 19:21:51 EST
Created attachment 372989 [details]
Support for handling route-file by ifcfg-rh plugin

The patch in the attachment adds the support for handling static routes to ifcfg-rh plugin. (just IPv4 now) 
It does that by handling standard route- files of initscripts. Both new and legacy syntax format are supported as described in sysconfig.txt (/usr/share/doc/initscripts-<ver>).
So that routes edited via the NM connection editor are not lost any more, but are stored into the route- file (and read from that as well).
Comment 4 Dan Williams 2009-12-07 18:09:21 EST
Thanks!

9e93924cca6c9f5f7fc6819babd9dd2771c1cc03 (master)
0fdbefa8736c318886e7e59ef27e5005054ac327 (0.7.x)

I had to fix one thing related to the 'make distcheck' (ensuring that we remove the rewritten routes file in that one test that reads in and writes back out routes) and also adding the new ifcfg- and route- files to the Makefile.am to ensure they show up in the source tarball.  Other than that, excellent work.
Comment 5 Fedora Update System 2009-12-08 03:23:31 EST
NetworkManager-0.7.997-1.fc12,ModemManager-0.2.997-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/NetworkManager-0.7.997-1.fc12,ModemManager-0.2.997-1.fc12
Comment 6 Fedora Update System 2009-12-09 23:24:07 EST
NetworkManager-0.7.997-1.fc12, ModemManager-0.2.997-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update NetworkManager ModemManager'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-13012
Comment 7 Fedora Update System 2009-12-14 17:49:05 EST
NetworkManager-0.7.997-2.git20091214.fc12,ModemManager-0.2.997-2.git20091214.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/NetworkManager-0.7.997-2.git20091214.fc12,ModemManager-0.2.997-2.git20091214.fc12
Comment 8 Fedora Update System 2009-12-15 20:08:37 EST
NetworkManager-0.7.997-2.git20091214.fc12, ModemManager-0.2.997-2.git20091214.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update NetworkManager ModemManager'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-13165
Comment 9 Fedora Update System 2009-12-17 23:26:35 EST
ModemManager-0.2.997-3.git20091216.fc12, NetworkManager-0.7.997-2.git20091214.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ModemManager NetworkManager'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-13165
Comment 10 Fedora Update System 2009-12-21 23:48:58 EST
ModemManager-0.2.997-4.git20091218.fc12, NetworkManager-0.7.997-2.git20091214.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ModemManager NetworkManager'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-13165
Comment 11 Fedora Update System 2009-12-23 14:27:47 EST
NetworkManager-0.7.2-2.git20091223.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/NetworkManager-0.7.2-2.git20091223.fc11
Comment 12 Fedora Update System 2009-12-24 15:40:08 EST
NetworkManager-0.7.2-2.git20091223.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update NetworkManager'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-13642
Comment 13 Fedora Update System 2010-01-02 16:27:16 EST
ModemManager-0.2.997-4.git20091218.fc12, NetworkManager-0.7.997-2.git20091214.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Fedora Update System 2010-01-02 16:30:13 EST
NetworkManager-0.7.2-2.git20091223.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 15 Dan Williams 2010-01-04 18:09:02 EST
*** Bug 546840 has been marked as a duplicate of this bug. ***
Comment 16 Jirka Klimes 2010-07-22 08:30:45 EDT
*** Bug 488332 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.