Bug 488349 - elisa won't launch, just throws a python stack trace
elisa won't launch, just throws a python stack trace
Status: CLOSED DUPLICATE of bug 429590
Product: Fedora
Classification: Fedora
Component: elisa (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Matthias Saou
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-03 15:25 EST by Adam Miller
Modified: 2009-03-04 05:26 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-04 05:26:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Miller 2009-03-03 15:25:27 EST
Description of problem: elisa fails to start, it appears to be missing a dependency


Version-Release number of selected component (if applicable): 0.3.2-1


How reproducible: Every attempt to run off a fresh install of F-10 + updates


Steps to Reproduce:
1. yum -y install elisa
2. run 'elisa' from a terminal window
3. see the python stack trace
  
Actual results:
python stack trace

Expected results:
elisa to run

Additional info:
Python stack trace:
[adam@f10build ~]$ elisa 
Traceback (most recent call last):
  File "/usr/bin/elisa", line 8, in <module>
    load_entry_point('elisa==0.3.2', 'gui_scripts', 'elisa')()
  File "/usr/lib/python2.5/site-packages/pkg_resources.py", line 277, in load_entry_point
    return get_distribution(dist).load_entry_point(group, name)
  File "/usr/lib/python2.5/site-packages/pkg_resources.py", line 2180, in load_entry_point
    return ep.load()
  File "/usr/lib/python2.5/site-packages/pkg_resources.py", line 1913, in load
    entry = __import__(self.module_name, globals(),globals(), ['__name__'])
  File "/usr/lib/python2.5/site-packages/elisa/core/application.py", line 48, in <module>
    from twisted.web import client
ImportError: No module named web


It appears to need to depend on the package twisted-web.
Comment 1 Matthias Saou 2009-03-04 05:26:42 EST

*** This bug has been marked as a duplicate of bug 429590 ***

Note You need to log in before you can comment on or make changes to this bug.