Bug 488358 - Create supplemental cert infrastructure for hwcatalog
Create supplemental cert infrastructure for hwcatalog
Status: CLOSED DUPLICATE of bug 446164
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Hardware Catalog (Show other bugs)
5.3
All Linux
medium Severity medium
: ---
: ---
Assigned To: XINSUN
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-03 16:36 EST by Gary Case
Modified: 2009-03-04 13:17 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-04 13:17:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gary Case 2009-03-03 16:36:36 EST
Description of problem:

The current method of certification requires supplemental certs to add new/previously untested hardware support to existing certified systems. Once created, there's no easy way to link the supplemental certs to their existing parent systems. I propose that we include an "Add Supplemental Certification" section, similar to the existing "Clone Certification" section, to every closed cert, and change the name of the current "Internal Relationships" field that tracks supplemental certs to "Supplemental Certifications". The "Add Supplemental Certification" section should include a button to create the supplemental cert, a field to describe the purpose of the supplemental cert and an optional field to upload a supplemental results package. Upon clicking the button, BZ would create a new cert entry, copying the Vendor, Make, Model and URL of the original, it would add the description field as a comment, attach the optional package as a results package and link the parent and supplemental cert. 

What would also be helpful is if the supplemental certs were inherited by clones. That way, when you viewed a cloned cert, you could see the supplemental certs linked to its parent cert.
Comment 1 Rob Landry 2009-03-04 13:17:27 EST

*** This bug has been marked as a duplicate of bug 446164 ***

Note You need to log in before you can comment on or make changes to this bug.