Bug 488419 - ntop : Conflicts with other packages
ntop : Conflicts with other packages
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ntop (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Rakesh Pandit
Fedora Extras Quality Assurance
:
: 488413 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-04 04:29 EST by Michael Schwendt
Modified: 2009-03-06 01:53 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-05 08:32:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2009-03-04 04:29:55 EST
=> ntop-3.3.9-1.fc11.src.rpm
=> ntop-3.3.9-1.fc11.i586 in rawhide-development-i386
  File conflict with: GeoIP-1.4.5-3.fc11.i586
     /usr/bin/geoiplookup
     /usr/bin/geoiplookup6
     /usr/bin/geoipupdate
     /usr/lib/libGeoIPUpdate.so.0.0.0
     /usr/share/GeoIP/GeoIP.dat
     /usr/share/man/man1/geoiplookup.1.gz
     /usr/share/man/man1/geoipupdate.1.gz
Comment 1 Kevin Kofler 2009-03-04 18:51:39 EST
This should Requires: GeoIP instead of duplicating its huge data (as well as its binaries and library).
Comment 2 Peter Vrabec 2009-03-05 07:57:58 EST
Hi, I have built another update - ntop-3_3_9-3_fc11. The good thing is that it requires GeoIP package, but on the other side I had to include GeoLiteCity.dat and GeoIPASNum.dat. Rakesh mentioned that there might be some problems with that 


1. legal issues - http://geolite.maxmind.com/download/geoip/database/LICENSE.txt
lets ask fedora legal

2. files are to big 
I'm not sure it's such a problem, what I don't like is that they are placed in /etc/ntop. /usr/share/ntop would be better place I guess.

Anyway, I hope that problem reported in this bz is resolved.
Comment 3 Rakesh Pandit 2009-03-05 08:21:17 EST
You may like to close this bug I have opened a new one for these issues:
https://bugzilla.redhat.com/show_bug.cgi?id=488717

To 1 I wanted to add that .. contents of .dat files needs to be verified with legal also.
Comment 4 Rakesh Pandit 2009-03-06 01:53:58 EST
*** Bug 488413 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.